aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomebuild
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-10-16 15:54:11 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-10-16 15:54:11 +0000
commit0e5d616650ec21f1110b5f1bbadcf5c8c78348cb (patch)
tree8e1753e5cc373ca7d5440f10ce8654697710b984 /devel/gnomebuild
parentc30cb1f3d81621acf742dcf8f7aebcad2d176adb (diff)
downloadports-0e5d616650ec21f1110b5f1bbadcf5c8c78348cb.tar.gz
ports-0e5d616650ec21f1110b5f1bbadcf5c8c78348cb.zip
Update to 0.1.0.
Notes
Notes: svn path=/head/; revision=91436
Diffstat (limited to 'devel/gnomebuild')
-rw-r--r--devel/gnomebuild/Makefile14
-rw-r--r--devel/gnomebuild/distinfo2
-rw-r--r--devel/gnomebuild/files/patch-Makefile.in14
-rw-r--r--devel/gnomebuild/files/patch-configure10
-rw-r--r--devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-build.c13
-rw-r--r--devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-project.c17
-rw-r--r--devel/gnomebuild/files/patch-src::controls::Makefile.in14
-rw-r--r--devel/gnomebuild/files/patch-src::gbf::Makefile.in32
-rw-r--r--devel/gnomebuild/pkg-plist79
9 files changed, 117 insertions, 78 deletions
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 7f21736ed351..39403ffdaa4b 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomebuild
-PORTVERSION= 0.0.2
-PORTREVISION= 1
-CATEGORIES?= devel gnome
+PORTVERSION= 0.1.0
+CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/gnome/gnome-/}/0.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/gnome/gnome-/}/0.1
DISTNAME= ${PORTNAME:S/gnome/gnome-/}-${PORTVERSION}
MAINTAINER?= gnome@FreeBSD.org
@@ -18,14 +17,13 @@ COMMENT= A GNOME Build Framework (GBF)
LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
-IGNORE= "Broken for now; to be updated after GNOME 2.4 is released"
-
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomevfs bonobo libglade gal gtkhtml
+USE_GNOME= gnomeprefix gnomehack gnometarget libgnomeui gnomevfs2
USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib -lgnuregex"
.include <bsd.port.mk>
diff --git a/devel/gnomebuild/distinfo b/devel/gnomebuild/distinfo
index dba874ee1628..41939fb14fd5 100644
--- a/devel/gnomebuild/distinfo
+++ b/devel/gnomebuild/distinfo
@@ -1 +1 @@
-MD5 (gnome-build-0.0.2.tar.bz2) = b11ea327dfec58a80b62c1ef41f3f889
+MD5 (gnome-build-0.1.0.tar.bz2) = eb3d68c661f2ff0f92bb97ab14749805
diff --git a/devel/gnomebuild/files/patch-Makefile.in b/devel/gnomebuild/files/patch-Makefile.in
deleted file mode 100644
index 880769f21307..000000000000
--- a/devel/gnomebuild/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in 2001/07/24 11:40:27 1.1
-+++ Makefile.in 2001/07/24 11:40:57
-@@ -148,7 +148,7 @@
-
- SUBDIRS = po intl src idl
-
--confexecdir = $(libdir)
-+confexecdir = $(sysconfdir)
- confexec_DATA = gnome_buildConf.sh
-
- bin_SCRIPTS = gnome-build-clean.sh
diff --git a/devel/gnomebuild/files/patch-configure b/devel/gnomebuild/files/patch-configure
new file mode 100644
index 000000000000..2c2719fb4163
--- /dev/null
+++ b/devel/gnomebuild/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Oct 16 11:43:53 2003
++++ configure Thu Oct 16 11:44:25 2003
+@@ -19321,6 +19321,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-build.c b/devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-build.c
new file mode 100644
index 000000000000..4c8380eb3706
--- /dev/null
+++ b/devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-build.c
@@ -0,0 +1,13 @@
+--- src/backends/libgbf_am/gbf-am-build.c.orig Thu Oct 16 11:34:19 2003
++++ src/backends/libgbf_am/gbf-am-build.c Thu Oct 16 11:35:42 2003
+@@ -27,9 +27,9 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <string.h>
+-#include <regex.h>
+ #include "gbf-i18n.h"
+ #include "gbf-am-build.h"
++#include <gnuregex.h>
+
+ /* FIXME: mark strings for translation and this file to POTFILES.in */
+
diff --git a/devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-project.c b/devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-project.c
deleted file mode 100644
index 08a428958f4c..000000000000
--- a/devel/gnomebuild/files/patch-src::backends::libgbf_am::gbf-am-project.c
+++ /dev/null
@@ -1,17 +0,0 @@
-
-$FreeBSD$
-
---- src/backends/libgbf_am/gbf-am-project.c 2001/07/24 11:44:39 1.1
-+++ src/backends/libgbf_am/gbf-am-project.c 2001/07/24 11:46:14
-@@ -33,6 +33,11 @@
- #include "../../lib/gnome-build.h"
- #include "gbf-am-project.h"
-
-+#ifdef __FreeBSD__
-+extern char **environ;
-+#define __environ environ
-+#endif
-+
- #define SCRIPT_NAME "gbf-am-parse"
- #define BUILD_SCRIPT_NAME "gbf-am-build"
-
diff --git a/devel/gnomebuild/files/patch-src::controls::Makefile.in b/devel/gnomebuild/files/patch-src::controls::Makefile.in
deleted file mode 100644
index 57bbd3e251e6..000000000000
--- a/devel/gnomebuild/files/patch-src::controls::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/controls/Makefile.in 2002/03/15 08:29:51 1.1
-+++ src/controls/Makefile.in 2002/03/15 08:30:37
-@@ -145,7 +145,7 @@
- cxxflags_set = @cxxflags_set@
- l = @l@
-
--INCLUDES = -I$(includedir) -I$(top_srcdir)/src/lib/ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DGBF_DATADIR=\""$(datadir)"\" $(GNOME_INCLUDEDIR) $(OAF_CFLAGS) $(BONOBO_CFLAGS) $(BONOBOX_CFLAGS) $(GNOME_VFS_CFLAGS) $(GTKHTML_CFLAGS) $(GAL_CFLAGS) $(GDL_CFLAGS)
-+INCLUDES = -I$(includedir) -I$(top_srcdir)/src/lib/ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DGBF_DATADIR=\""$(datadir)"\" $(GNOME_INCLUDEDIR) $(OAF_CFLAGS) $(BONOBO_CFLAGS) $(BONOBOX_CFLAGS) @VFS_CFLAGS@ $(GTKHTML_CFLAGS) $(GAL_CFLAGS) $(GDL_CFLAGS)
-
-
- CFLAGS = @CFLAGS@ -DGNOME_DATADIR=\""$(datadir)"\"
diff --git a/devel/gnomebuild/files/patch-src::gbf::Makefile.in b/devel/gnomebuild/files/patch-src::gbf::Makefile.in
new file mode 100644
index 000000000000..c8648653d8f1
--- /dev/null
+++ b/devel/gnomebuild/files/patch-src::gbf::Makefile.in
@@ -0,0 +1,32 @@
+--- src/gbf/Makefile.in.orig Thu Oct 16 11:32:14 2003
++++ src/gbf/Makefile.in Thu Oct 16 11:32:38 2003
+@@ -701,18 +701,18 @@
+ uninstall-libgbfincludeHEADERS uninstall-pixmapDATA
+
+
+-libgbfmarshal.h: $(srcdir)/libgbfmarshal.list $(GLIB_GENMARSHAL)
+- @GLIB_GENMARSHAL@ \
+- --prefix=gbf_marshal $(srcdir)/libgbfmarshal.list --header > xgen-gmc \
+- && cp xgen-gmc $(@F) \
+- && rm -f xgen-gmc
++#libgbfmarshal.h: $(srcdir)/libgbfmarshal.list $(GLIB_GENMARSHAL)
++# @GLIB_GENMARSHAL@ \
++# --prefix=gbf_marshal $(srcdir)/libgbfmarshal.list --header > xgen-gmc \
++# && cp xgen-gmc $(@F) \
++# && rm -f xgen-gmc
+
+-libgbfmarshal.c: $(srcdir)/libgbfmarshal.list $(GLIB_GENMARSHAL)
+- echo "#include \"libgbfmarshal.h\"" > xgen-gmc \
+- && @GLIB_GENMARSHAL@ \
+- --prefix=gbf_marshal $(srcdir)/libgbfmarshal.list --body >> xgen-gmc \
+- && cp xgen-gmc $(@F) \
+- && rm -f xgen-gmc
++#libgbfmarshal.c: $(srcdir)/libgbfmarshal.list $(GLIB_GENMARSHAL)
++# echo "#include \"libgbfmarshal.h\"" > xgen-gmc \
++# && @GLIB_GENMARSHAL@ \
++# --prefix=gbf_marshal $(srcdir)/libgbfmarshal.list --body >> xgen-gmc \
++# && cp xgen-gmc $(@F) \
++# && rm -f xgen-gmc
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/devel/gnomebuild/pkg-plist b/devel/gnomebuild/pkg-plist
index 40420acbaeaf..b738ab463d70 100644
--- a/devel/gnomebuild/pkg-plist
+++ b/devel/gnomebuild/pkg-plist
@@ -1,27 +1,58 @@
-bin/gbf-am-build
bin/gbf-am-parse
-bin/gbf-am-project
-bin/gbf-controls-server
-bin/gnome-build-clean.sh
-etc/gnome_buildConf.sh
-include/gbf/gbf-build-info.h
-include/gbf/gbf-project-client.h
-include/gbf/gbf-project-tree.h
-include/gbf/gbf-target-tree.h
-include/gbf/gbf-widgets.h
-include/gbf/gbf.h
-include/gbf/gnome-build.h
-lib/libgbf-widgets.a
-lib/libgbf-widgets.so
-lib/libgbf-widgets.so.0
-lib/libgbf.a
-lib/libgbf.so
-lib/libgbf.so.0
-share/gnome/idl/gbf-project.idl
-share/gnome/idl/gnome-build.idl
-share/gnome/oaf/GNOME_Development_BuildControls.oaf
-share/gnome/oaf/GNOME_Development_Project_Automake.oaf
+include/gnome-build-1.0/gbf/gbf-backend.h
+include/gnome-build-1.0/gbf/gbf-build-info.h
+include/gnome-build-1.0/gbf/gbf-project-model.h
+include/gnome-build-1.0/gbf/gbf-project-util.h
+include/gnome-build-1.0/gbf/gbf-project-view.h
+include/gnome-build-1.0/gbf/gbf-project.h
+include/gnome-build-1.0/gbf/gbf-tree-data.h
+include/gnome-build-1.0/gbf/gbf-widgets.h
+include/gnome-build-1.0/gbf/glue-plugin.h
+lib/gnome-build-1.0/backends/gbf-am.server
+lib/gnome-build-1.0/backends/libgbf-am.a
+lib/gnome-build-1.0/backends/libgbf-am.so
+lib/gnome-build-1.0/backends/libgbf-am.so.0
+lib/libgbf-1.a
+lib/libgbf-1.so
+lib/libgbf-1.so.0
+lib/libgbf-widgets-1.a
+lib/libgbf-widgets-1.so
+lib/libgbf-widgets-1.so.0
+libdata/pkgconfig/gnome-build-1.0.pc
+share/gnome/gnome-build/GBF/AmFiles.pm
+share/gnome/gnome-build/GBF/General.pm
+share/gnome/gnome-build/glade/create_dialogs.glade
share/gnome/pixmaps/gbf-build.png
share/gnome/pixmaps/gbf-install.png
-share/gnome/ui/gbf-tree.xml
-@dirrm include/gbf
+share/locale/am/LC_MESSAGES/gbf-1.mo
+share/locale/az/LC_MESSAGES/gbf-1.mo
+share/locale/be/LC_MESSAGES/gbf-1.mo
+share/locale/ca/LC_MESSAGES/gbf-1.mo
+share/locale/cs/LC_MESSAGES/gbf-1.mo
+share/locale/de/LC_MESSAGES/gbf-1.mo
+share/locale/el/LC_MESSAGES/gbf-1.mo
+share/locale/es/LC_MESSAGES/gbf-1.mo
+share/locale/fr/LC_MESSAGES/gbf-1.mo
+share/locale/it/LC_MESSAGES/gbf-1.mo
+share/locale/ja/LC_MESSAGES/gbf-1.mo
+share/locale/lv/LC_MESSAGES/gbf-1.mo
+share/locale/mk/LC_MESSAGES/gbf-1.mo
+share/locale/ml/LC_MESSAGES/gbf-1.mo
+share/locale/nl/LC_MESSAGES/gbf-1.mo
+share/locale/no/LC_MESSAGES/gbf-1.mo
+share/locale/pl/LC_MESSAGES/gbf-1.mo
+share/locale/pt/LC_MESSAGES/gbf-1.mo
+share/locale/pt_BR/LC_MESSAGES/gbf-1.mo
+share/locale/ru/LC_MESSAGES/gbf-1.mo
+share/locale/sk/LC_MESSAGES/gbf-1.mo
+share/locale/sr/LC_MESSAGES/gbf-1.mo
+share/locale/sr@Latn/LC_MESSAGES/gbf-1.mo
+share/locale/sv/LC_MESSAGES/gbf-1.mo
+share/locale/vi/LC_MESSAGES/gbf-1.mo
+@dirrm share/gnome/gnome-build/glade
+@dirrm share/gnome/gnome-build/GBF
+@dirrm share/gnome/gnome-build
+@dirrm lib/gnome-build-1.0/backends
+@dirrm lib/gnome-build-1.0
+@dirrm include/gnome-build-1.0/gbf
+@dirrm include/gnome-build-1.0