aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomevfs
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /devel/gnomevfs
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Notes
Notes: svn path=/head/; revision=62821
Diffstat (limited to 'devel/gnomevfs')
-rw-r--r--devel/gnomevfs/Makefile24
-rw-r--r--devel/gnomevfs/pkg-plist4
2 files changed, 8 insertions, 20 deletions
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index 0e6e1a2e64dd..1775fc998cf0 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -16,37 +16,29 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
-RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
+ gnomemimedata gnomelibs
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
- @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
-
-post-patch:
- @${PERL} -pi -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/libcharset/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/gnomevfs/pkg-plist b/devel/gnomevfs/pkg-plist
index beba41f47813..ec29ffe212d7 100644
--- a/devel/gnomevfs/pkg-plist
+++ b/devel/gnomevfs/pkg-plist
@@ -111,10 +111,6 @@ share/locale/tr/LC_MESSAGES/gnome-vfs.mo
share/locale/uk/LC_MESSAGES/gnome-vfs.mo
share/locale/wa/LC_MESSAGES/gnome-vfs.mo
share/locale/zh_TW/LC_MESSAGES/gnome-vfs.mo
-@dirrm lib/vfs/modules
@dirrm lib/vfs/extfs
@dirrm include/gnome-vfs-1.0/libgnomevfs
@dirrm include/gnome-vfs-1.0
-@dirrm etc/vfs/modules
-@dirrm etc/vfs
-@unexec /bin/rmdir %D/lib/vfs 2>/dev/null || /usr/bin/true