aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomevfs
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-11-30 18:15:57 +0000
committerAde Lovett <ade@FreeBSD.org>2000-11-30 18:15:57 +0000
commit69fdfd600a387ebde6f426f5cba66898bd528c14 (patch)
treecf80231d63df1a0229d3602daeb10b3ddbd366a9 /devel/gnomevfs
parent524adabce9706b0166173999ce69eeeebafd9a97 (diff)
downloadports-69fdfd600a387ebde6f426f5cba66898bd528c14.tar.gz
ports-69fdfd600a387ebde6f426f5cba66898bd528c14.zip
* Fix gnome-vfs-config: looking in wrong directory for vfsConf.sh
* Don't build the test programs, since they're not installed and are pretty much meaningless anyway Submitted by: sobomax
Notes
Notes: svn path=/head/; revision=35560
Diffstat (limited to 'devel/gnomevfs')
-rw-r--r--devel/gnomevfs/Makefile1
-rw-r--r--devel/gnomevfs/files/patch-ab27
-rw-r--r--devel/gnomevfs/files/patch-ag11
3 files changed, 35 insertions, 4 deletions
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index 75f12247da0f..1b8951876aab 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomevfs
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gnome-vfs
diff --git a/devel/gnomevfs/files/patch-ab b/devel/gnomevfs/files/patch-ab
index 2f95b5e5577f..0b8cc0137d1e 100644
--- a/devel/gnomevfs/files/patch-ab
+++ b/devel/gnomevfs/files/patch-ab
@@ -1,12 +1,31 @@
---- Makefile.in.orig Thu Nov 2 17:45:38 2000
-+++ Makefile.in Fri Nov 3 10:24:16 2000
-@@ -171,3 +171,3 @@
+--- Makefile.in.orig Wed Nov 29 15:02:07 2000
++++ Makefile.in Wed Nov 29 15:04:28 2000
+@@ -169,9 +169,9 @@
+ @USING_OAF_TRUE@SUBDIRS_OAF = libgnomevfs-corba
+ @USING_OAF_FALSE@SUBDIRS_OAF =
+ @PLATFORM_GNOME_2_TRUE@SUBDIRS_GNOME =
+-@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME = test mime-type-capplet
++@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME = mime-type-capplet
-SUBDIRS = libgnomevfs libgnomevfs-pthread $(SUBDIRS_OAF) idl modules data man devel-docs $(SUBDIRS_GNOME) po
+SUBDIRS = libgnomevfs libgnomevfs-pthread $(SUBDIRS_OAF) idl modules data man $(SUBDIRS_GNOME) po
-@@ -179,3 +179,3 @@
+
+ EXTRA_DIST = HACKING TODO autogen.sh gnome-vfs.spec vfsConf.sh.in vfscorbaConf.sh.in vfspthreadConf.sh.in gnome-vfs-config.in
+@@ -179,7 +179,7 @@
+
+ bin_SCRIPTS = $(top_builddir)/gnome-vfs-config
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = vfsConf.sh vfscorbaConf.sh vfspthreadConf.sh
+
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+@@ -539,6 +539,7 @@
+
+ gnome-vfs-config: gnome-vfs-config.in Makefile
+ sed -e 's?\@LIBDIR\@?$(libdir)?g' \
++ -e 's?\@SYSCONFDIR\@?$(sysconfdir)?g' \
+ -e 's?\@VFS_LIBDIR\@?$(VFS_LIBDIR)?g' \
+ -e 's?\@VFS_INCLUDEDIR\@?$(VFS_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
diff --git a/devel/gnomevfs/files/patch-ag b/devel/gnomevfs/files/patch-ag
new file mode 100644
index 000000000000..da795f940c50
--- /dev/null
+++ b/devel/gnomevfs/files/patch-ag
@@ -0,0 +1,11 @@
+--- gnome-vfs-config.in.orig Thu Aug 31 14:32:38 2000
++++ gnome-vfs-config.in Wed Nov 29 15:04:43 2000
+@@ -3,7 +3,7 @@
+ usage="\
+ Usage: gnome-vfs-config [--version] [--config] [--cflags] [--libs]"
+
+-config_file="@LIBDIR@/vfsConf.sh"
++config_file="@SYSCONFDIR@/vfsConf.sh"
+ . $config_file
+
+ if test $# -eq 0; then