aboutsummaryrefslogtreecommitdiff
path: root/devel/go-goregen
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2016-07-11 20:04:27 +0000
committerCarlo Strub <cs@FreeBSD.org>2016-07-11 20:04:27 +0000
commitf10587efd298619e1f732bb30e6df3ef112ddf9d (patch)
tree81a91886f70d801b790d53019cfbc1e9003a5125 /devel/go-goregen
parent5a62a7d924d62254423633495fe6a71d9b84815d (diff)
downloadports-f10587efd298619e1f732bb30e6df3ef112ddf9d.tar.gz
ports-f10587efd298619e1f732bb30e6df3ef112ddf9d.zip
A Golang library for generating random strings from regular expressions.
Notes
Notes: svn path=/head/; revision=418401
Diffstat (limited to 'devel/go-goregen')
-rw-r--r--devel/go-goregen/Makefile20
-rw-r--r--devel/go-goregen/distinfo3
-rw-r--r--devel/go-goregen/pkg-descr3
-rw-r--r--devel/go-goregen/pkg-plist13
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/go-goregen/Makefile b/devel/go-goregen/Makefile
new file mode 100644
index 000000000000..0a91a03c13bf
--- /dev/null
+++ b/devel/go-goregen/Makefile
@@ -0,0 +1,20 @@
+# Created by: Carlo Strub <cs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= goregen
+PORTVERSION= 20160303
+CATEGORIES= devel
+PKGNAMEPREFIX= go-
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= randexp for Go
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_ACCOUNT= zach-klippenstein
+GH_TAGNAME= 795b5e3961ea1912fde60af417ad85e86acc0d6a
+USES= go
+GO_PKGNAME= github.com/zach-klippenstein/goregen
+
+.include <bsd.port.mk>
diff --git a/devel/go-goregen/distinfo b/devel/go-goregen/distinfo
new file mode 100644
index 000000000000..288a16bcf8da
--- /dev/null
+++ b/devel/go-goregen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468219586
+SHA256 (zach-klippenstein-goregen-20160303-795b5e3961ea1912fde60af417ad85e86acc0d6a_GH0.tar.gz) = d2731d2ddb909515805b2be90a5d564f4fea1e9d0749d1fb6705567b416f573d
+SIZE (zach-klippenstein-goregen-20160303-795b5e3961ea1912fde60af417ad85e86acc0d6a_GH0.tar.gz) = 14627
diff --git a/devel/go-goregen/pkg-descr b/devel/go-goregen/pkg-descr
new file mode 100644
index 000000000000..b47a044b7510
--- /dev/null
+++ b/devel/go-goregen/pkg-descr
@@ -0,0 +1,3 @@
+A Golang library for generating random strings from regular expressions.
+
+WWW: https://github.com/zach-klippenstein/goregen
diff --git a/devel/go-goregen/pkg-plist b/devel/go-goregen/pkg-plist
new file mode 100644
index 000000000000..3795a4412f8e
--- /dev/null
+++ b/devel/go-goregen/pkg-plist
@@ -0,0 +1,13 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE.txt
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/char_class.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/generator_error.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/generator_error_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/internal_generator.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/regen.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/regen_benchmarks_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/regen_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/regexp_format.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/rng.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/rng_test.go