aboutsummaryrefslogtreecommitdiff
path: root/devel/googlemock
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-25 07:10:17 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-25 07:10:17 +0000
commit846bfb31dc0e1307c89ce5f80c9ef93827203ba4 (patch)
tree1122ce532eefaa0aaa9eabc67505fbe57b6f3bb7 /devel/googlemock
parent9c9c56a703f197d209f7296fb0846a1f5454767f (diff)
downloadports-846bfb31dc0e1307c89ce5f80c9ef93827203ba4.tar.gz
ports-846bfb31dc0e1307c89ce5f80c9ef93827203ba4.zip
devel/google{test,mock}: chase new home
Notes
Notes: svn path=/head/; revision=395218
Diffstat (limited to 'devel/googlemock')
-rw-r--r--devel/googlemock/Makefile25
-rw-r--r--devel/googlemock/distinfo6
-rw-r--r--devel/googlemock/pkg-descr2
3 files changed, 14 insertions, 19 deletions
diff --git a/devel/googlemock/Makefile b/devel/googlemock/Makefile
index 0ddd984a644a..eb1ae113d72e 100644
--- a/devel/googlemock/Makefile
+++ b/devel/googlemock/Makefile
@@ -3,22 +3,22 @@
PORTNAME= googlemock
PORTVERSION= 1.7.0
+DISTVERSIONPREFIX= release-
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE \
- https://googlemock.googlecode.com/svn-history/r407/trunk/scripts/:svn
-DISTNAME= gmock-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} gmock_doctor.py:svn
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Library for writing and using C++ mock classes
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= googletest>=1.7.0:${PORTSDIR}/devel/googletest
+BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_pthread.m4:${PORTSDIR}/devel/autoconf-archive \
+ googletest>=1.7.0:${PORTSDIR}/devel/googletest
LIB_DEPENDS= libgtest.so:${PORTSDIR}/devel/googletest
-USES= libtool shebangfix zip
+USE_GITHUB= yes
+GH_ACCOUNT= google
+
+USES= autoreconf libtool shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -33,14 +33,11 @@ OPTIONS_DEFINE= TEST
TEST_USES= python:2,build
TEST_ALL_TARGET=check
-post-extract:
-# XXX gmock_doctor.py is missing from distfile before r455 or 1.8.0
- ${CP} ${DISTDIR}/gmock_doctor.py ${WRKSRC}/scripts
-
post-patch:
-# enable vendor make install again (revert r562)
- ${REINPLACE_CMD} -E 's/ install-(exec|data)-local//' \
- ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} '/acx_pthread.m4/d' ${WRKSRC}/configure.ac
+# enable vendor make install again (revert 52277c9)
+ ${REINPLACE_CMD} -E 's/install-(exec|data)-local/&-dummy/' \
+ ${WRKSRC}/Makefile.am
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/gmock-config ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/googlemock/distinfo b/devel/googlemock/distinfo
index bf42fb29b8cb..96af375d199f 100644
--- a/devel/googlemock/distinfo
+++ b/devel/googlemock/distinfo
@@ -1,4 +1,2 @@
-SHA256 (gmock-1.7.0.zip) = 26fcbb5925b74ad5fc8c26b0495dfc96353f4d553492eb97e85a8a6d2f43095b
-SIZE (gmock-1.7.0.zip) = 2167746
-SHA256 (gmock_doctor.py) = 92a8eaf7f4c0716ecd9622b97d907e68d5eb63d6c89acbc1fc72d573d00fc47d
-SIZE (gmock_doctor.py) = 23590
+SHA256 (google-googlemock-release-1.7.0_GH0.tar.gz) = 3f20b6acb37e5a98e8c4518165711e3e35d47deb6cdb5a4dd4566563b5efd232
+SIZE (google-googlemock-release-1.7.0_GH0.tar.gz) = 296168
diff --git a/devel/googlemock/pkg-descr b/devel/googlemock/pkg-descr
index 6bdf4b75a53f..1944462efd40 100644
--- a/devel/googlemock/pkg-descr
+++ b/devel/googlemock/pkg-descr
@@ -8,4 +8,4 @@ for writing and using C++ mock classes. Google Mock:
* is extensible by users, and
* works on Linux, Windows, and Mac OS X.
-WWW: http://code.google.com/p/googlemock/
+WWW: https://github.com/google/googlemock