aboutsummaryrefslogtreecommitdiff
path: root/devel/googletest
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-10-14 08:01:13 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-10-14 08:01:13 +0000
commit356b28794d5187696b63d96225fdd4ddd46b63d5 (patch)
treeea943831b0da00ec64d014a5f9ed87bdd26f1d5d /devel/googletest
parent322ff1d62df163b57922ca46d6a18aee51869daa (diff)
downloadports-356b28794d5187696b63d96225fdd4ddd46b63d5.tar.gz
ports-356b28794d5187696b63d96225fdd4ddd46b63d5.zip
Google's framework for writing C++ tests on a variety of platforms
(Linux, Mac OS X, Windows, Cygwin, Windows CE, and Symbian). Based on the xUnit architecture. Supports automatic test discovery, a rich set of assertions, user-defined assertions, death tests, fatal and non-fatal failures, type-parameterized tests, various options for running the tests, and XML test report generation.
Notes
Notes: svn path=/head/; revision=221573
Diffstat (limited to 'devel/googletest')
-rw-r--r--devel/googletest/Makefile23
-rw-r--r--devel/googletest/distinfo3
-rw-r--r--devel/googletest/pkg-descr9
-rw-r--r--devel/googletest/pkg-plist25
4 files changed, 60 insertions, 0 deletions
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
new file mode 100644
index 000000000000..50852c92152a
--- /dev/null
+++ b/devel/googletest/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: googletest
+# Date created: Oct 14, 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= googletest
+PORTVERSION= 1.1.0
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= gtest-${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A framework for writing C++ tests on a variety of platforms
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+#regression-test:
+# cd ${WRKSRC}; ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/devel/googletest/distinfo b/devel/googletest/distinfo
new file mode 100644
index 000000000000..7e579d2f106b
--- /dev/null
+++ b/devel/googletest/distinfo
@@ -0,0 +1,3 @@
+MD5 (gtest-1.1.0.tar.gz) = bd4a018ebfab798f7f608f920f460936
+SHA256 (gtest-1.1.0.tar.gz) = 4dd99e57cc258b88a4d163bfc031d54b2806b76ee27f36a5ffe581ade8102c11
+SIZE (gtest-1.1.0.tar.gz) = 522308
diff --git a/devel/googletest/pkg-descr b/devel/googletest/pkg-descr
new file mode 100644
index 000000000000..921ebf6d5dad
--- /dev/null
+++ b/devel/googletest/pkg-descr
@@ -0,0 +1,9 @@
+Google's framework for writing C++ tests on a variety of platforms
+(Linux, Mac OS X, Windows, Cygwin, Windows CE, and Symbian).
+
+Based on the xUnit architecture. Supports automatic test discovery,
+a rich set of assertions, user-defined assertions, death tests,
+fatal and non-fatal failures, type-parameterized tests, various
+options for running the tests, and XML test report generation.
+
+WWW: http://code.google.com/p/googletest/
diff --git a/devel/googletest/pkg-plist b/devel/googletest/pkg-plist
new file mode 100644
index 000000000000..370825e86923
--- /dev/null
+++ b/devel/googletest/pkg-plist
@@ -0,0 +1,25 @@
+bin/gtest-config
+include/gtest/gtest.h
+include/gtest/gtest-death-test.h
+include/gtest/gtest-message.h
+include/gtest/gtest-spi.h
+include/gtest/gtest_pred_impl.h
+include/gtest/gtest_prod.h
+include/gtest/gtest-typed-test.h
+include/gtest/internal/gtest-death-test-internal.h
+include/gtest/internal/gtest-filepath.h
+include/gtest/internal/gtest-internal.h
+include/gtest/internal/gtest-port.h
+include/gtest/internal/gtest-string.h
+include/gtest/internal/gtest-type-util.h
+lib/libgtest.so.0
+lib/libgtest.so
+lib/libgtest.la
+lib/libgtest.a
+lib/libgtest_main.so.0
+lib/libgtest_main.so
+lib/libgtest_main.la
+lib/libgtest_main.a
+share/aclocal/gtest.m4
+@dirrm include/gtest/internal
+@dirrm include/gtest