aboutsummaryrefslogtreecommitdiff
path: root/devel/gprbuild/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-06-09 22:20:34 +0000
committerJohn Marino <marino@FreeBSD.org>2016-06-09 22:20:34 +0000
commit612b236c0fb3a5ad16dce7f632367181a76b03a9 (patch)
treee1b97f443b39a0539d73a840bbf63003d321dd63 /devel/gprbuild/Makefile
parentf1eb32fd9b29d9e719cee005630314e5b4f7f660 (diff)
downloadports-612b236c0fb3a5ad16dce7f632367181a76b03a9.tar.gz
ports-612b236c0fb3a5ad16dce7f632367181a76b03a9.zip
devel/gprbuild: Upgrade version 20150506 => 20160609
GPRBuild build is now hosted on github, so we can move away from the yearly releases and update more frequently. Unfortunately the docs makefile is currently broken so docs are disabled currently. When they come back, only txt and html docs will be supported. This new version detected a missing reference in the template-parser port so that port has been fixed and the downstream ports bumped accordingly. It also discovered an interface specification issue in a designer example of qtada. I spent a few minutes trying to fix/workaround it, but ultimately marked it broken. I will also deprecate the port because it no development has occurred since the port was created, and it's not even based on a real release. We'll see if anybody cares (3 month deprecation).
Notes
Notes: svn path=/head/; revision=416637
Diffstat (limited to 'devel/gprbuild/Makefile')
-rw-r--r--devel/gprbuild/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/devel/gprbuild/Makefile b/devel/gprbuild/Makefile
index 1f13e16a10c3..fbe0c07cd765 100644
--- a/devel/gprbuild/Makefile
+++ b/devel/gprbuild/Makefile
@@ -3,10 +3,7 @@
PORTNAME= gprbuild
PORTVERSION= ${SNAPSHOT}
-PORTREVISION= 3
CATEGORIES= devel
-MASTER_SITES= http://downloads.dragonlace.net/src/
-DISTNAME= gprbuild-gpl-${YEAR}-src
MAINTAINER= marino@FreeBSD.org
COMMENT= Adacore multi-language software build tool
@@ -15,26 +12,29 @@ LICENSE= GPLv3
BUILD_DEPENDS= xmlada>=4.4:textproc/xmlada
-YEAR= 2015
-SNAPSHOT= 20150506
+SNAPSHOT= 20160609
USES= ada
+USE_GITHUB= yes
+GH_ACCOUNT= AdaCore
+GH_PROJECT= gprbuild
+GH_TAGNAME= 376670f
+
+PORTDOCS= *
MAKE_ARGS= PROCESSORS=${MAKE_JOBS_NUMBER}
-PORTDOCS= html txt pdf
-CONHOST= ${CONFIGURE_TARGET}
+BUILD_WRKSRC= ${WRKSRC}/construction
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
INSTALL_TARGET= install
-OPTIONS_DEFINE= DOCS
-DOCS_INSTALL_TARGET= install-docs
-
-.include <bsd.port.options.mk>
+#OPTIONS_DEFINE= DOCS
+#DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
+#DOCS_ALL_TARGET= gen-docs
+#DOCS_INSTALL_TARGET= install-docs
post-patch:
- ${CP} ${FILESDIR}/Makefile.BSD ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -i "" -e "s,@AUXPREFIX@,${PREFIX}/gcc5-aux," \
+ ${MKDIR} ${WRKDIR}/trash ${BUILD_WRKSRC}
+ ${CP} ${FILESDIR}/Makefile.BSD ${WRKSRC}/construction/Makefile
+ @${REINPLACE_CMD} -i "" -e "s,@AUXPREFIX@,${PREFIX}/${ADAXX}-aux," \
${WRKSRC}/share/gprconfig/compilers.xml
- ${SED} -e 's|@host@|${CONHOST}|' \
- ${WRKSRC}/src/gprconfig-sdefault.ads.in > \
- ${WRKSRC}/src/gprconfig-sdefault.ads
- ${MV} ${WRKSRC}/share/gprconfig/*.orig ${WRKSRC}/obj-cov
+ ${MV} ${WRKSRC}/share/gprconfig/*.orig ${WRKDIR}/trash
.include <bsd.port.mk>