aboutsummaryrefslogtreecommitdiff
path: root/devel/gprbuild/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-05-16 09:06:13 +0000
committerJohn Marino <marino@FreeBSD.org>2014-05-16 09:06:13 +0000
commite960f790739ae6b4f8bf38e8b57aabcff45ec728 (patch)
tree8a2a8c2af974c7e15801f3e413f4a3a8492612ec /devel/gprbuild/Makefile
parentbb2f11734136f17178a56746fea19dd4fb5a0a18 (diff)
downloadports-e960f790739ae6b4f8bf38e8b57aabcff45ec728.tar.gz
ports-e960f790739ae6b4f8bf38e8b57aabcff45ec728.zip
devel/gprbuild: Upgrade version 20130416 (2013) => 20140417 (2014)
Adacore provides annual releases for its major GPL-licensed products. GPRBuild is an important tool, but it's source is only exposed once per year, in May. The 2014 release of GPRBuild relies on features in Adacore's commercial product, GNAT Pro, that has not yet been migrated to FSF GNAT. I had to patch 2014 to get it to build with FSF GNAT 4.9, losing minor new functionality in the process. My first decision was to simply skip GPRBuild 2014 stay on the 2013 version, but it turns out packages are already using the new features in gprinstall, one of the tools in the GPRBuild package. Tests on adabooch, aws, asis and opentoken indicate they build fine with GPRBuild 2014.
Notes
Notes: svn path=/head/; revision=354203
Diffstat (limited to 'devel/gprbuild/Makefile')
-rw-r--r--devel/gprbuild/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/devel/gprbuild/Makefile b/devel/gprbuild/Makefile
index 499d9de72afb..0c6a20c6815c 100644
--- a/devel/gprbuild/Makefile
+++ b/devel/gprbuild/Makefile
@@ -3,23 +3,20 @@
PORTNAME= gprbuild
PORTVERSION= ${SNAPSHOT}
-PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= gprbuild-gpl-${YEAR}-src
-EXTRACT_SUFX= .tgz
MAINTAINER= marino@FreeBSD.org
COMMENT= Adacore multi-language software build tool
LICENSE= GPLv3
-BUILD_DEPENDS+= xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
- gnat_util>=2013:${PORTSDIR}/lang/gnat_util
+BUILD_DEPENDS+= xmlada>=4.4:${PORTSDIR}/textproc/xmlada \
+ gnat_util>=20140422:${PORTSDIR}/lang/gnat_util
-WRKSRC= ${WRKDIR}/gprbuild-${YEAR}-src
-YEAR= 2013
-SNAPSHOT= 20130416
+YEAR= 2014
+SNAPSHOT= 20140417
GNU_CONFIGURE= yes
USES= ada gmake
MAKE_ARGS+= BUILD=production
@@ -33,13 +30,17 @@ OPTIONS_DEFINE= DOCS EXAMPLES
do-build:
# Recreate the do-build target without -j parameter
-# It interferes with PROCESSORS configure argument
+# It interferes with PROCESSORS make argument
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET})
post-patch:
@${REINPLACE_CMD} -e "s,@AUXPREFIX@,${PREFIX}/gcc-aux," \
- ${WRKSRC}/share/gprconfig/compilers.xml
+ ${WRKSRC}/share/gprconfig/compilers.xml
+ # Try_Help is part of GNAT Pro, but it's not in GCC 4.9 yet
+ # It's not strictly needed. Before it just repeated usage.
+ # There are other messages; just suppress Try_Help on 4 files
+ ${REINPLACE_CMD} -e '/Try_Help;/d' ${WRKSRC}/src/*-main.adb
post-install:
.if !${PORT_OPTIONS:MDOCS}