aboutsummaryrefslogtreecommitdiff
path: root/devel/gprbuild/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-30 12:03:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-30 12:03:14 +0000
commitf149a8d2d56341c8b5ca5310824fd678a5ea059d (patch)
tree73b8e3b5e9c267641c7734bab907bbaed0405de3 /devel/gprbuild/Makefile
parentd6cdd002880d9ef5a732e89ee1f472dc1a8bc17c (diff)
downloadports-f149a8d2d56341c8b5ca5310824fd678a5ea059d.tar.gz
ports-f149a8d2d56341c8b5ca5310824fd678a5ea059d.zip
The devel/gprbuild-aux is heavily tied with lang/gnat-aux. No other gnat compiler can use it (e.g. lang/gnat).
This new port intends to be more versatile although the only verified compiler atm is lang/gcc-aux. Once the two port that depend on gprbuild are updated, devel/gprbuild-aux should be removed main points: 1) supports new USES+= ada 2) Updated to GNAT GPL 2012 source 3) supports DESTDIR (tested on pkgsrc) 4) improved targetsets 5) Includes custom support for -R RPATH support (only found here, I created it) PR: ports/178146 Submitted by: John Marino <draco@marino.st>
Notes
Notes: svn path=/head/; revision=316921
Diffstat (limited to 'devel/gprbuild/Makefile')
-rw-r--r--devel/gprbuild/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/gprbuild/Makefile b/devel/gprbuild/Makefile
new file mode 100644
index 000000000000..5bb3051e8984
--- /dev/null
+++ b/devel/gprbuild/Makefile
@@ -0,0 +1,36 @@
+# Created by: John Marino <draco@marino.st>
+# $FreeBSD$
+
+PORTNAME= gprbuild
+PORTVERSION= ${SNAPSHOT}
+CATEGORIES= devel
+MASTER_SITES= http://downloads.dragonlace.net/src/
+DISTNAME= gprbuild-gpl-2012-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= draco@marino.st
+COMMENT= Adacore multi-language software build tool
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS+= xmlada>=3.2:${PORTSDIR}/textproc/xmlada
+
+EXAMPLESDIR= share/examples/gprbuild
+DOCSDIR= share/doc/gprbuild
+WRKSRC= ${WRKDIR}/gprbuild-2012-src
+SNAPSHOT= 20120510
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USES+= ada
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD"
+CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:L}${OSREL}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,@AUXPREFIX@,${PREFIX}/gcc-aux," \
+ ${WRKSRC}/share/gprconfig/compilers.xml
+
+.include <bsd.port.post.mk>