aboutsummaryrefslogtreecommitdiff
path: root/devel/gsoap
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-01-16 23:35:43 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-01-16 23:35:43 +0000
commit269c37fc15604e43d03c08b10b06f0dc0ca906a1 (patch)
treebde7deac2505c6ba5a39825daed063419725f767 /devel/gsoap
parent780132228a5a7424f5022d930045cf4d9ba85083 (diff)
downloadports-269c37fc15604e43d03c08b10b06f0dc0ca906a1.tar.gz
ports-269c37fc15604e43d03c08b10b06f0dc0ca906a1.zip
Remove unnecessary CPPFLAGS and fix the import paths properly. It seems
there was an upstream bug introduced in 2.7.11 (via Red Hat), which broke the default values. In r295977, we added a hack to override these two definitions but it was actually incomplete and incorrect, e. g., the import path for wsdl2h was still not properly set. Now we fix the root cause of these longstanding problems correctly.
Notes
Notes: svn path=/head/; revision=339999
Diffstat (limited to 'devel/gsoap')
-rw-r--r--devel/gsoap/Makefile7
-rw-r--r--devel/gsoap/files/patch-gsoap__wsdl__Makefile.in11
2 files changed, 15 insertions, 3 deletions
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
index 8f135207e787..395fe36c6284 100644
--- a/devel/gsoap/Makefile
+++ b/devel/gsoap/Makefile
@@ -14,8 +14,6 @@ COMMENT= Generator Tools for Coding SOAP/XML Web Services in C and C++
LICENSE= GPLv2
CONFIGURE_ENV= LEX=flex YACC=yacc
-CPPFLAGS+= -DWSDL_TYPEMAP_FILE=\\\"${DATADIR}/WS/typemap.dat\\\" \
- -DSOAPCPP2_IMPORT_PATH=\\\"${DATADIR}/import\\\"
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
USES= pathfix
@@ -40,7 +38,10 @@ CONFIGURE_ARGS= --disable-ssl
.endif
post-patch:
- ${REINPLACE_CMD} -e 's| sys/timeb.h | |' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ ${REINPLACE_CMD} -e 's| sys/timeb.h | |' \
+ -e 's|-DSOAPCPP_IMPORT_PATH=|-DSOAPCPP2_IMPORT_PATH=|' \
+ -e 's|-DWSDL_IMPORT_PATH=|-DWSDL2H_IMPORT_PATH=|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/gsoap
diff --git a/devel/gsoap/files/patch-gsoap__wsdl__Makefile.in b/devel/gsoap/files/patch-gsoap__wsdl__Makefile.in
new file mode 100644
index 000000000000..1004dd9ce45f
--- /dev/null
+++ b/devel/gsoap/files/patch-gsoap__wsdl__Makefile.in
@@ -0,0 +1,11 @@
+--- gsoap/wsdl/Makefile.in 2013-12-18 14:58:38.000000000 -0500
++++ gsoap/wsdl/Makefile.in 2014-01-16 14:35:52.000000000 -0500
+@@ -204,7 +204,7 @@
+ BUILT_SOURCES = $(SOAP_CPP_SRC)
+ wsdl2h_CFLAGS = $(C_DEBUG_FLAGS) $(WSDL2H_EXTRA_FLAGS)
+ wsdl2h_CXXFLAGS = $(C_DEBUG_FLAGS) $(WSDL2H_EXTRA_FLAGS)
+-wsdl2h_CPPFLAGS = $(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) -D$(platform)
++wsdl2h_CPPFLAGS = $(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) $(WSDL2H_IMPORTPATH) -D$(platform)
+ wsdl2h_SOURCES = wsdl2h.cpp wsdl.cpp schema.cpp types.cpp service.cpp soap.cpp mime.cpp wsp.cpp $(SOAP_CPP_SRC)
+ wsdl2h_LDADD = $(SOAP_CPP_LIB) $(WSDL2H_EXTRA_LIBS)
+ CLEANFILES = *~ *C.cpp *H.h *Stub.h *.nsmap