aboutsummaryrefslogtreecommitdiff
path: root/devel/gsoap
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-04-25 02:10:32 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-04-25 02:10:32 +0000
commitf472052dba562032e7e793ba85c6c01a385df37e (patch)
treea62d941ba7347573ea8b2f1e8566d3c4390a581f /devel/gsoap
parent07b0bf3735868db932b92f38d2167b5ca51e7613 (diff)
downloadports-f472052dba562032e7e793ba85c6c01a385df37e.tar.gz
ports-f472052dba562032e7e793ba85c6c01a385df37e.zip
devel/gsoap: Update version 2.8.59=>2.8.66
Notes
Notes: svn path=/head/; revision=468257
Diffstat (limited to 'devel/gsoap')
-rw-r--r--devel/gsoap/Makefile2
-rw-r--r--devel/gsoap/distinfo6
-rw-r--r--devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp14
-rw-r--r--devel/gsoap/files/patch-gsoap_plugin_mecevp.c6
-rw-r--r--devel/gsoap/files/patch-gsoap_plugin_smdevp.c10
-rw-r--r--devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp14
-rw-r--r--devel/gsoap/files/patch-gsoap_stdsoap2.c20
-rw-r--r--devel/gsoap/files/patch-gsoap_stdsoap2.cpp20
-rw-r--r--devel/gsoap/files/patch-gsoap_wsdl_Makefile.in14
9 files changed, 53 insertions, 53 deletions
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
index 17409d2d3294..96fdd273cbf1 100644
--- a/devel/gsoap/Makefile
+++ b/devel/gsoap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gsoap
-PORTVERSION= 2.8.59
+PORTVERSION= 2.8.66
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}2/gsoap-2.8
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/devel/gsoap/distinfo b/devel/gsoap/distinfo
index 6b599e89b5e8..0e28b2e58786 100644
--- a/devel/gsoap/distinfo
+++ b/devel/gsoap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515432916
-SHA256 (gsoap_2.8.59.zip) = fe5631df7fc840ac71def03be8fe1c55f2e8de2affe60ea64bb0f083e857ca5a
-SIZE (gsoap_2.8.59.zip) = 33109898
+TIMESTAMP = 1524616877
+SHA256 (gsoap_2.8.66.zip) = ef7a7ebf3963922ebc97424a6b2371b3761581f3fd07ecfdbaf8a36a8df63d59
+SIZE (gsoap_2.8.66.zip) = 33002504
diff --git a/devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp b/devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp
index fac13340ee52..05138d1f70f2 100644
--- a/devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp
+++ b/devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp
@@ -1,6 +1,6 @@
---- gsoap/VisualStudio2005/wsdl2h/wsdl2h/stdsoap2.cpp.orig 2017-04-07 18:39:02 UTC
+--- gsoap/VisualStudio2005/wsdl2h/wsdl2h/stdsoap2.cpp.orig 2018-04-08 14:22:45 UTC
+++ gsoap/VisualStudio2005/wsdl2h/wsdl2h/stdsoap2.cpp
-@@ -3735,7 +3735,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4281,7 +4281,7 @@ ssl_auth_init(struct soap *soap)
ERR_clear_error();
if (!soap->ctx)
{
@@ -9,7 +9,7 @@
/* TLS_method: a TLS/SSL connection established may understand the SSLv3, TLSv1, TLSv1.1 and TLSv1.2 protocols. */
soap->ctx = SSL_CTX_new(TLS_method());
#else
-@@ -3812,7 +3812,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4369,7 +4369,7 @@ ssl_auth_init(struct soap *soap)
#endif
if ((soap->ssl_flags & SOAP_SSL_RSA))
{
@@ -17,8 +17,8 @@
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER))
if (SSL_CTX_need_tmp_RSA(soap->ctx))
#endif
- { RSA *rsa = RSA_generate_key(SOAP_SSL_RSA_BITS, RSA_F4, NULL, NULL);
-@@ -5501,7 +5501,7 @@ tcp_disconnect(struct soap *soap)
+ {
+@@ -6390,7 +6390,7 @@ tcp_disconnect(struct soap *soap)
DBGLOG(TEST, SOAP_MESSAGE(fdebug, "Connection lost...\n"));
soap->fclosesocket(soap, soap->socket);
soap->socket = SOAP_INVALID_SOCKET;
@@ -27,7 +27,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -5525,7 +5525,7 @@ tcp_disconnect(struct soap *soap)
+@@ -6416,7 +6416,7 @@ tcp_disconnect(struct soap *soap)
}
SSL_free(soap->ssl);
soap->ssl = NULL;
@@ -36,7 +36,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -6146,7 +6146,7 @@ soap_done(struct soap *soap)
+@@ -7096,7 +7096,7 @@ soap_done(struct soap *soap)
soap->ctx = NULL;
}
}
diff --git a/devel/gsoap/files/patch-gsoap_plugin_mecevp.c b/devel/gsoap/files/patch-gsoap_plugin_mecevp.c
index 14d25337c42d..ca107b2e5693 100644
--- a/devel/gsoap/files/patch-gsoap_plugin_mecevp.c
+++ b/devel/gsoap/files/patch-gsoap_plugin_mecevp.c
@@ -1,6 +1,6 @@
---- gsoap/plugin/mecevp.c.orig 2017-04-07 18:39:01 UTC
+--- gsoap/plugin/mecevp.c.orig 2018-04-08 14:22:44 UTC
+++ gsoap/plugin/mecevp.c
-@@ -284,7 +284,7 @@ soap_mec_init(struct soap *soap, struct
+@@ -284,7 +284,7 @@ soap_mec_init(struct soap *soap, struct soap_mec_data
int ok = 1;
DBGLOG(TEST, SOAP_MESSAGE(fdebug, "soap_mec_init()\n"));
soap_ssl_init();
@@ -9,7 +9,7 @@
data->ctx = (EVP_CIPHER_CTX*)SOAP_MALLOC(soap, sizeof(EVP_CIPHER_CTX));
if (data->ctx)
EVP_CIPHER_CTX_init(data->ctx);
-@@ -448,7 +448,7 @@ soap_mec_cleanup(struct soap *soap, stru
+@@ -448,7 +448,7 @@ soap_mec_cleanup(struct soap *soap, struct soap_mec_da
data->type = NULL;
if (data->ctx)
{
diff --git a/devel/gsoap/files/patch-gsoap_plugin_smdevp.c b/devel/gsoap/files/patch-gsoap_plugin_smdevp.c
index 19b2a2865f45..25196369a403 100644
--- a/devel/gsoap/files/patch-gsoap_plugin_smdevp.c
+++ b/devel/gsoap/files/patch-gsoap_plugin_smdevp.c
@@ -1,6 +1,6 @@
---- gsoap/plugin/smdevp.c.orig 2017-04-07 18:39:01 UTC
+--- gsoap/plugin/smdevp.c.orig 2018-04-08 14:22:44 UTC
+++ gsoap/plugin/smdevp.c
-@@ -479,7 +479,7 @@ soap_smd_init(struct soap *soap, struct
+@@ -479,7 +479,7 @@ soap_smd_init(struct soap *soap, struct soap_smd_data
/* allocate and init the OpenSSL HMAC or EVP_MD context */
if ((alg & SOAP_SMD_ALGO) == SOAP_SMD_HMAC)
{
@@ -9,7 +9,7 @@
data->ctx = (void*)SOAP_MALLOC(soap, sizeof(HMAC_CTX));
if (data->ctx)
HMAC_CTX_init((HMAC_CTX*)data->ctx);
-@@ -489,7 +489,7 @@ soap_smd_init(struct soap *soap, struct
+@@ -489,7 +489,7 @@ soap_smd_init(struct soap *soap, struct soap_smd_data
}
else
{
@@ -18,7 +18,7 @@
data->ctx = (void*)SOAP_MALLOC(soap, sizeof(EVP_MD_CTX));
if (data->ctx)
EVP_MD_CTX_init((EVP_MD_CTX*)data->ctx);
-@@ -642,7 +642,7 @@ soap_smd_final(struct soap *soap, struct
+@@ -642,7 +642,7 @@ soap_smd_final(struct soap *soap, struct soap_smd_data
*len = (int)n;
}
/* cleanup */
@@ -27,7 +27,7 @@
if ((data->alg & SOAP_SMD_ALGO) == SOAP_SMD_HMAC)
HMAC_CTX_cleanup((HMAC_CTX*)data->ctx);
else
-@@ -687,7 +687,7 @@ soap_smd_check(struct soap *soap, struct
+@@ -687,7 +687,7 @@ soap_smd_check(struct soap *soap, struct soap_smd_data
}
if (data->ctx)
{
diff --git a/devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp b/devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp
index adf484389b46..eab5c14db7a9 100644
--- a/devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp
+++ b/devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp
@@ -1,6 +1,6 @@
---- gsoap/samples/calc_vs2005/calc_vs2005/stdsoap2.cpp.orig 2017-04-07 18:39:02 UTC
+--- gsoap/samples/calc_vs2005/calc_vs2005/stdsoap2.cpp.orig 2018-04-08 14:22:45 UTC
+++ gsoap/samples/calc_vs2005/calc_vs2005/stdsoap2.cpp
-@@ -3735,7 +3735,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4281,7 +4281,7 @@ ssl_auth_init(struct soap *soap)
ERR_clear_error();
if (!soap->ctx)
{
@@ -9,7 +9,7 @@
/* TLS_method: a TLS/SSL connection established may understand the SSLv3, TLSv1, TLSv1.1 and TLSv1.2 protocols. */
soap->ctx = SSL_CTX_new(TLS_method());
#else
-@@ -3812,7 +3812,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4369,7 +4369,7 @@ ssl_auth_init(struct soap *soap)
#endif
if ((soap->ssl_flags & SOAP_SSL_RSA))
{
@@ -17,8 +17,8 @@
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER))
if (SSL_CTX_need_tmp_RSA(soap->ctx))
#endif
- { RSA *rsa = RSA_generate_key(SOAP_SSL_RSA_BITS, RSA_F4, NULL, NULL);
-@@ -5501,7 +5501,7 @@ tcp_disconnect(struct soap *soap)
+ {
+@@ -6390,7 +6390,7 @@ tcp_disconnect(struct soap *soap)
DBGLOG(TEST, SOAP_MESSAGE(fdebug, "Connection lost...\n"));
soap->fclosesocket(soap, soap->socket);
soap->socket = SOAP_INVALID_SOCKET;
@@ -27,7 +27,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -5525,7 +5525,7 @@ tcp_disconnect(struct soap *soap)
+@@ -6416,7 +6416,7 @@ tcp_disconnect(struct soap *soap)
}
SSL_free(soap->ssl);
soap->ssl = NULL;
@@ -36,7 +36,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -6146,7 +6146,7 @@ soap_done(struct soap *soap)
+@@ -7096,7 +7096,7 @@ soap_done(struct soap *soap)
soap->ctx = NULL;
}
}
diff --git a/devel/gsoap/files/patch-gsoap_stdsoap2.c b/devel/gsoap/files/patch-gsoap_stdsoap2.c
index dcd7ff82c742..7750fc87a9d9 100644
--- a/devel/gsoap/files/patch-gsoap_stdsoap2.c
+++ b/devel/gsoap/files/patch-gsoap_stdsoap2.c
@@ -1,6 +1,6 @@
---- gsoap/stdsoap2.c.orig 2017-04-07 18:39:02 UTC
+--- gsoap/stdsoap2.c.orig 2018-04-08 14:22:45 UTC
+++ gsoap/stdsoap2.c
-@@ -3735,7 +3735,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4281,7 +4281,7 @@ ssl_auth_init(struct soap *soap)
ERR_clear_error();
if (!soap->ctx)
{
@@ -9,7 +9,7 @@
/* TLS_method: a TLS/SSL connection established may understand the SSLv3, TLSv1, TLSv1.1 and TLSv1.2 protocols. */
soap->ctx = SSL_CTX_new(TLS_method());
#else
-@@ -3812,7 +3812,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4369,7 +4369,7 @@ ssl_auth_init(struct soap *soap)
#endif
if ((soap->ssl_flags & SOAP_SSL_RSA))
{
@@ -17,8 +17,8 @@
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER))
if (SSL_CTX_need_tmp_RSA(soap->ctx))
#endif
- { RSA *rsa = RSA_generate_key(SOAP_SSL_RSA_BITS, RSA_F4, NULL, NULL);
-@@ -5501,7 +5501,7 @@ tcp_disconnect(struct soap *soap)
+ {
+@@ -6390,7 +6390,7 @@ tcp_disconnect(struct soap *soap)
DBGLOG(TEST, SOAP_MESSAGE(fdebug, "Connection lost...\n"));
soap->fclosesocket(soap, soap->socket);
soap->socket = SOAP_INVALID_SOCKET;
@@ -27,7 +27,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -5525,7 +5525,7 @@ tcp_disconnect(struct soap *soap)
+@@ -6416,7 +6416,7 @@ tcp_disconnect(struct soap *soap)
}
SSL_free(soap->ssl);
soap->ssl = NULL;
@@ -36,7 +36,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -5703,6 +5703,9 @@ soap_bind(struct soap *soap, const char
+@@ -6603,6 +6603,9 @@ soap_bind(struct soap *soap, const char *host, int por
}
#endif
#ifdef TCP_FASTOPEN
@@ -44,9 +44,9 @@
+ #define SOL_TCP IPPROTO_TCP
+ #endif
if (!(soap->omode & SOAP_IO_UDP) && setsockopt(soap->master, IPPROTO_TCP, TCP_FASTOPEN, (char*)&set, sizeof(int)))
- { /* silently ignore */
- DBGLOG(TEST, SOAP_MESSAGE(fdebug, "setsockopt TCP_FASTOPEN failed in soap_bind()\n"));
-@@ -6146,7 +6149,7 @@ soap_done(struct soap *soap)
+ {
+ /* silently ignore */
+@@ -7096,7 +7099,7 @@ soap_done(struct soap *soap)
soap->ctx = NULL;
}
}
diff --git a/devel/gsoap/files/patch-gsoap_stdsoap2.cpp b/devel/gsoap/files/patch-gsoap_stdsoap2.cpp
index 930871b40ade..7a59e0cb2cdc 100644
--- a/devel/gsoap/files/patch-gsoap_stdsoap2.cpp
+++ b/devel/gsoap/files/patch-gsoap_stdsoap2.cpp
@@ -1,6 +1,6 @@
---- gsoap/stdsoap2.cpp.orig 2017-04-07 18:39:02 UTC
+--- gsoap/stdsoap2.cpp.orig 2018-04-08 14:22:45 UTC
+++ gsoap/stdsoap2.cpp
-@@ -3735,7 +3735,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4281,7 +4281,7 @@ ssl_auth_init(struct soap *soap)
ERR_clear_error();
if (!soap->ctx)
{
@@ -9,7 +9,7 @@
/* TLS_method: a TLS/SSL connection established may understand the SSLv3, TLSv1, TLSv1.1 and TLSv1.2 protocols. */
soap->ctx = SSL_CTX_new(TLS_method());
#else
-@@ -3812,7 +3812,7 @@ ssl_auth_init(struct soap *soap)
+@@ -4369,7 +4369,7 @@ ssl_auth_init(struct soap *soap)
#endif
if ((soap->ssl_flags & SOAP_SSL_RSA))
{
@@ -17,8 +17,8 @@
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER))
if (SSL_CTX_need_tmp_RSA(soap->ctx))
#endif
- { RSA *rsa = RSA_generate_key(SOAP_SSL_RSA_BITS, RSA_F4, NULL, NULL);
-@@ -5501,7 +5501,7 @@ tcp_disconnect(struct soap *soap)
+ {
+@@ -6390,7 +6390,7 @@ tcp_disconnect(struct soap *soap)
DBGLOG(TEST, SOAP_MESSAGE(fdebug, "Connection lost...\n"));
soap->fclosesocket(soap, soap->socket);
soap->socket = SOAP_INVALID_SOCKET;
@@ -27,7 +27,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -5525,7 +5525,7 @@ tcp_disconnect(struct soap *soap)
+@@ -6416,7 +6416,7 @@ tcp_disconnect(struct soap *soap)
}
SSL_free(soap->ssl);
soap->ssl = NULL;
@@ -36,7 +36,7 @@
ERR_clear_error();
#else
ERR_remove_state(0);
-@@ -5703,6 +5703,9 @@ soap_bind(struct soap *soap, const char
+@@ -6603,6 +6603,9 @@ soap_bind(struct soap *soap, const char *host, int por
}
#endif
#ifdef TCP_FASTOPEN
@@ -44,9 +44,9 @@
+ #define SOL_TCP IPPROTO_TCP
+ #endif
if (!(soap->omode & SOAP_IO_UDP) && setsockopt(soap->master, IPPROTO_TCP, TCP_FASTOPEN, (char*)&set, sizeof(int)))
- { /* silently ignore */
- DBGLOG(TEST, SOAP_MESSAGE(fdebug, "setsockopt TCP_FASTOPEN failed in soap_bind()\n"));
-@@ -6146,7 +6149,7 @@ soap_done(struct soap *soap)
+ {
+ /* silently ignore */
+@@ -7096,7 +7099,7 @@ soap_done(struct soap *soap)
soap->ctx = NULL;
}
}
diff --git a/devel/gsoap/files/patch-gsoap_wsdl_Makefile.in b/devel/gsoap/files/patch-gsoap_wsdl_Makefile.in
index ef0fbb99001e..d3f51946e5b4 100644
--- a/devel/gsoap/files/patch-gsoap_wsdl_Makefile.in
+++ b/devel/gsoap/files/patch-gsoap_wsdl_Makefile.in
@@ -1,11 +1,11 @@
---- gsoap/wsdl/Makefile.in.orig 2017-09-18 17:57:57 UTC
+--- gsoap/wsdl/Makefile.in.orig 2018-04-25 00:42:30 UTC
+++ gsoap/wsdl/Makefile.in
-@@ -322,7 +322,7 @@ SOAP_FLAGS = -SC -pwsdl -I$(top_srcdir)/gsoap/wsdl -I$
+@@ -340,7 +340,7 @@ SOAP_FLAGS = -SC -pwsdl -I$(top_srcdir)/gsoap/wsdl -I$
BUILT_SOURCES = $(SOAP_CPP_SRC)
- wsdl2h_CFLAGS = $(C_DEBUG_FLAGS) $(SOAPCPP2_NO_C_LOCALE) $(WSDL2H_EXTRA_FLAGS)
- wsdl2h_CXXFLAGS = $(C_DEBUG_FLAGS) $(SOAPCPP2_NO_C_LOCALE) $(WSDL2H_EXTRA_FLAGS) $(WSDL2H_IMPORTPATH)
+ wsdl2h_CFLAGS = $(C_DEBUG_FLAGS) $(SOAPCPP2_INCLUDE_XLOCALE) $(SOAPCPP2_NO_C_LOCALE) $(WSDL2H_EXTRA_FLAGS)
+ wsdl2h_CXXFLAGS = $(C_DEBUG_FLAGS) $(SOAPCPP2_INCLUDE_XLOCALE) $(SOAPCPP2_NO_C_LOCALE) $(WSDL2H_EXTRA_FLAGS) $(WSDL2H_IMPORTPATH)
-wsdl2h_CPPFLAGS = $(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) -D$(platform)
+wsdl2h_CPPFLAGS = $(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) $(WSDL2H_IMPORTPATH) -D$(platform)
- wsdl2h_SOURCES = wsdl2h.cpp wsdl.cpp wadl.cpp schema.cpp types.cpp service.cpp soap.cpp mime.cpp wsp.cpp bpel.cpp $(SOAP_CPP_SRC)
- @WITH_OPENSSL_FALSE@wsdl2h_LDADD = $(SOAP_CPP_LIB) $(WSDL2H_EXTRA_LIBS)
- @WITH_OPENSSL_TRUE@wsdl2h_LDADD = $(SOAP_CPP_LIB) $(top_srcdir)/gsoap/plugin/httpda.c $(top_srcdir)/gsoap/plugin/smdevp.c $(top_srcdir)/gsoap/plugin/threads.c $(WSDL2H_EXTRA_LIBS)
+ wsdl2h_SOURCES = wsdl2h.cpp wsdl.cpp wadl.cpp schema.cpp types.cpp \
+ service.cpp soap.cpp mime.cpp wsp.cpp bpel.cpp $(SOAP_CPP_SRC) \
+ $(am__append_1)