aboutsummaryrefslogtreecommitdiff
path: root/devel/hexd
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-10-27 11:58:20 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-10-27 11:58:20 +0000
commitaca67ca3eb6c984eb00afdc1b9ac6992c61ffd2b (patch)
tree26ec6c186e6f6b66462557cad98076037a56cdb0 /devel/hexd
parent1aa490991190775e163530838d1102e200bff32f (diff)
downloadports-aca67ca3eb6c984eb00afdc1b9ac6992c61ffd2b.tar.gz
ports-aca67ca3eb6c984eb00afdc1b9ac6992c61ffd2b.zip
New port: devel/hexd
hexd prints a human-readable hexdump of the specified files, or standard input if omitted. Its main distinguishing feature is the use of colours to visually indicate which range of values an octet belongs to, aiding in spotting patterns in binary data. WWW: https://github.com/FireyFly/hexd/ PR: 219719 Submitted by: Dhananjay Balan <mail@dbalan.in>
Notes
Notes: svn path=/head/; revision=452971
Diffstat (limited to 'devel/hexd')
-rw-r--r--devel/hexd/Makefile25
-rw-r--r--devel/hexd/distinfo3
-rw-r--r--devel/hexd/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/devel/hexd/Makefile b/devel/hexd/Makefile
new file mode 100644
index 000000000000..e6d22566d609
--- /dev/null
+++ b/devel/hexd/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= hexd
+PORTVERSION= g20170531
+CATEGORIES= devel
+
+MAINTAINER= mail@dbalan.in
+COMMENT= Colourful, human-friendly hexdump tool
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= FireyFly
+GH_TAGNAME= 934a506
+
+PLIST_FILES= bin/hexd \
+ man/man1/hexd.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hexd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/hexd.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/hexd/distinfo b/devel/hexd/distinfo
new file mode 100644
index 000000000000..5811f4ddcb35
--- /dev/null
+++ b/devel/hexd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509079149
+SHA256 (FireyFly-hexd-g20170531-934a506_GH0.tar.gz) = f9f74bf6165c281c997df823e9781a329bd9eadc0a66a14b47dae91144799db5
+SIZE (FireyFly-hexd-g20170531-934a506_GH0.tar.gz) = 27322
diff --git a/devel/hexd/pkg-descr b/devel/hexd/pkg-descr
new file mode 100644
index 000000000000..efae492901df
--- /dev/null
+++ b/devel/hexd/pkg-descr
@@ -0,0 +1,6 @@
+hexd prints a human-readable hexdump of the specified files, or
+standard input if omitted. Its main distinguishing feature is the use
+of colours to visually indicate which range of values an octet belongs
+to, aiding in spotting patterns in binary data.
+
+WWW: https://github.com/FireyFly/hexd/