aboutsummaryrefslogtreecommitdiff
path: root/devel/hp48cc/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-09-04 21:06:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-09-04 21:06:12 +0000
commit856a51e90a2c2b0f56892fc84310d1377fc06bde (patch)
treea209b4f7f43a81a43aea5ed6a5fb08f6e241442a /devel/hp48cc/Makefile
parent6aa511e0f0faf94b70914320f136d91765545f1c (diff)
downloadports-856a51e90a2c2b0f56892fc84310d1377fc06bde.tar.gz
ports-856a51e90a2c2b0f56892fc84310d1377fc06bde.zip
- Resurrect once dead port
- Take maintainership - Respect CC and CLAGS - Clean up Makefile - Utilize EXAMPLESDIR macro - Pet some portlint(1) - Fix a WWW line, remove attribution
Notes
Notes: svn path=/head/; revision=172221
Diffstat (limited to 'devel/hp48cc/Makefile')
-rw-r--r--devel/hp48cc/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/hp48cc/Makefile b/devel/hp48cc/Makefile
new file mode 100644
index 000000000000..75b1a45addf9
--- /dev/null
+++ b/devel/hp48cc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hp48cc
+# Date created: Sun Aug 12 04:33:37 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hp48cc
+PORTVERSION= 1.3
+PORTREVISION= 1
+CATEGORIES= devel lang
+MASTER_SITES= http://www.sigala.it/sandro/files/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= C-like compiler that translates input code to the HP48 RPN language
+
+USE_BISON= yes
+GNU_CONFIGURE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+
+MAN1= ${PORTNAME}.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>