aboutsummaryrefslogtreecommitdiff
path: root/devel/hp48xgcc
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2006-03-06 20:33:56 +0000
committerKris Kennaway <kris@FreeBSD.org>2006-03-06 20:33:56 +0000
commit67f0d04819b0cf0f62d6f2664182851035414358 (patch)
treec39420fd2566bbb70bc36a08b2b329efd254efb3 /devel/hp48xgcc
parentbabcd8561c21cbf13d4111c068d3ba24d59d7d90 (diff)
downloadports-67f0d04819b0cf0f62d6f2664182851035414358.tar.gz
ports-67f0d04819b0cf0f62d6f2664182851035414358.zip
BROKEN on !i386: Configure fails
Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=156988
Diffstat (limited to 'devel/hp48xgcc')
-rw-r--r--devel/hp48xgcc/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/hp48xgcc/Makefile b/devel/hp48xgcc/Makefile
index 439e8e10d9b3..a287c0f86cc9 100644
--- a/devel/hp48xgcc/Makefile
+++ b/devel/hp48xgcc/Makefile
@@ -36,6 +36,12 @@ MAKE_ARGS= GCC_SRC="${GCC_DIR}" GCC_VERSION="${GCC_VER}" \
INSTALL_PROG="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= Configure fails on !i386
+.endif
+
post-extract: .SILENT
# Extract GCC distribution separately because of USE_ZIP/.tar.gz conflict
cd ${WRKDIR} && ${GZIP_CMD} -dc \
@@ -56,4 +62,4 @@ do-configure:
cd ${GCC_DIR} && ./configure --target=saturn-local-hp48 \
--prefix=${PREFIX}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>