aboutsummaryrefslogtreecommitdiff
path: root/devel/hp48xgcc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-01-11 04:48:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-01-11 04:48:19 +0000
commitaa470459551a7ed9d9a7621fba301581b79b062e (patch)
tree703cf6aa043b23916a852f8844c94e3867e81bce /devel/hp48xgcc
parentea684d55471b0e2b882d97490cb14345141cef97 (diff)
downloadports-aa470459551a7ed9d9a7621fba301581b79b062e.tar.gz
ports-aa470459551a7ed9d9a7621fba301581b79b062e.zip
- Convert BROKEN into ONLY_FOR_ARCHS: this port is based on ancient GCC
version (2.7.2) which is not likely to be fixed or taught new arches - Define LICENSE and do some minor non-functional retouch while here
Notes
Notes: svn path=/head/; revision=267623
Diffstat (limited to 'devel/hp48xgcc')
-rw-r--r--devel/hp48xgcc/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/hp48xgcc/Makefile b/devel/hp48xgcc/Makefile
index 985373b42dfa..3dee11c93a47 100644
--- a/devel/hp48xgcc/Makefile
+++ b/devel/hp48xgcc/Makefile
@@ -20,6 +20,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
COMMENT= GNU C cross-compiler for HP48 calculators
+LICENSE= GPLv2
+
+ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_ZIP= yes
@@ -35,12 +38,6 @@ MAKE_ARGS= GCC_SRC="${GCC_DIR}" GCC_VERSION="${GCC_VER}" \
INSTALL_PROG="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= Configure fails on !i386
-.endif
-
post-extract: .SILENT
# Extract GCC distribution separately because of USE_ZIP/.tar.gz conflict
cd ${WRKDIR} && ${GZIP_CMD} -dc \
@@ -50,15 +47,15 @@ post-extract: .SILENT
# Prepare GCC by creating proper config symlink
${LN} -sf ../../saturn/gcc-target/config-saturn ${GCC_DIR}/config/saturn
# Allow GCC to build in our environment
- ${REINPLACE_CMD} '178d' ${GCC_DIR}/gcc.c
+ ${REINPLACE_CMD} -e '178d' ${GCC_DIR}/gcc.c
# FreeBSD has vprintf() actually
${CHMOD} +w ${GCC_DIR}/config/xm-freebsd.h
${ECHO_CMD} '#define HAVE_VPRINTF' >> ${GCC_DIR}/config/xm-freebsd.h
# Do not install yet another copies of GPL
- ${REINPLACE_CMD} '/COPYING/d' ${WRKSRC}/make.pubfiles
+ ${REINPLACE_CMD} -e '/COPYING/d' ${WRKSRC}/make.pubfiles
do-configure:
cd ${GCC_DIR} && ./configure --target=saturn-local-hp48 \
--prefix=${PREFIX}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>