aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-DeepArrow
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-12 21:29:02 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-12 21:29:02 +0000
commitfb4945a8093b699b977bce63142690a8e20085f2 (patch)
treeecbfb572ea19de286ff8b8f4613c5c76096e0b8f /devel/hs-DeepArrow
parenta5a1d7c211ef79a38cb1fe17c91ee9f9a97cac6a (diff)
downloadports-fb4945a8093b699b977bce63142690a8e20085f2.tar.gz
ports-fb4945a8093b699b977bce63142690a8e20085f2.zip
This Haskell library provides a framework for type-directed composition
of value editors (non-syntactic transformations). The tools enable "deep function application" in two senses: deep application of functions and application of deep functions. These tools generalize beyond values and functions, via the DeepArrow subclass of the Arrow type class. WWW: http://haskell.org/haskellwiki/DeepArrow PR: ports/142482 Submitted by: Jacula Modyun <jacula(at)gmail.com>
Notes
Notes: svn path=/head/; revision=247735
Diffstat (limited to 'devel/hs-DeepArrow')
-rw-r--r--devel/hs-DeepArrow/Makefile77
-rw-r--r--devel/hs-DeepArrow/distinfo3
-rw-r--r--devel/hs-DeepArrow/pkg-descr7
-rw-r--r--devel/hs-DeepArrow/pkg-plist23
4 files changed, 110 insertions, 0 deletions
diff --git a/devel/hs-DeepArrow/Makefile b/devel/hs-DeepArrow/Makefile
new file mode 100644
index 000000000000..7986814601a4
--- /dev/null
+++ b/devel/hs-DeepArrow/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: hs-DeepArrow
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DeepArrow
+PORTVERSION= 0.3.3
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Haskell arrows for deep application
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-TypeCompose>=0.6.7:${PORTSDIR}/devel/hs-TypeCompose
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-TypeCompose>=0.6.7:${PORTSDIR}/devel/hs-TypeCompose
+
+GHC_VERSION= 6.10.4
+DEEPARROW_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+DEEPARROW_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ DEEPARROW_VERSION=${DEEPARROW_VERSION} \
+ DEEPARROW_LIBDIR_REL=${DEEPARROW_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${DEEPARROW_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/devel/hs-DeepArrow/distinfo b/devel/hs-DeepArrow/distinfo
new file mode 100644
index 000000000000..05f92f4de02b
--- /dev/null
+++ b/devel/hs-DeepArrow/distinfo
@@ -0,0 +1,3 @@
+MD5 (DeepArrow-0.3.3.tar.gz) = b8cf314d2535759dad0686f803908532
+SHA256 (DeepArrow-0.3.3.tar.gz) = 82cc77d62119279f409a2e6b57344f252af3b6eb9d15695434c5b5fc76c76c78
+SIZE (DeepArrow-0.3.3.tar.gz) = 9716
diff --git a/devel/hs-DeepArrow/pkg-descr b/devel/hs-DeepArrow/pkg-descr
new file mode 100644
index 000000000000..d12653532e7d
--- /dev/null
+++ b/devel/hs-DeepArrow/pkg-descr
@@ -0,0 +1,7 @@
+This Haskell library provides a framework for type-directed composition
+of value editors (non-syntactic transformations). The tools enable "deep
+function application" in two senses: deep application of functions and
+application of deep functions. These tools generalize beyond values and
+functions, via the DeepArrow subclass of the Arrow type class.
+
+WWW: http://haskell.org/haskellwiki/DeepArrow
diff --git a/devel/hs-DeepArrow/pkg-plist b/devel/hs-DeepArrow/pkg-plist
new file mode 100644
index 000000000000..c8f5b02a8337
--- /dev/null
+++ b/devel/hs-DeepArrow/pkg-plist
@@ -0,0 +1,23 @@
+@comment $FreeBSD$
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow/DeepArrow.hi
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow/DeepArrow/Examples.hi
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/DDeepArrow.hi
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/FunArr.hi
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSDeepArrow-%%DEEPARROW_VERSION%%.o
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Language/Haskell/Parens.hi
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Language/Haskell/ToHs.hi
+%%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSDeepArrow-%%DEEPARROW_VERSION%%.a
+%%DEEPARROW_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Language/Haskell
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Language
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow/DeepArrow
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control
+@dirrm %%DEEPARROW_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%DEEPARROW_LIBDIR_REL%%
+@exec /bin/sh %D/%%DEEPARROW_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister DeepArrow
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old