aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-TypeCompose
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-12 21:26:47 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-12 21:26:47 +0000
commita5a1d7c211ef79a38cb1fe17c91ee9f9a97cac6a (patch)
tree864c157106e20e605d6296535c79fb9754247a7b /devel/hs-TypeCompose
parent9e11274446ca306bbbdf7d1e0d96a9e17a623870 (diff)
downloadports-a5a1d7c211ef79a38cb1fe17c91ee9f9a97cac6a.tar.gz
ports-a5a1d7c211ef79a38cb1fe17c91ee9f9a97cac6a.zip
TypeCompose provides some Haskell classes and instances for forms of
type composition, as well as some modules who have not yet found a home. WWW: http://haskell.org/haskellwiki/TypeCompose PR: ports/142481 Submitted by: Jacula Modyun <jacula(at)gmail.com>
Notes
Notes: svn path=/head/; revision=247734
Diffstat (limited to 'devel/hs-TypeCompose')
-rw-r--r--devel/hs-TypeCompose/Makefile75
-rw-r--r--devel/hs-TypeCompose/distinfo3
-rw-r--r--devel/hs-TypeCompose/pkg-descr5
-rw-r--r--devel/hs-TypeCompose/pkg-plist23
4 files changed, 106 insertions, 0 deletions
diff --git a/devel/hs-TypeCompose/Makefile b/devel/hs-TypeCompose/Makefile
new file mode 100644
index 000000000000..fbaf6a511b39
--- /dev/null
+++ b/devel/hs-TypeCompose/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: hs-TypeCompose
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TypeCompose
+PORTVERSION= 0.6.7
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Type composition classes and instances for Haskell
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.10.4
+TYPECOMPOSE_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+TYPECOMPOSE_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ TYPECOMPOSE_VERSION=${TYPECOMPOSE_VERSION} \
+ TYPECOMPOSE_LIBDIR_REL=${TYPECOMPOSE_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${TYPECOMPOSE_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/devel/hs-TypeCompose/distinfo b/devel/hs-TypeCompose/distinfo
new file mode 100644
index 000000000000..f1044bbf89d1
--- /dev/null
+++ b/devel/hs-TypeCompose/distinfo
@@ -0,0 +1,3 @@
+MD5 (TypeCompose-0.6.7.tar.gz) = 3440bb581e2845e9333f969ab5ff250c
+SHA256 (TypeCompose-0.6.7.tar.gz) = 69168e3d239831426520687508b94f5a3d1fe6ee6490ac8cf9c384a9996769bf
+SIZE (TypeCompose-0.6.7.tar.gz) = 18569
diff --git a/devel/hs-TypeCompose/pkg-descr b/devel/hs-TypeCompose/pkg-descr
new file mode 100644
index 000000000000..ffa4ec1aee01
--- /dev/null
+++ b/devel/hs-TypeCompose/pkg-descr
@@ -0,0 +1,5 @@
+TypeCompose provides some Haskell classes and instances for forms of
+type composition, as well as some modules who have not yet found a
+home.
+
+WWW: http://haskell.org/haskellwiki/TypeCompose
diff --git a/devel/hs-TypeCompose/pkg-plist b/devel/hs-TypeCompose/pkg-plist
new file mode 100644
index 000000000000..d4c3f543d33f
--- /dev/null
+++ b/devel/hs-TypeCompose/pkg-plist
@@ -0,0 +1,23 @@
+@comment $FreeBSD$
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Compose.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Instances.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Bijection.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/CxMonoid.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Lambda.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Pair.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Partial.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/RefMonad.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Title.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Zip.hi
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSTypeCompose-%%TYPECOMPOSE_VERSION%%.o
+%%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSTypeCompose-%%TYPECOMPOSE_VERSION%%.a
+%%TYPECOMPOSE_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control
+@dirrm %%TYPECOMPOSE_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%TYPECOMPOSE_LIBDIR_REL%%
+@exec /bin/sh %D/%%TYPECOMPOSE_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister TypeCompose
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old