aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-darcs
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-21 22:31:11 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-21 22:31:11 +0000
commit7435bc8346106625215c45e9b694f1d7bf7537c0 (patch)
treeefd0579f8dc253aed945e3a90df3d30dc6e14ac8 /devel/hs-darcs
parent16afe2f83ead684aee20dee7111a0da89799e45a (diff)
downloadports-7435bc8346106625215c45e9b694f1d7bf7537c0.tar.gz
ports-7435bc8346106625215c45e9b694f1d7bf7537c0.zip
- Fix build when non-default options are used
PR: ports/146804 Submitted by: Anatoly Borodin <anatoly.borodin@gmail.com>
Notes
Notes: svn path=/head/; revision=254761
Diffstat (limited to 'devel/hs-darcs')
-rw-r--r--devel/hs-darcs/Makefile2
-rw-r--r--devel/hs-darcs/files/patch-darcs.cabal29
2 files changed, 30 insertions, 1 deletions
diff --git a/devel/hs-darcs/Makefile b/devel/hs-darcs/Makefile
index 1b2aa736a03a..4e9cce17d02d 100644
--- a/devel/hs-darcs/Makefile
+++ b/devel/hs-darcs/Makefile
@@ -42,6 +42,7 @@ CONFIGURE_ARGS+= --flags="-curl"
.if defined(WITH_CURL_PIPELINING)
CONFIGURE_ARGS+= --flags="curl-pipelining"
+BUILD_DEPENDS+= pkg-config>=0.9.0:${PORTSDIR}/devel/pkg-config
.if !defined(WITH_CURL)
IGNORE= cannot be compiled without CURL in this configuration. Please (re)run 'make config' and choose CURL too
.endif
@@ -103,6 +104,7 @@ CONFIGURE_ARGS+= --flags="-mmap"
.if defined(WITH_TEST)
CONFIGURE_ARGS+= --flags="test"
+USE_HACKAGE+= QuickCheck>=2.1.0.0 test-framework>=0.2.2 test-framework-hunit>=0.2.2 test-framework-quickcheck2>=0.2.2
EXECUTABLE+= unit
PLIST_SUB+= MAYBE_TEST=""
.else
diff --git a/devel/hs-darcs/files/patch-darcs.cabal b/devel/hs-darcs/files/patch-darcs.cabal
index 3f96af76dc74..595619a55580 100644
--- a/devel/hs-darcs/files/patch-darcs.cabal
+++ b/devel/hs-darcs/files/patch-darcs.cabal
@@ -1,5 +1,5 @@
--- ./darcs.cabal.orig 2010-05-09 15:23:32.000000000 +0200
-+++ ./darcs.cabal 2010-05-15 13:36:40.000000000 +0200
++++ ./darcs.cabal 2010-05-21 21:08:36.000000000 +0200
@@ -328,7 +328,7 @@
html == 1.0.*,
filepath == 1.1.*,
@@ -9,6 +9,15 @@
if !os(windows)
build-depends: unix >= 1.0 && < 2.5
+@@ -374,7 +374,7 @@
+ buildable: False
+
+ if flag(mmap) && !os(windows)
+- build-depends: mmap >= 0.2 && < 0.5
++ build-depends: mmap >= 0.2
+ cpp-options: -DHAVE_MMAP
+
+ build-depends: zlib >= 0.5.1.0 && < 0.6.0.0
@@ -459,7 +459,7 @@
html == 1.0.*,
filepath == 1.1.*,
@@ -18,3 +27,21 @@
if !os(windows)
build-depends: unix >= 1.0 && < 2.5
+@@ -497,7 +497,7 @@
+ buildable: False
+
+ if flag(mmap) && !os(windows)
+- build-depends: mmap >= 0.2 && < 0.5
++ build-depends: mmap >= 0.2
+ cpp-options: -DHAVE_MMAP
+
+ build-depends: zlib >= 0.5.1.0 && < 0.6.0.0
+@@ -605,7 +605,7 @@
+ random == 1.0.*
+
+ if flag(mmap) && !os(windows)
+- build-depends: mmap >= 0.2 && < 0.5
++ build-depends: mmap >= 0.2
+ cpp-options: -DHAVE_MMAP
+
+ build-depends: zlib >= 0.5.1.0 && < 0.6.0.0