aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-darcs
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-15 19:27:51 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-15 19:27:51 +0000
commitbda1e307a23d3aa7788b962b8c8ba57cbd66bd1d (patch)
treedcf878198bbe6a661a6d96b6b3aaef89f39ea371 /devel/hs-darcs
parentd99a8f098d35988af8517722f0c365ec381de1a8 (diff)
downloadports-bda1e307a23d3aa7788b962b8c8ba57cbd66bd1d.tar.gz
ports-bda1e307a23d3aa7788b962b8c8ba57cbd66bd1d.zip
- Update to 2.4.3
- Cabalize port
Notes
Notes: svn path=/head/; revision=254373
Diffstat (limited to 'devel/hs-darcs')
-rw-r--r--devel/hs-darcs/Makefile152
-rw-r--r--devel/hs-darcs/distinfo6
-rw-r--r--devel/hs-darcs/files/patch-Setup.lhs20
-rw-r--r--devel/hs-darcs/files/patch-darcs.cabal20
-rw-r--r--devel/hs-darcs/pkg-descr19
-rw-r--r--devel/hs-darcs/pkg-plist176
6 files changed, 309 insertions, 84 deletions
diff --git a/devel/hs-darcs/Makefile b/devel/hs-darcs/Makefile
index a793c53f0656..1b2aa736a03a 100644
--- a/devel/hs-darcs/Makefile
+++ b/devel/hs-darcs/Makefile
@@ -6,79 +6,109 @@
#
PORTNAME= darcs
-PORTVERSION= 2.2.0
-PORTREVISION= 7
-CATEGORIES= devel
-MASTER_SITES= http://darcs.net/
+PORTVERSION= 2.4.3
+CATEGORIES= devel haskell
+PKGNAMEPREFIX=
MAINTAINER= haskell@FreeBSD.org
-COMMENT= Yet another replacement for CVS, written in Haskell
-
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- gmp.10:${PORTSDIR}/math/gmp
-
-OPTIONS= SERVER "install server" on
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${PREFIX}/lib/ ${PTHREAD_LIBS}"
-USE_GMAKE= yes
-MAKEFILE= GNUmakefile
-INSTALL_TARGET= install
-PORTDOCS= manual examples
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_SERVER)
-BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt
-RUN_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt
-INSTALL_TARGET+= installserver
-.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
-CGIDIR?= share/apache/cgi-bin
+COMMENT= A distributed, interactive, smart revision control system
+
+USE_HACKAGE= hashed-storage haskeline>=0.6.1 utf8-string>=0.3 zlib>=0.5.1.0
+
+EXECUTABLE= darcs
+
+MAN1= darcs.1
+MAN1SRC= dist/build/darcs
+
+OPTIONS= CURL "Use libcurl for HTTP support" on \
+ CURL_PIPELINING "Use libcurl's HTTP pipelining" off \
+ HTTP "Use the pure HTTP package" off \
+ STATIC "Build static binary" off \
+ TERMINFO "Use the terminfo package" off \
+ THREADED "Use threading and SMP support" on \
+ TYPE_WITNESSES "Use GADT type witnesses" off \
+ COLOR "Use ANSI color escapes" off \
+ MMAP "Compile with mmap support" off \
+ TEST "Compile unit tests" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_CURL)
+CONFIGURE_ARGS+= --flags="curl"
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+.else
+CONFIGURE_ARGS+= --flags="-curl"
+.endif
+
+.if defined(WITH_CURL_PIPELINING)
+CONFIGURE_ARGS+= --flags="curl-pipelining"
+.if !defined(WITH_CURL)
+IGNORE= cannot be compiled without CURL in this configuration. Please (re)run 'make config' and choose CURL too
+.endif
+.else
+CONFIGURE_ARGS+= --flags="-curl-pipelining"
+.endif
+
+.if defined(WITH_HTTP)
+CONFIGURE_ARGS+= --flags="http"
+USE_HACKAGE+= HTTP>=3000.0
.else
-CGIDIR?= www/cgi-bin
+CONFIGURE_ARGS+= --flags="-http"
.endif
-PLIST_SUB+= CGIDIR=${CGIDIR} SERVER=""
+
+.if !defined(WITH_CURL) && !defined(WITH_HTTP)
+IGNORE= cannot be compiled without HTTP support. Please (re)run 'make config' and choose either CURL or HTTP
+.endif
+
+.if defined(WITH_STATIC)
+CONFIGURE_ARGS+= --flags="static"
.else
-PLIST_SUB+= SERVER="@comment "
+CONFIGURE_ARGS+= --flags="-static"
.endif
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
- latex2html:${PORTSDIR}/textproc/latex2html
-ALL_TARGET+= doc/manual/darcs.ps doc/manual/patch-theory.pdf doc/manual/index.html
-INSTALL_TARGET+= install-ps install-pdf install-html install-examples
+
+.if defined(WITH_TERMINFO)
+CONFIGURE_ARGS+= --flags="terminfo"
+USE_HACKAGE+= terminfo>=0.3
.else
-CONFIGURE_ARGS+= --without-manual
+CONFIGURE_ARGS+= --flags="-terminfo"
.endif
-MAN1= darcs.1
+.if defined(WITH_THREADED)
+CONFIGURE_ARGS+= --flags="threaded"
+.else
+CONFIGURE_ARGS+= --flags="-threaded"
+.endif
-.if defined(WITH_SERVER)
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(libexecdir)/cgi-bin|${PREFIX}/${CGIDIR}| ; \
- s|darcs/cgi.conf|darcs/cgi.conf.sample|' \
- ${WRKSRC}/${MAKEFILE}
+.if defined(WITH_TYPE_WITNESSES)
+CONFIGURE_ARGS+= --flags="type-witnesses"
+EXECUTABLE+= witnesses
+PLIST_SUB+= MAYBE_TYPE_WITNESSES=""
+.else
+CONFIGURE_ARGS+= --flags="-type-witnesses"
+PLIST_SUB+= MAYBE_TYPE_WITNESSES="@comment "
.endif
-pre-configure:
-.if ${OSVERSION} < 700000
- @${ECHO_MSG} ""
- @${ECHO_MSG} "###############################################################################"
- @${ECHO_MSG} " "
- @${ECHO_MSG} " A T T E N T I O N "
- @${ECHO_MSG} " "
- @${ECHO_MSG} "If you experience problems during the configure process, please add the "
- @${ECHO_MSG} "following lines to your /etc/libmap.conf configuration file: "
- @${ECHO_MSG} " "
- @${ECHO_MSG} "libpthread.so.1 libthr.so.1 "
- @${ECHO_MSG} "libpthread.so.2 libthr.so.2 "
- @${ECHO_MSG} "libkse.so.3 libthr.so.3 "
- @${ECHO_MSG} " "
- @${ECHO_MSG} "###############################################################################"
- @${ECHO_MSG} ""
+.if defined(WITH_COLOR)
+CONFIGURE_ARGS+= --flags="color"
+.else
+CONFIGURE_ARGS+= --flags="-color"
+.endif
+
+.if defined(WITH_MMAP)
+CONFIGURE_ARGS+= --flags="mmap"
+USE_HACKAGE+= mmap>=0.2
+.else
+CONFIGURE_ARGS+= --flags="-mmap"
.endif
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/darcs
+.if defined(WITH_TEST)
+CONFIGURE_ARGS+= --flags="test"
+EXECUTABLE+= unit
+PLIST_SUB+= MAYBE_TEST=""
+.else
+CONFIGURE_ARGS+= --flags="-test"
+PLIST_SUB+= MAYBE_TEST="@comment "
+.endif
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-darcs/distinfo b/devel/hs-darcs/distinfo
index e12ede6ee3a8..afb41bcb05cf 100644
--- a/devel/hs-darcs/distinfo
+++ b/devel/hs-darcs/distinfo
@@ -1,3 +1,3 @@
-MD5 (darcs-2.2.0.tar.gz) = 8f0a5eba5971e7cf324c63664cde59e2
-SHA256 (darcs-2.2.0.tar.gz) = 81633effd983b2d67e2d5eaee32666f1207def8a9af189c5abd6d1a9acab35da
-SIZE (darcs-2.2.0.tar.gz) = 1793273
+MD5 (darcs-2.4.3.tar.gz) = 7263a8578f2a1f4e57ad90f3ad5bfe04
+SHA256 (darcs-2.4.3.tar.gz) = 3aa1d00bad07e4e797fb6420d2fd1f22fda04af52d51839690e3047e16759ddb
+SIZE (darcs-2.4.3.tar.gz) = 1193044
diff --git a/devel/hs-darcs/files/patch-Setup.lhs b/devel/hs-darcs/files/patch-Setup.lhs
new file mode 100644
index 000000000000..5bf1fce13516
--- /dev/null
+++ b/devel/hs-darcs/files/patch-Setup.lhs
@@ -0,0 +1,20 @@
+--- ./Setup.lhs.orig 2010-05-09 15:23:32.000000000 +0200
++++ ./Setup.lhs 2010-05-15 13:37:00.000000000 +0200
+@@ -17,7 +17,7 @@
+ ( Version(versionBranch) )
+ import Distribution.Simple.LocalBuildInfo
+ ( LocalBuildInfo(..), absoluteInstallDirs )
+-import Distribution.Simple.InstallDirs (mandir, CopyDest (NoCopyDest))
++import Distribution.Simple.InstallDirs (prefix, CopyDest (NoCopyDest))
+ import Distribution.Simple.Setup
+ (buildVerbosity, copyDest, copyVerbosity, fromFlag,
+ haddockVerbosity, installVerbosity, sDistVerbosity)
+@@ -168,7 +168,7 @@
+ -> Verbosity -> CopyDest -> IO ()
+ installManpage pkg lbi verbosity copy =
+ copyFiles verbosity
+- (mandir (absoluteInstallDirs pkg lbi copy) </> "man1")
++ (prefix (absoluteInstallDirs pkg lbi copy) </> "man/man1")
+ [(buildDir lbi </> "darcs", "darcs.1")]
+
+ determineVersion :: Verbosity -> PackageDescription -> IO (String, String)
diff --git a/devel/hs-darcs/files/patch-darcs.cabal b/devel/hs-darcs/files/patch-darcs.cabal
new file mode 100644
index 000000000000..3f96af76dc74
--- /dev/null
+++ b/devel/hs-darcs/files/patch-darcs.cabal
@@ -0,0 +1,20 @@
+--- ./darcs.cabal.orig 2010-05-09 15:23:32.000000000 +0200
++++ ./darcs.cabal 2010-05-15 13:36:40.000000000 +0200
+@@ -328,7 +328,7 @@
+ html == 1.0.*,
+ filepath == 1.1.*,
+ haskeline >= 0.6.1 && < 0.7,
+- hashed-storage == 0.4.13
++ hashed-storage
+
+ if !os(windows)
+ build-depends: unix >= 1.0 && < 2.5
+@@ -459,7 +459,7 @@
+ html == 1.0.*,
+ filepath == 1.1.*,
+ haskeline >= 0.6.1 && < 0.7,
+- hashed-storage == 0.4.13
++ hashed-storage
+
+ if !os(windows)
+ build-depends: unix >= 1.0 && < 2.5
diff --git a/devel/hs-darcs/pkg-descr b/devel/hs-darcs/pkg-descr
index 081165326174..97c938b0857c 100644
--- a/devel/hs-darcs/pkg-descr
+++ b/devel/hs-darcs/pkg-descr
@@ -1,4 +1,19 @@
-David's Advanced Revision Control System is yet another replacement for
-CVS. It is written in Haskell.
+Darcs is a free, open source revision control system. It is:
+
+* Distributed: Every user has access to the full command set, removing
+boundaries between server and client or committer and non-committers.
+
+* Interactive: Darcs is easy to learn and efficient to use because it
+asks you questions in response to simple commands, giving you choices in
+your work flow. You can choose to record one change in a file, while
+ignoring another. As you update from upstream, you can review each patch
+name, even the full "diff" for interesting patches.
+
+* Smart: Originally developed by physicist David Roundy, darcs is based
+on a unique algebra of patches.
+
+This smartness lets you respond to changing demands in ways that would
+otherwise not be possible. Learn more about spontaneous branches with
+darcs.
WWW: http://darcs.net/
diff --git a/devel/hs-darcs/pkg-plist b/devel/hs-darcs/pkg-plist
index 5897cd25d12e..0091e7a49aa6 100644
--- a/devel/hs-darcs/pkg-plist
+++ b/devel/hs-darcs/pkg-plist
@@ -1,20 +1,160 @@
@comment $FreeBSD$
bin/darcs
-etc/bash_completion.d/darcs
-%%SERVER%%%%CGIDIR%%/darcs.cgi
-%%SERVER%%etc/darcs/cgi.conf.sample
-%%SERVER%%etc/darcs/styles.css
-%%SERVER%%share/darcs/xslt/annotate.xslt
-%%SERVER%%share/darcs/xslt/browse.xslt
-%%SERVER%%share/darcs/xslt/common.xslt
-%%SERVER%%share/darcs/xslt/errors.xslt
-%%SERVER%%share/darcs/xslt/errors.xml
-%%SERVER%%share/darcs/xslt/patches.xslt
-%%SERVER%%share/darcs/xslt/repos.xslt
-%%SERVER%%share/darcs/xslt/rss.xslt
-%%SERVER%%share/darcs/xslt/styles.css
-@dirrmtry etc/bash_completion.d
-%%SERVER%%@dirrmtry etc/darcs
-%%SERVER%%@dirrmtry www/cgi-bin
-%%SERVER%%@dirrm share/darcs/xslt
-%%SERVER%%@dirrm share/darcs
+%%MAYBE_TEST%%bin/unit
+%%MAYBE_TYPE_WITNESSES%%bin/witnesses
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/ByteStringUtils.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/CommandLine.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Crypt/SHA256.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/ArgumentDefaults.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Arguments.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Bug.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/CheckFileSystem.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/ColorPrinter.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Add.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/AmendRecord.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Annotate.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Apply.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Changes.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Check.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Convert.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Diff.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Dist.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/GZCRCs.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Get.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Help.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Init.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/MarkConflicts.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Move.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Optimize.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Pull.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Push.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Put.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Record.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Remove.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Repair.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Replace.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Revert.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Rollback.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Send.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/SetPref.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Show.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowAuthors.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowBug.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowContents.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowFiles.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowIndex.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowRepo.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/ShowTags.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Tag.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/TrackDown.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/TransferMode.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Unrecord.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/Unrevert.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands/WhatsNew.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/CommandsAux.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Compat.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Diff.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Email.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/External.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/FilePathMonad.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Flags.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Global.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Hopefully.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/IO.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Lock.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Match.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Apply.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Bundle.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Choices.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Commute.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Core.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Depends.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/FileName.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Info.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Match.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/MatchData.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Non.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/OldDate.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Patchy.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Permutations.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Prim.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Properties.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Read.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/ReadMonads.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Real.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/RegChars.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Set.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Show.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Split.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/TouchesFiles.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch/Viewing.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Population.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/PopulationData.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/PrintPatch.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/ProgressPatches.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/RemoteApply.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/RepoPath.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/ApplyPatches.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Cache.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Checkpoint.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/DarcsRepo.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Format.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/HashedIO.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/HashedRepo.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Internal.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/InternalTypes.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/LowLevel.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Merge.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Motd.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Prefs.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Pristine.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/Repair.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository/State.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Resolution.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/RunCommand.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/SelectChanges.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/SignalHandler.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/SlurpDirectory.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/SlurpDirectory/Internal.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Test.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/TheCommands.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/URL.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Utils.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Witnesses/Ordered.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Witnesses/Sealed.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Witnesses/Show.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/DateMatcher.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/English.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Exec.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HTTP.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/IsoDate.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Lcs.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Printer.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Progress.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Ratified.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/SHA1.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Ssh.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/URL.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Version.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Workaround.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/COPYING
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Witnesses
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/SlurpDirectory
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Repository
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Patch
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs/Commands
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Darcs
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Crypt
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old