aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-dlist
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 19:51:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 19:51:57 +0000
commita2d02bde1863c6beb593a7ca7b376382ac4f7a64 (patch)
tree75fed1c9a28140ff1bffb581a807219d0d6b72e0 /devel/hs-dlist
parent32a1d5cb97a9da0077f45e3556a425f239c0b87a (diff)
downloadports-a2d02bde1863c6beb593a7ca7b376382ac4f7a64.tar.gz
ports-a2d02bde1863c6beb593a7ca7b376382ac4f7a64.zip
Differences lists are a list-like type supporting O(1) append. This is
particularly useful for efficient logging and pretty printing, (e.g. with the Writer monad), where list append quickly becomes too expensive. WWW: http://code.haskell.org/~dons/code/dlist/ PR: ports/128770 Submitted by: Samy Al Bahra <sbahra at kerneled.org>
Notes
Notes: svn path=/head/; revision=222872
Diffstat (limited to 'devel/hs-dlist')
-rw-r--r--devel/hs-dlist/Makefile37
-rw-r--r--devel/hs-dlist/distinfo3
-rw-r--r--devel/hs-dlist/pkg-descr5
-rw-r--r--devel/hs-dlist/pkg-plist13
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/hs-dlist/Makefile b/devel/hs-dlist/Makefile
new file mode 100644
index 000000000000..3a550cb7ad08
--- /dev/null
+++ b/devel/hs-dlist/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: dlist
+# Date created: November 10, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= dlist
+PORTVERSION= 0.4.1
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= A list-like type supporting O(1) append for Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/devel/hs-dlist/distinfo b/devel/hs-dlist/distinfo
new file mode 100644
index 000000000000..b48ed2a18362
--- /dev/null
+++ b/devel/hs-dlist/distinfo
@@ -0,0 +1,3 @@
+MD5 (dlist-0.4.1.tar.gz) = c1d0bcebbb62a60f56a42cfdc1b32758
+SHA256 (dlist-0.4.1.tar.gz) = 5e3271b7962e002a86c62cd13aa27960ef643cdf87908324a781e9a437898b10
+SIZE (dlist-0.4.1.tar.gz) = 5841
diff --git a/devel/hs-dlist/pkg-descr b/devel/hs-dlist/pkg-descr
new file mode 100644
index 000000000000..363c837fd492
--- /dev/null
+++ b/devel/hs-dlist/pkg-descr
@@ -0,0 +1,5 @@
+Differences lists are a list-like type supporting O(1) append. This is
+particularly useful for efficient logging and pretty printing, (e.g.
+with the Writer monad), where list append quickly becomes too expensive.
+
+WWW: http://code.haskell.org/~dons/code/dlist/
diff --git a/devel/hs-dlist/pkg-plist b/devel/hs-dlist/pkg-plist
new file mode 100644
index 000000000000..cbb4384f880a
--- /dev/null
+++ b/devel/hs-dlist/pkg-plist
@@ -0,0 +1,13 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSdlist-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSdlist-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/DList.hi
+%%SUBDIR%%/register.sh
+share/doc/dlist-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/dlist-%%PORTVERSION%%
+@dirrm lib/dlist-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data
+@dirrm lib/dlist-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/dlist-%%PORTVERSION%%
+@exec /bin/sh %D/%%SUBDIR%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister dlist
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old