aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hat
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-22 06:21:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-22 06:21:46 +0000
commitadf254e464aae2f0d7a692ec1f8c86ef94f009fe (patch)
tree7ea45cc64aecff32ce69be67f46e24e5048865ed /devel/hs-hat
parent590fdc6ba4bdb04b66b735b72db2277f0b9f3782 (diff)
downloadports-adf254e464aae2f0d7a692ec1f8c86ef94f009fe.tar.gz
ports-adf254e464aae2f0d7a692ec1f8c86ef94f009fe.zip
upgrade to 1.10
PR: 31453 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=51965
Diffstat (limited to 'devel/hs-hat')
-rw-r--r--devel/hs-hat/Makefile17
-rw-r--r--devel/hs-hat/distinfo16
-rw-r--r--devel/hs-hat/files/patch-include::Array.hi12
-rw-r--r--devel/hs-hat/pkg-plist12
4 files changed, 40 insertions, 17 deletions
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 6fa0f3818e8a..cff9b316a10f 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -5,15 +5,23 @@
# $FreeBSD$
PORTNAME= nhc98
-PORTVERSION= 1.08
+PORTVERSION= 1.10
CATEGORIES= lang
MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/${PORTNAME}/
DISTNAME= ${PORTNAME}src-${PORTVERSION}
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.08-ghc5.02 \
- patch-1.08-hmake \
- patch-1.08-hat-makefile
+PATCHFILES= patch-1.10-IO \
+ patch-1.10-arrow \
+ patch-1.10-blockbuffer \
+ patch-1.10-commas \
+ patch-1.10-counter \
+ patch-1.10-hp2graph \
+ patch-1.10-keywords \
+ patch-1.10-lhs \
+ patch-1.10-patterns \
+ patch-1.10-hiding \
+ patch-1.10-ghc5.02
MAINTAINER= obraun@informatik.unibw-muenchen.de
@@ -60,6 +68,7 @@ pre-fetch:
# into the build directory. The configure option won't work in the
# ports system.
pre-install:
+ ${RM} -f ${WRKSRC}/include/*.orig
${SED} -e "s#LIBDIR=.*##" \
< ${WRKSRC}/targets/ix86-FreeBSD/config.cache \
> ${WRKSRC}/targets/ix86-FreeBSD/config.cache.fix1
diff --git a/devel/hs-hat/distinfo b/devel/hs-hat/distinfo
index 8fedab1d6c99..1534a598e5c4 100644
--- a/devel/hs-hat/distinfo
+++ b/devel/hs-hat/distinfo
@@ -1,4 +1,12 @@
-MD5 (nhc98/nhc98src-1.08.tar.gz) = 6234cafff0cc09fbc73127c421232463
-MD5 (nhc98/patch-1.08-ghc5.02) = aea26d10381d13363611797fb14896b9
-MD5 (nhc98/patch-1.08-hmake) = 589e4558e29ae95bdf1d79a100b2180f
-MD5 (nhc98/patch-1.08-hat-makefile) = 7882524c5d9a6567dc18a6b2c2a9b7d5
+MD5 (nhc98/nhc98src-1.10.tar.gz) = 159e043a520d2eaa886213b53d50f666
+MD5 (nhc98/patch-1.10-IO) = 46b5c25be1dd764c84a3ddcab9a94c38
+MD5 (nhc98/patch-1.10-arrow) = d27deb1683c33d58a41c3eb28e9c0e9a
+MD5 (nhc98/patch-1.10-blockbuffer) = f66a8885fd0bd037b68e8024942fc274
+MD5 (nhc98/patch-1.10-commas) = fda47aeaa34b6bcb981f93d905baf889
+MD5 (nhc98/patch-1.10-counter) = e78121249b077e57489f0b0ad72e6bad
+MD5 (nhc98/patch-1.10-hp2graph) = 447391cc6f882caaf7f1ba64cff06e07
+MD5 (nhc98/patch-1.10-keywords) = 6d25095fa09626ce088daba7e7c70e48
+MD5 (nhc98/patch-1.10-lhs) = 99883604c9d7fabebf5d2c5932f4c090
+MD5 (nhc98/patch-1.10-patterns) = 605013e0a7678fe7789e5ccb917018bf
+MD5 (nhc98/patch-1.10-hiding) = 9203ebd44bda7db58f5ba8cd92861645
+MD5 (nhc98/patch-1.10-ghc5.02) = f7eb18ac28feb431f651b5e571724bc9
diff --git a/devel/hs-hat/files/patch-include::Array.hi b/devel/hs-hat/files/patch-include::Array.hi
new file mode 100644
index 000000000000..30613af20c78
--- /dev/null
+++ b/devel/hs-hat/files/patch-include::Array.hi
@@ -0,0 +1,12 @@
+diff -ruN include.bak/Array.hi include/Array.hi
+--- include.bak/Array.hi Tue Sep 18 12:50:40 2001
++++ include/Array.hi Fri Dec 21 23:25:13 2001
+@@ -113,7 +113,7 @@
+ {-# NEED _tupleRange #-}
+ _tupleRange{-# 3 #-}::(Ix a) => (a -> (a -> ([(a -> b)] -> [b])));
+
+-{-# NEED {Ix range index inRange} #-}
++{-# NEED {Ix range index inRange rangeSize} #-}
+ class (Prelude.Ord a) => Ix a where {
+ range{-# 1 #-}::((a,a) -> [a]);
+ index{-# 2 #-}::((a,a) -> (a -> Prelude.Int));
diff --git a/devel/hs-hat/pkg-plist b/devel/hs-hat/pkg-plist
index 9f4b2f4c98f3..f4a41b853e31 100644
--- a/devel/hs-hat/pkg-plist
+++ b/devel/hs-hat/pkg-plist
@@ -53,11 +53,6 @@ lib/nhc98/ix86-FreeBSD/Older
%%TRACER%%lib/nhc98/ix86-FreeBSD/FFI.z.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/GreenCard.z.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/Haskell.z.a
-%%TRACER%%lib/nhc98/ix86-FreeBSD/HatExpressionTree.o
-%%TRACER%%lib/nhc98/ix86-FreeBSD/HatTrace.o
-%%TRACER%%lib/nhc98/ix86-FreeBSD/HatTrie.o
-%%TRACER%%lib/nhc98/ix86-FreeBSD/Hatdetect.o
-%%TRACER%%lib/nhc98/ix86-FreeBSD/Hatobserve.o
%%TRACER%%lib/nhc98/ix86-FreeBSD/IO.z.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/IOExtras.z.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/Ix.z.a
@@ -76,8 +71,6 @@ lib/nhc98/ix86-FreeBSD/Older
%%TRACER%%lib/nhc98/ix86-FreeBSD/Prelude.T.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/Prelude.p.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/PreludeAll.z.a
-%%TRACER%%lib/nhc98/ix86-FreeBSD/PrettyExp.o
-%%TRACER%%lib/nhc98/ix86-FreeBSD/PrettyLib.o
%%TRACER%%lib/nhc98/ix86-FreeBSD/Random.z.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/Ratio.z.a
%%TRACER%%lib/nhc98/ix86-FreeBSD/Runtime.T.a
@@ -128,6 +121,7 @@ include/nhc98/GreenCard.T.hi
include/nhc98/GreenCard.gc
include/nhc98/GreenCard.hi
include/nhc98/Haskell.hi
+include/nhc98/Hat.hi
include/nhc98/HatBuiltin.hi
include/nhc98/HsFFI.h
include/nhc98/IO.T.hi
@@ -166,7 +160,9 @@ include/nhc98/Ratio.hi
include/nhc98/System.T.hi
include/nhc98/System.hi
include/nhc98/Time.hi
+include/nhc98/TPrelude.hi
include/nhc98/Warning.hi
+include/nhc98/art.h
include/nhc98/bytecode.h
include/nhc98/bytecode_o.h
include/nhc98/cinterface.h
@@ -174,7 +170,6 @@ include/nhc98/codemacros.h
include/nhc98/flt.h
include/nhc98/greencard.h
include/nhc98/haskell2c.h
-include/nhc98/hat.h
include/nhc98/localmalloc.h
include/nhc98/macros_o.h
include/nhc98/mk.h
@@ -209,7 +204,6 @@ include/nhc98/twopass.h
%%PORTDOCS%%share/doc/nhc98/heapprof.html
%%PORTDOCS%%share/doc/nhc98/history.html
%%PORTDOCS%%share/doc/nhc98/history98.html
-%%PORTDOCS%%share/doc/nhc98/hmake.html
%%PORTDOCS%%share/doc/nhc98/index.html
%%PORTDOCS%%share/doc/nhc98/install.html
%%PORTDOCS%%share/doc/nhc98/libraries.html