aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-g77
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2003-11-19 23:31:30 +0000
committerJames E. Housley <jeh@FreeBSD.org>2003-11-19 23:31:30 +0000
commit2f4627bc37ae80de40a55d054f3ce7b1c98adc6b (patch)
treeb0dad8c6828e76420a717d60da8354b0e4d9dcda /devel/i386-rtems-g77
parentab58441d9d1c66621bde8005a5576fdf2f71bc80 (diff)
downloadports-2f4627bc37ae80de40a55d054f3ce7b1c98adc6b.tar.gz
ports-2f4627bc37ae80de40a55d054f3ce7b1c98adc6b.zip
Since once mk/bsd.cpu.mk adds the -mcpu and/or -march flags they can't
be removed. And setting NO_CPU_CFLAGS in a ports Makefile does not help. It might be nice if Mk/bsd.port.mk would remove it if NO_CPU_CFLAGS was set, patch coming soon.
Notes
Notes: svn path=/head/; revision=94415
Diffstat (limited to 'devel/i386-rtems-g77')
-rw-r--r--devel/i386-rtems-g77/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index be6f443749ff..5b29ef4d31c1 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -44,7 +44,6 @@ PKGNAMEPREFIX= ${LCLTARGET}-
USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= all info
-NO_CPUCFLAGS= yes
CONFIGURE_TARGET?= --target=${LCLTARGET}
CONFIGURE_ARGS?= --with-gnu-as --with-gnu-ld --with-newlib --verbose \
@@ -57,7 +56,13 @@ CONFIGURE_SCRIPT?= ../${G77NAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-MAKE_FLAGS= LANGUAGES="f77"
+NO_CPU_FLAGS= true
+MAKE_FLAGS= LANGUAGES="c c++ java"
+MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
+# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
+# by NO_CPU_FLAGS, and since they are added long before here we are
+# stuck with this hack.
+CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//}
pre-configure:
@(cd ${WRKDIR} ; \