aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-g77
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-10-16 00:22:08 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-10-16 00:22:08 +0000
commit6602612e39792614e5847c828c1d405d576a7f5b (patch)
treeb34dd2e80b6f4e38d415a3f9ccc170dfb311d249 /devel/i386-rtems-g77
parent2218402e7248b866bd8903a599505f2ad3d4de92 (diff)
downloadports-6602612e39792614e5847c828c1d405d576a7f5b.tar.gz
ports-6602612e39792614e5847c828c1d405d576a7f5b.zip
Minor update in where the files are fetched from. Maybe now
I will stop getting "Unfetchable distfiles" message for files that do get fetched in the real-world (tm). Suggested by sf, and changed. Also update i386-rtems-g77/Makefile: s/F77/G77/g Submitted by: FUJISHIMA Satsuki <sf@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=48825
Diffstat (limited to 'devel/i386-rtems-g77')
-rw-r--r--devel/i386-rtems-g77/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index 1d714f982868..dc8b32510296 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -10,9 +10,9 @@ PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib
-DISTFILES= ${F77NAME}.tar.gz ${NEWLIBNAME}.tar.gz
-PATCHFILES= ${F77NAME}-rtems-20010622a.diff \
+MASTER_SITE_SUBDIR= newlib gcc/releases/${G77NAME}
+DISTFILES= ${NEWLIBNAME}.tar.gz ${G77NAME}.tar.gz
+PATCHFILES= ${G77NAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
http://rtems.thehousleys.net/
@@ -21,7 +21,7 @@ MAINTAINER= jeh@FreeBSD.org
LCLTARGET?= i386-rtems
-F77NAME= gcc-2.95.3
+G77NAME= gcc-2.95.3
NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-g77
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
@@ -40,7 +40,7 @@ CONFIGURE_TARGET?= --target=${LCLTARGET}
CONFIGURE_ARGS?= --with-gnu-as --with-gnu-ld --with-newlib --verbose \
--enable-languages="f77"
CONFIGURE_WRKSRC?= ${WRKDIR}/build-${LCLTARGET}
-CONFIGURE_SCRIPT?= ../${F77NAME}/configure
+CONFIGURE_SCRIPT?= ../${G77NAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
@@ -49,7 +49,7 @@ MAKE_FLAGS= LANGUAGES="f77"
pre-configure:
@(cd ${WRKDIR} ; \
- cd ${F77NAME} ; ${LN} -fs ../${NEWLIBNAME}/newlib . ; \
+ cd ${G77NAME} ; ${LN} -fs ../${NEWLIBNAME}/newlib . ; \
cd .. ; \
${MKDIR} build-${LCLTARGET})