aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-gdb
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2004-02-21 17:36:00 +0000
committerJames E. Housley <jeh@FreeBSD.org>2004-02-21 17:36:00 +0000
commiteecdd0fef1dfbce9f4c933484c08ea9d37b92c55 (patch)
tree12b5f14e1862f57972155e1357364d117ae562b7 /devel/i386-rtems-gdb
parentfb777a7a11b8ef7459b517a3651b1eddec4f3a3e (diff)
downloadports-eecdd0fef1dfbce9f4c933484c08ea9d37b92c55.tar.gz
ports-eecdd0fef1dfbce9f4c933484c08ea9d37b92c55.zip
Disable building the simulator on sparc until I can figure out how to
make it compile again, > 5.2 only. Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=101584
Diffstat (limited to 'devel/i386-rtems-gdb')
-rw-r--r--devel/i386-rtems-gdb/Makefile17
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.sparc-rtems6
2 files changed, 18 insertions, 5 deletions
diff --git a/devel/i386-rtems-gdb/Makefile b/devel/i386-rtems-gdb/Makefile
index 4a52e955c67e..66a99ff528de 100644
--- a/devel/i386-rtems-gdb/Makefile
+++ b/devel/i386-rtems-gdb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdb
PORTVERSION= 5.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gdb
@@ -21,6 +21,8 @@ PATCHFILES= ${GDBNAME}-rtems-base-20020612.diff \
PATCH_SITES= ftp://ftp.rtems.com/pub/rtems/snapshots/c_tools/source/ \
http://rtems.thehousleys.net/
+.include <bsd.port.pre.mk>
+
LCLTARGET?= i386-rtems
GDBNAME= gdb-5.2
@@ -51,6 +53,17 @@ PATCHFILES+= powerpc-gdb-5.2-hw_sem.c.diff:THN \
PATCH_SITES+= http://rtems.thehousleys.net/:THN
.endif
+.if ${LCLTARGET} == sparc-rtems
+.if (${OSVERSION} >= 502000)
+CONFIGURE_ARGS+= --verbose --disable-sim
+PLIST_SUB+= SPARC_NOSIM='@comment '
+.else
+CONFIGURE_ARGS+= --verbose --enable-sim
+PLIST_SUB+= SPARC_NOSIM=''
+MAN1= ${LCLTARGET}-run.1
+.endif
+.endif
+
MAN1+= ${LCLTARGET}-gdb.1
pre-configure:
@@ -64,4 +77,4 @@ do-install:
@(cd ${WRKDIR}/build-${LCLTARGET} && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/i386-rtems-gdb/pkg-plist.sparc-rtems b/devel/i386-rtems-gdb/pkg-plist.sparc-rtems
index 0ae6820e3526..49c66bc7e7f2 100644
--- a/devel/i386-rtems-gdb/pkg-plist.sparc-rtems
+++ b/devel/i386-rtems-gdb/pkg-plist.sparc-rtems
@@ -1,4 +1,4 @@
bin/sparc-rtems-gdb
-bin/sparc-rtems-run
-bin/sparc-rtems-sis
-lib/libsparc-rtems-sim.a
+%%SPARC_NOSIM%%bin/sparc-rtems-run
+%%SPARC_NOSIM%%bin/sparc-rtems-sis
+%%SPARC_NOSIM%%lib/libsparc-rtems-sim.a