aboutsummaryrefslogtreecommitdiff
path: root/devel/ipython
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /devel/ipython
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'devel/ipython')
-rw-r--r--devel/ipython/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index 26d506d1e226..a14177912acd 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -14,14 +14,14 @@ COMMENT= Enhanced Interactive Python shell
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.rst
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}decorator>=0:devel/py-decorator \
- ${PYTHON_PKGNAMEPREFIX}pickleshare>=0:databases/py-pickleshare \
- ${PYTHON_PKGNAMEPREFIX}prompt_toolkit>=1.0.4:devel/py-prompt_toolkit \
- ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments \
- ${PYTHON_PKGNAMEPREFIX}simplegeneric>0.8:devel/py-simplegeneric \
- ${PYTHON_PKGNAMEPREFIX}traitlets>=4.2:devel/py-traitlets
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:databases/py-sqlite3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}decorator>=0:devel/py-decorator@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pickleshare>=0:databases/py-pickleshare@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prompt_toolkit>=1.0.4:devel/py-prompt_toolkit@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplegeneric>0.8:devel/py-simplegeneric@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=4.2:devel/py-traitlets@${FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
@@ -34,10 +34,10 @@ PORTEXAMPLES= *
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.shutil_get_terminal_size>=0:devel/py-backports.shutil_get_terminal_size
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.shutil_get_terminal_size>=0:devel/py-backports.shutil_get_terminal_size@${FLAVOR}
.endif
.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib2>=0:devel/py-pathlib2
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib2>=0:devel/py-pathlib2@${FLAVOR}
.endif
post-install: