aboutsummaryrefslogtreecommitdiff
path: root/devel/kcachegrind/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-09 19:19:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-09 19:19:41 +0000
commitf797a14ff8ea93520b4717a156f065f91bf67b5f (patch)
tree48606a0d42c756472902fc781e06d4eab3846d19 /devel/kcachegrind/Makefile
parent90bd92c8dacf256364bddb11e16d2b8c8dac78f3 (diff)
downloadports-f797a14ff8ea93520b4717a156f065f91bf67b5f.tar.gz
ports-f797a14ff8ea93520b4717a156f065f91bf67b5f.zip
New ports: KDE Applications devel/
* devel/cervisia * devel/kapptemplate * devel/kcachegrind * devel/kde-dev-scripts * devel/kde-dev-utils * devel/kdesdk-thumbnailers * devel/kio-extras * devel/lokalize * devel/okteta * devel/poxml * devel/umbrello This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Notes
Notes: svn path=/head/; revision=466899
Diffstat (limited to 'devel/kcachegrind/Makefile')
-rw-r--r--devel/kcachegrind/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/kcachegrind/Makefile b/devel/kcachegrind/Makefile
new file mode 100644
index 000000000000..dd48e795b30e
--- /dev/null
+++ b/devel/kcachegrind/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= kcachegrind
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= devel kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Profiler frontend for KDE
+
+USES= cmake:outsource kde:5 python:run shebangfix tar:xz
+USE_KDE= archive auth bookmarks codecs completion config configwidgets \
+ coreaddons ecm i18n itemviews jobwidgets kio service solid \
+ widgetsaddons xmlgui
+USE_QT5= core dbus gui network widgets xml \
+ buildtools_build qmake_build
+
+SHEBANG_FILES= converters/hotshot2calltree.cmake \
+ converters/memprof2calltree \
+ converters/op2calltree converters/dprof2calltree
+
+OPTIONS_DEFINE= DOT VALGRIND
+
+DOT_DESC= Use GraphViz/dot to render call graphs
+DOT_RUN_DEPENDS= dot:graphics/graphviz
+
+VALGRIND_DESC= Install devel/valgrind
+VALGRIND_RUN_DEPENDS= valgrind:devel/valgrind
+
+.include <bsd.port.mk>