aboutsummaryrefslogtreecommitdiff
path: root/devel/kde-dev-scripts
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /devel/kde-dev-scripts
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!
Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
Notes
Notes: svn path=/head/; revision=344893
Diffstat (limited to 'devel/kde-dev-scripts')
-rw-r--r--devel/kde-dev-scripts/Makefile25
-rw-r--r--devel/kde-dev-scripts/distinfo2
-rw-r--r--devel/kde-dev-scripts/pkg-descr1
-rw-r--r--devel/kde-dev-scripts/pkg-plist74
4 files changed, 102 insertions, 0 deletions
diff --git a/devel/kde-dev-scripts/Makefile b/devel/kde-dev-scripts/Makefile
new file mode 100644
index 000000000000..5bc184150bbb
--- /dev/null
+++ b/devel/kde-dev-scripts/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= kde-dev-scripts
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= devel kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE development scripts
+
+USES= cmake:outsource shebangfix
+USE_KDE4= kdelibs kdeprefix kdehier automoc4
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+
+SHEBANG_FILES= cxxmetric \
+ draw_lib_dependencies \
+ fixkdeincludes \
+ fixuifiles \
+ krazy-licensecheck \
+ png2mng.pl \
+ svnintegrate
+
+.include <bsd.port.mk>
diff --git a/devel/kde-dev-scripts/distinfo b/devel/kde-dev-scripts/distinfo
new file mode 100644
index 000000000000..75e85c50fb2e
--- /dev/null
+++ b/devel/kde-dev-scripts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/kde-dev-scripts-4.12.2.tar.xz) = a9f6bc1d429af758375b2920c45579f925e68ef5d007580cae1865eeff68ee5b
+SIZE (KDE/4.12.2/kde-dev-scripts-4.12.2.tar.xz) = 257148
diff --git a/devel/kde-dev-scripts/pkg-descr b/devel/kde-dev-scripts/pkg-descr
new file mode 100644
index 000000000000..969f392608a5
--- /dev/null
+++ b/devel/kde-dev-scripts/pkg-descr
@@ -0,0 +1 @@
+KDE development scripts.
diff --git a/devel/kde-dev-scripts/pkg-plist b/devel/kde-dev-scripts/pkg-plist
new file mode 100644
index 000000000000..1b608c0c248b
--- /dev/null
+++ b/devel/kde-dev-scripts/pkg-plist
@@ -0,0 +1,74 @@
+bin/adddebug
+bin/build-progress.sh
+bin/cheatmake
+bin/colorsvn
+bin/create_cvsignore
+bin/create_makefile
+bin/create_makefiles
+bin/create_svnignore
+bin/cvs-clean
+bin/cvsaddcurrentdir
+bin/cvsbackport
+bin/cvsblame
+bin/cvscheck
+bin/cvsforwardport
+bin/cvslastchange
+bin/cvslastlog
+bin/cvsrevertlast
+bin/cvsversion
+bin/cxxmetric
+bin/draw_lib_dependencies
+bin/extend_dmalloc
+bin/extractattr
+bin/extractrc
+bin/findmissingcrystal
+bin/fix-include.sh
+bin/fixkdeincludes
+bin/fixuifiles
+bin/includemocs
+bin/kde-systemsettings-tree.py
+bin/kde_generate_export_header
+bin/kdedoc
+bin/kdekillall
+bin/kdelnk2desktop.py
+bin/kdemangen.pl
+bin/krazy-licensecheck
+bin/makeobj
+bin/noncvslist
+bin/nonsvnlist
+bin/optimizegraphics
+bin/package_crystalsvg
+bin/png2mng.pl
+bin/pruneemptydirs
+bin/qtdoc
+bin/reviewboard-am
+bin/svn-clean
+bin/svnbackport
+bin/svnchangesince
+bin/svnforwardport
+bin/svngettags
+bin/svnintegrate
+bin/svnlastchange
+bin/svnlastlog
+bin/svnrevertlast
+bin/svnversions
+bin/wcgrep
+bin/zonetab2pot.py
+man/man1/adddebug.1.gz
+man/man1/cheatmake.1.gz
+man/man1/create_cvsignore.1.gz
+man/man1/create_makefile.1.gz
+man/man1/create_makefiles.1.gz
+man/man1/cvscheck.1.gz
+man/man1/cvslastchange.1.gz
+man/man1/cvslastlog.1.gz
+man/man1/cvsrevertlast.1.gz
+man/man1/cxxmetric.1.gz
+man/man1/extend_dmalloc.1.gz
+man/man1/extractrc.1.gz
+man/man1/fixincludes.1.gz
+man/man1/pruneemptydirs.1.gz
+man/man1/qtdoc.1.gz
+man/man1/reportview.1.gz
+man/man1/transxx.1.gz
+man/man1/zonetab2pot.py.1.gz