aboutsummaryrefslogtreecommitdiff
path: root/devel/kdesdk3/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-06-05 10:59:43 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-06-05 10:59:43 +0000
commitbf492587b14d600a8b92b7f8f4ec6853a7a77d0f (patch)
tree3d4008936d2f6e9760e36402a8534e4f9c637932 /devel/kdesdk3/Makefile
parentcf6781f7cff52dfe912219a016ecc4d9b80b25d3 (diff)
downloadports-bf492587b14d600a8b92b7f8f4ec6853a7a77d0f.tar.gz
ports-bf492587b14d600a8b92b7f8f4ec6853a7a77d0f.zip
Switch optional dependency from removed devel/callgrind to devel/valgrind
Clean up a bit while here PR: ports/147437 Reported by: Anatoly Borodin <anatoly.borodin AT gmail.com>
Notes
Notes: svn path=/head/; revision=255760
Diffstat (limited to 'devel/kdesdk3/Makefile')
-rw-r--r--devel/kdesdk3/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/devel/kdesdk3/Makefile b/devel/kdesdk3/Makefile
index 108124656e13..d034f3142333 100644
--- a/devel/kdesdk3/Makefile
+++ b/devel/kdesdk3/Makefile
@@ -22,13 +22,12 @@ LIB_DEPENDS= svn_client-1.0:${PORTSDIR}/devel/subversion
CONFLICTS= umbrello-[0-9]* kcachegrind-[0-9]*
USE_KDEBASE_VER=3
-PREFIX= ${KDE_PREFIX}
USE_PERL5= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_BDB= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
@@ -42,20 +41,13 @@ CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
MAN1= cervisia.1 cvsblame.1 cvscheck.1 cvsversion.1 includemocs.1 kde-build.1 kdesvn-build.1 noncvslist.1
+OPTIONS= VALGRIND "Install devel/valgrind" off
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-pre-everything::
-.if !defined(WITH_OPTIONAL_DEPENDS)
- @${ECHO_MSG}
- @${ECHO_MSG} "You may define WITH_OPTIONAL_DEPENDS (make WITH_OPTIONAL_DEPENDS=YES)"
- @${ECHO_MSG} "to automatically build the suggested programs to complement kdesdk3."
- @${ECHO_MSG}
-.endif
-
-# callgrind is optional. It depends on valgrind, which is i386 only.
-.if defined(WITH_OPTIONAL_DEPENDS) && ${ARCH} == "i386"
-RUN_DEPENDS+= callgrind:${PORTSDIR}/devel/callgrind
+.if defined(WITH_VALGRIND)
+RUN_DEPENDS+= valgrind:${PORTSDIR}/devel/valgrind
.endif
post-patch: