aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-kitemmodels/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 22:14:10 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 17:36:35 +0000
commitc0f139b89306c012b33bdd4d676b107305ba3e06 (patch)
tree02588523ca26bd83647873708e04d2c1bdd56495 /devel/kf5-kitemmodels/Makefile
parentba93bcdc15399175b77e3ae109a6ed37807b1364 (diff)
downloadports-c0f139b89306c012b33bdd4d676b107305ba3e06.tar.gz
ports-c0f139b89306c012b33bdd4d676b107305ba3e06.zip
*/kf5-*: (KDE Frameworks) lighten dependencies
- ECM (extra-cmake-modules) is only ever a build-dep and was missing in some places where it was previously pulled in implicitly - Qt testlib is only a build-dep While here - conventionally, the _build and _run items in USE_KDE and USE_QT are sorted to the end, and they start a new line in the Makefile - remove tcberner's created-line (confirmed on IRC) - use DISTVERSION everywhere - reduce inter-framework dependencies using the tooling proposed by tcberner in https://reviews.freebsd.org/D27304 Some PORTREVISION may have jumped by more than 1, since this commit is a squash of a long string of updates where I may have bumped a port once for ecm_build, and a second time for other lightening-up.
Diffstat (limited to 'devel/kf5-kitemmodels/Makefile')
-rw-r--r--devel/kf5-kitemmodels/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/kf5-kitemmodels/Makefile b/devel/kf5-kitemmodels/Makefile
index 8535a1e451c2..274ff3686c3a 100644
--- a/devel/kf5-kitemmodels/Makefile
+++ b/devel/kf5-kitemmodels/Makefile
@@ -1,12 +1,13 @@
PORTNAME= kitemmodels
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 models for Qt Model/View system
USES= cmake compiler:c++11-lib kde:5 qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm_build
USE_QT= core declarative network \
buildtools_build qmake_build testlib_build