aboutsummaryrefslogtreecommitdiff
path: root/devel/kyra/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-26 14:11:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-26 14:11:35 +0000
commit9e8881703e37fd60633033bb758db6940cbbff3c (patch)
tree856d89fa391fd0153ae07ee10860006069ad96d1 /devel/kyra/Makefile
parentf230d27c660c74a7fe2986e544c5dc04245b733f (diff)
downloadports-9e8881703e37fd60633033bb758db6940cbbff3c.tar.gz
ports-9e8881703e37fd60633033bb758db6940cbbff3c.zip
- Update to 2.1.3
PR: v176562 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=315293
Diffstat (limited to 'devel/kyra/Makefile')
-rw-r--r--devel/kyra/Makefile48
1 files changed, 31 insertions, 17 deletions
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index 8d86f75e13a7..6b0895018fd2 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -1,32 +1,46 @@
-# New ports collection makefile for: kyra
-# Date created: 10.05.2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
-#
PORTNAME= kyra
-PORTVERSION= 2.0.7
-PORTREVISION= 12
+PORTVERSION= 2.1.3
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2/${PORTVERSION}
DISTNAME= ${PORTNAME}_src_${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A simple Sprite engine written in C++
+COMMENT= Simple Sprite engine written in C++
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LICENSE= GPLv2
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png15:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_AUTOTOOLS= libtool
+USE_ZIP= yes
+USE_GL= gl
USE_SDL= image sdl
-USE_GNOME= lthack
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
+USE_GMAKE= yes
+MAKEFILE= MakefileKyra
+MAKE_ENV= MAKE_KYRA=RELEASE KYRA_OPENGL=YES
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
+ RELEASE_CFLAGS="${CFLAGS}" RELEASE_CXXFLAGS="${CXXFLAGS}"
+MAKE_JOBS_SAFE= yes
+
+do-install:
+.for i in encoder spriteed
+ (cd ${WRKSRC}/${i} && ${INSTALL_PROGRAM} kr${i} ${PREFIX}/bin)
+.endfor
+ (cd ${WRKSRC}/engine && ${INSTALL_DATA} libkyra.a ${PREFIX}/lib)
+ @${MKDIR} ${PREFIX}/include/Kyra
+ (cd ${WRKSRC} && ${INSTALL_DATA} kyra.h ${PREFIX}/include/Kyra)
+.for i in engine gui guiExtended util
+ @${MKDIR} ${PREFIX}/include/Kyra/${i}
+ (cd ${WRKSRC}/${i} && ${INSTALL_DATA} *.h ${PREFIX}/include/Kyra/${i})
+.endfor
+ @${MKDIR} ${PREFIX}/include/Kyra/tinyxml
+ (cd ${WRKSRC}/../tinyxml && ${INSTALL_DATA} *.h \
+ ${PREFIX}/include/Kyra/tinyxml)
.include <bsd.port.mk>