aboutsummaryrefslogtreecommitdiff
path: root/devel/lcov
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-07-24 08:52:02 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-07-24 08:52:02 +0000
commit681f53e6c5feaf7c0d4653d33b6bb6c43712bbbc (patch)
tree8b0fb13e089f542d2eb469e0f7e8247eda297c15 /devel/lcov
parent134cd0581eeb0eb845128255ef658e59e2f9590e (diff)
downloadports-681f53e6c5feaf7c0d4653d33b6bb6c43712bbbc.tar.gz
ports-681f53e6c5feaf7c0d4653d33b6bb6c43712bbbc.zip
LCOV is a graphical front-end for GCC's coverage testing tool gcov. It collects
gcov data for multiple source files and creates HTML pages containing the source code annotated with coverage information. It also adds overview pages for easy navigation within the file structure. WWW: http://ltp.sourceforge.net/coverage/lcov.php
Notes
Notes: svn path=/head/; revision=258134
Diffstat (limited to 'devel/lcov')
-rw-r--r--devel/lcov/Makefile31
-rw-r--r--devel/lcov/distinfo3
-rw-r--r--devel/lcov/pkg-descr6
3 files changed, 40 insertions, 0 deletions
diff --git a/devel/lcov/Makefile b/devel/lcov/Makefile
new file mode 100644
index 000000000000..d5af5eb5dc49
--- /dev/null
+++ b/devel/lcov/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: lcov
+# Date created: 2010-02-11
+# Whom: Romain Tartiere <romain@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lcov
+PORTVERSION= 1.8
+CATEGORIES= devel
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=ltp/Coverage%20Analysis/LCOV-1.8
+
+MAINTAINER= romain@FreeBSD.org
+COMMENT= The Linux Test Project GCOV extension
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/lcov bin/gendesc bin/genhtml bin/genpng bin/geninfo
+MAN1= gendesc.1 genhtml.1 geninfo.1 genpng.1 lcov.1
+MAN5= lcovrc.5
+
+do-install:
+ cd ${WRKSRC}/bin && ${COPYTREE_BIN} "gendesc genhtml geninfo genpng lcov" ${PREFIX}/bin
+ cd ${WRKSRC}/man && ${INSTALL_MAN} *.1 ${MANPREFIX}/man/man1
+ cd ${WRKSRC}/man && ${INSTALL_MAN} *.5 ${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/devel/lcov/distinfo b/devel/lcov/distinfo
new file mode 100644
index 000000000000..996ccd312f23
--- /dev/null
+++ b/devel/lcov/distinfo
@@ -0,0 +1,3 @@
+MD5 (lcov-1.8.tar.gz) = a909d9145111c6133c65b9dce007d7a1
+SHA256 (lcov-1.8.tar.gz) = f2a8bb2a328ac678579f43a7d177f6db46797013e7ec64698ad3bf00974a2df7
+SIZE (lcov-1.8.tar.gz) = 131581
diff --git a/devel/lcov/pkg-descr b/devel/lcov/pkg-descr
new file mode 100644
index 000000000000..45d21e6676ad
--- /dev/null
+++ b/devel/lcov/pkg-descr
@@ -0,0 +1,6 @@
+LCOV is a graphical front-end for GCC's coverage testing tool gcov. It collects
+gcov data for multiple source files and creates HTML pages containing the
+source code annotated with coverage information. It also adds overview pages
+for easy navigation within the file structure.
+
+WWW: http://ltp.sourceforge.net/coverage/lcov.php