aboutsummaryrefslogtreecommitdiff
path: root/devel/liballium
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-23 14:43:06 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-23 14:43:06 +0000
commit35650d71bf17c5e434a5c2d1ce23dec2758d5111 (patch)
tree5852df44a40c4331bb77fe336ff41a850483058a /devel/liballium
parent8290033cad6cd2fe16b5748b086e078f53deb82e (diff)
downloadports-35650d71bf17c5e434a5c2d1ce23dec2758d5111.tar.gz
ports-35650d71bf17c5e434a5c2d1ce23dec2758d5111.zip
Add devel/liballium and security/obfsclient.
liballium attempts to reduce the amount of boilerplate code required to implement pluggable transports for Tor in C or C++. WWW: https://github.com/yawning/liballium obfsclient is a C++11 Tor-managed pluggable transport client implementation of the following protocols: obfs2 - The Twobfuscator obfs3 - The Threebfuscator ScrambleSuit - Experimental WWW: https://github.com/yawning/obfsclient PR: 187926, 187927 Submitted by: fk@fabiankeil.de
Notes
Notes: svn path=/head/; revision=365738
Diffstat (limited to 'devel/liballium')
-rw-r--r--devel/liballium/Makefile39
-rw-r--r--devel/liballium/distinfo2
-rw-r--r--devel/liballium/pkg-descr4
-rw-r--r--devel/liballium/pkg-plist11
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/liballium/Makefile b/devel/liballium/Makefile
new file mode 100644
index 000000000000..d20aeb50c53a
--- /dev/null
+++ b/devel/liballium/Makefile
@@ -0,0 +1,39 @@
+# Created by: Fabian Keil <fk@fabiankeil.de>
+# $FreeBSD$
+
+PORTNAME= liballium
+PORTVERSION= 0.0.1
+CATEGORIES= devel security
+MASTER_SITES= GH
+DISTNAME= g-${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-${GH_COMMIT}
+
+MAINTAINER= fk@fabiankeil.de
+COMMENT= Tor pluggable transports utility library
+
+USE_GITHUB= yes
+GH_ACCOUNT= Yawning
+GH_COMMIT= 0c9b50f
+GH_TAGNAME= ${GH_COMMIT}
+
+GNU_CONFIGURE= yes
+USES= libtool:build pkgconfig tar:bzip2 pathfix
+USE_AUTOTOOLS= autoconf aclocal automake
+USE_LDCONFIG= yes
+
+PLIST_SUB+= PKGNAME=${PKGNAME}
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -E -e "s@^(pkgconfigdir =) .*@\1 ${LOCALBASE}/libdata/pkgconfig@" \
+ ${WRKSRC}/Makefile.am
+
+pre-configure:
+ @(cd ${WRKSRC}; ./autogen.sh)
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/liballium/distinfo b/devel/liballium/distinfo
new file mode 100644
index 000000000000..322bc16c1895
--- /dev/null
+++ b/devel/liballium/distinfo
@@ -0,0 +1,2 @@
+SHA256 (g-Yawning-liballium-0.0.1-0c9b50f.tar.bz2) = cf621145ae328d3694fda1231a645cf91ccc5fcd7edfaf263a21e20d9e48853d
+SIZE (g-Yawning-liballium-0.0.1-0c9b50f.tar.bz2) = 39938
diff --git a/devel/liballium/pkg-descr b/devel/liballium/pkg-descr
new file mode 100644
index 000000000000..8d7d4a4e1e6c
--- /dev/null
+++ b/devel/liballium/pkg-descr
@@ -0,0 +1,4 @@
+liballium attempts to reduce the amount of boilerplate code required to
+implement pluggable transports for Tor in C or C++.
+
+WWW: https://github.com/yawning/liballium
diff --git a/devel/liballium/pkg-plist b/devel/liballium/pkg-plist
new file mode 100644
index 000000000000..b32e3e8c7c29
--- /dev/null
+++ b/devel/liballium/pkg-plist
@@ -0,0 +1,11 @@
+include/allium/allium.h
+include/allium/allium_ptcfg.h
+include/allium/bstrlib.h
+lib/liballium-1.0.a
+lib/liballium-1.0.so
+lib/liballium-1.0.so.0
+lib/liballium-1.0.so.0.0.1
+libdata/pkgconfig/liballium-1.0.pc
+@dirrmtry include/allium
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%@dirrm %%DOCSDIR%%