aboutsummaryrefslogtreecommitdiff
path: root/devel/libassetml/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-02-27 08:45:45 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-02-27 08:45:45 +0000
commitd5ad5ae32b1aefb703fa408611d05e832a07018d (patch)
tree734a01b6b1ff8bdacbaccafbb76f37eb09bb4535 /devel/libassetml/Makefile
parent9d3619961ec4505fe1322822a9878abbf07954cf (diff)
downloadports-d5ad5ae32b1aefb703fa408611d05e832a07018d.tar.gz
ports-d5ad5ae32b1aefb703fa408611d05e832a07018d.zip
Add libassetml 1.2.1, devel Library to share image and audio files
between projects.
Notes
Notes: svn path=/head/; revision=102271
Diffstat (limited to 'devel/libassetml/Makefile')
-rw-r--r--devel/libassetml/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/libassetml/Makefile b/devel/libassetml/Makefile
new file mode 100644
index 000000000000..0fb6057143d3
--- /dev/null
+++ b/devel/libassetml/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libassetml
+# Date created: 2 Dec 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libassetml
+PORTVERSION= 1.2.1
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ofset
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Devel Library to share image and audio files between projects
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack lthack gnomeprefix gnometarget libxml2 pkgconfig
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+
+INFO= libassetml
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/gnome/assetml
+
+.include <bsd.port.mk>