aboutsummaryrefslogtreecommitdiff
path: root/devel/libastylej/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2018-12-02 20:37:44 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2018-12-02 20:37:44 +0000
commita543540a81a86d998a0f8d5fc41418a635e5f474 (patch)
treefdf73cdf67e4361717efbf85e0b7509ce580c470 /devel/libastylej/Makefile
parent88473fafc11c297a06ceab02537aee32118c3b1b (diff)
downloadports-a543540a81a86d998a0f8d5fc41418a635e5f474.tar.gz
ports-a543540a81a86d998a0f8d5fc41418a635e5f474.zip
devel/libastylej: respect CXX
PR: 233704 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=486484
Diffstat (limited to 'devel/libastylej/Makefile')
-rw-r--r--devel/libastylej/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/libastylej/Makefile b/devel/libastylej/Makefile
index 329091762f6f..3b60317f7df0 100644
--- a/devel/libastylej/Makefile
+++ b/devel/libastylej/Makefile
@@ -15,7 +15,7 @@ LICENSE= LGPL3
ALL_TARGET= java
LDFLAGS+= -s
-USES= compiler gmake
+USES= compiler:c++11-lang gmake
USE_JAVA= yes
USE_LDCONFIG= yes
MAKE_ARGS+= JAVA_HOME=${JAVA_HOME}
@@ -27,6 +27,7 @@ PLIST_FILES= lib/jni/libastylej${PKGNAMESUFFIX}.so lib/jni/libastylej${PKGNAMESU
post-patch:
${REINPLACE_CMD} -e 's,\(JAVAINCS.*=.*\),\1 -I$(JAVA_HOME)/include/freebsd,' \
-e '176 s,libastylej\.so,libastylej${PKGNAMESUFFIX}\.so,2' \
+ -e 's/CXX = g++/CXX ?= g++/' \
${WRKSRC}/Makefile
do-install: