aboutsummaryrefslogtreecommitdiff
path: root/devel/libb2/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2018-10-05 00:15:26 +0000
committerMartin Matuska <mm@FreeBSD.org>2018-10-05 00:15:26 +0000
commit0eba313e3d6cb55edac988cb0431f855a531e19e (patch)
tree6a9161cc0db4bca4b27ac5dd9cf51c0f0bb0ac4a /devel/libb2/Makefile
parenta31f3edca24d98320d0dfb2a288ee77b0f91fdb7 (diff)
downloadports-0eba313e3d6cb55edac988cb0431f855a531e19e.tar.gz
ports-0eba313e3d6cb55edac988cb0431f855a531e19e.zip
Add a new port: devel/libb2
Notes
Notes: svn path=/head/; revision=481256
Diffstat (limited to 'devel/libb2/Makefile')
-rw-r--r--devel/libb2/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/libb2/Makefile b/devel/libb2/Makefile
new file mode 100644
index 000000000000..06faa0edd618
--- /dev/null
+++ b/devel/libb2/Makefile
@@ -0,0 +1,21 @@
+# Created by: Martin Matuska <mm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libb2
+PORTVERSION= 0.98
+CATEGORIES= devel
+MASTER_SITES= GH
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp
+
+LICENSE= CC0-1.0
+
+USES= autoreconf libtool
+USE_GITHUB= yes
+
+GH_ACCOUNT= BLAKE2
+GH_TAGNAME= v${PORTVERSION}
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>