aboutsummaryrefslogtreecommitdiff
path: root/devel/libc++
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-29 23:46:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-29 23:46:13 +0000
commit4d92814f8401cd0942c722921fce46239a01c313 (patch)
tree5e931c5c9e4a81bdb513e5030f1b24a1d440e701 /devel/libc++
parent4346032a222313635bf15480e16e16f34797f4b1 (diff)
downloadports-4d92814f8401cd0942c722921fce46239a01c313.tar.gz
ports-4d92814f8401cd0942c722921fce46239a01c313.zip
Update to r200401
Use libcxxrt from ports if not in base Add stage support Convert libc++.so into a ldscript Create a testing lib/c++/libstdc++ ldscript to cheat with g++
Notes
Notes: svn path=/head/; revision=341794
Diffstat (limited to 'devel/libc++')
-rw-r--r--devel/libc++/Makefile41
-rw-r--r--devel/libc++/Makefile.svn_rev2
-rw-r--r--devel/libc++/distinfo4
-rw-r--r--devel/libc++/pkg-plist149
4 files changed, 169 insertions, 27 deletions
diff --git a/devel/libc++/Makefile b/devel/libc++/Makefile
index 17a51b73119b..757c1a8597ea 100644
--- a/devel/libc++/Makefile
+++ b/devel/libc++/Makefile
@@ -4,41 +4,36 @@
PORTNAME= libc++
PORTVERSION= ${SVN_REV}
CATEGORIES= devel
-MASTER_SITES= LOCAL/kwm
+MASTER_SITES= http://files.etoilebsd.net/libc++/ \
+ LOCAL/bapt
MAINTAINER= bapt@FreeBSD.org
COMMENT= Llvm's C++ standard library with c++11 support
-BUILD_DEPENDS= clang33:${PORTSDIR}/lang/clang33
+LIB_DEPENDS= libcxxrt.so:${PORTSDIR}/devel/libcxxrt
LICENSE_GROUP= MIT UIUC
LICENSE_NAME_UIUC= University of Illinois/NCSA Open Source License
LICENSE_PERMS_UIUC= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USE_BZIP2= yes
-USES= cmake:outsource
+USE_XZ= yes
+USES= cmake:outsource compiler:c++11-lang
USE_LDCONFIG= yes
+LDFLAGS+= -L${LOCALBASE}/lib
-CC= clang33
-CXX= clang++33
-CPP= clang-cpp33
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 901502
-IGNORE= Doesn't build due to lack of aligned_alloc()
+.if exists(/usr/lib/libcxxrt.so)
+CXXRT_INCS= /usr/include/c++/v1/
+.else
+CXXRT_INCS= /usr/local/include/cxxrt/
.endif
-# This check can be replaced with a compiler groks c++11. Suggestions welcome.
-.if ${OSVERSION} >= 1000019
-IGNORE= libc++ is in base please use that
-.endif
+CMAKE_ARGS= -DLIBCXX_CXX_ABI=libcxxrt -DLIBCXX_LIBCXXRT_INCLUDE_PATHS=${CXXRT_INCS}
.if !defined(SVN_REV)
.if defined(BOOTSTRAP)
-LANG= "C"
-SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d' ' -f2
+SVN_REV!= LC_ALL=C svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d' ' -f2
.else
.include "Makefile.svn_rev"
.endif
@@ -50,11 +45,19 @@ FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
do-fetch:
${MKDIR} ${WRKDIR}
svn export -r ${SVN_REV} \
- http://llvm.org/svn/llvm-project/libcxx/trunk ${WRKSRC}
- cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+ http://llvm.org/svn/llvm-project/libcxx/trunk \
+ ${WRKSRC}
+ cd ${WRKDIR}; tar cfJ ${DISTDIR}/${DISTNAME}.tar.xz ${DISTNAME}
echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
.endif
+post-install:
+ ${LN} -sf c++/v1 ${STAGEDIR}${PREFIX}/include/c++/v1/tr1
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libc++.so
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/c++/
+ ${ECHO} 'GROUP ( ${PREFIX}/lib/libc++.so.1 ${LOCALBASE}/lib/libcxxrt.so)' > ${STAGEDIR}${PREFIX}/lib/libc++.so
+ ${ECHO} 'GROUP ( ${PREFIX}/lib/libc++.so.1 ${LOCALBASE}/lib/libcxxrt.so)' > ${STAGEDIR}${PREFIX}/lib/c++/libstdc++.so
+
regression-test: build
cd ${WRKSRC}/test && ${SH} ./testit
diff --git a/devel/libc++/Makefile.svn_rev b/devel/libc++/Makefile.svn_rev
index a039785a0f87..39a2afba999d 100644
--- a/devel/libc++/Makefile.svn_rev
+++ b/devel/libc++/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 185324
+SVN_REV= 200401
diff --git a/devel/libc++/distinfo b/devel/libc++/distinfo
index ed3432aa41fd..d69d148eb191 100644
--- a/devel/libc++/distinfo
+++ b/devel/libc++/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libc++-185324.tar.bz2) = fe074d4c969170075e906191b629d65c854962ec326b3d3c88c95fa384e64b8c
-SIZE (libc++-185324.tar.bz2) = 864599
+SHA256 (libc++-200401.tar.xz) = 7ccb493d658a46bb0187283cf9c9345989dc5a4a981f29efa0df1f44578e8a6f
+SIZE (libc++-200401.tar.xz) = 856836
diff --git a/devel/libc++/pkg-plist b/devel/libc++/pkg-plist
index dfbe8104500b..2b8ee0506868 100644
--- a/devel/libc++/pkg-plist
+++ b/devel/libc++/pkg-plist
@@ -1,3 +1,6 @@
+include/c++/v1/CMakeFiles/CMakeDirectoryInformation.cmake
+include/c++/v1/CMakeFiles/progress.marks
+include/c++/v1/Makefile
include/c++/v1/__bit_reference
include/c++/v1/__config
include/c++/v1/__debug
@@ -18,6 +21,117 @@ include/c++/v1/algorithm
include/c++/v1/array
include/c++/v1/atomic
include/c++/v1/bitset
+include/c++/v1/c++/v1/__bit_reference
+include/c++/v1/c++/v1/__config
+include/c++/v1/c++/v1/__debug
+include/c++/v1/c++/v1/__functional_03
+include/c++/v1/c++/v1/__functional_base
+include/c++/v1/c++/v1/__functional_base_03
+include/c++/v1/c++/v1/__hash_table
+include/c++/v1/c++/v1/__locale
+include/c++/v1/c++/v1/__mutex_base
+include/c++/v1/c++/v1/__split_buffer
+include/c++/v1/c++/v1/__sso_allocator
+include/c++/v1/c++/v1/__std_stream
+include/c++/v1/c++/v1/__tree
+include/c++/v1/c++/v1/__tuple
+include/c++/v1/c++/v1/__tuple_03
+include/c++/v1/c++/v1/__undef_min_max
+include/c++/v1/c++/v1/algorithm
+include/c++/v1/c++/v1/array
+include/c++/v1/c++/v1/atomic
+include/c++/v1/c++/v1/bitset
+include/c++/v1/c++/v1/cassert
+include/c++/v1/c++/v1/ccomplex
+include/c++/v1/c++/v1/cctype
+include/c++/v1/c++/v1/cerrno
+include/c++/v1/c++/v1/cfenv
+include/c++/v1/c++/v1/cfloat
+include/c++/v1/c++/v1/chrono
+include/c++/v1/c++/v1/cinttypes
+include/c++/v1/c++/v1/ciso646
+include/c++/v1/c++/v1/climits
+include/c++/v1/c++/v1/clocale
+include/c++/v1/c++/v1/cmath
+include/c++/v1/c++/v1/codecvt
+include/c++/v1/c++/v1/complex
+include/c++/v1/c++/v1/complex.h
+include/c++/v1/c++/v1/condition_variable
+include/c++/v1/c++/v1/csetjmp
+include/c++/v1/c++/v1/csignal
+include/c++/v1/c++/v1/cstdarg
+include/c++/v1/c++/v1/cstdbool
+include/c++/v1/c++/v1/cstddef
+include/c++/v1/c++/v1/cstdint
+include/c++/v1/c++/v1/cstdio
+include/c++/v1/c++/v1/cstdlib
+include/c++/v1/c++/v1/cstring
+include/c++/v1/c++/v1/ctgmath
+include/c++/v1/c++/v1/ctime
+include/c++/v1/c++/v1/cwchar
+include/c++/v1/c++/v1/cwctype
+include/c++/v1/c++/v1/deque
+include/c++/v1/c++/v1/exception
+include/c++/v1/c++/v1/experimental/dynarray
+include/c++/v1/c++/v1/experimental/optional
+include/c++/v1/c++/v1/ext/__hash
+include/c++/v1/c++/v1/ext/hash_map
+include/c++/v1/c++/v1/ext/hash_set
+include/c++/v1/c++/v1/forward_list
+include/c++/v1/c++/v1/fstream
+include/c++/v1/c++/v1/functional
+include/c++/v1/c++/v1/future
+include/c++/v1/c++/v1/initializer_list
+include/c++/v1/c++/v1/iomanip
+include/c++/v1/c++/v1/ios
+include/c++/v1/c++/v1/iosfwd
+include/c++/v1/c++/v1/iostream
+include/c++/v1/c++/v1/istream
+include/c++/v1/c++/v1/iterator
+include/c++/v1/c++/v1/limits
+include/c++/v1/c++/v1/list
+include/c++/v1/c++/v1/locale
+include/c++/v1/c++/v1/map
+include/c++/v1/c++/v1/memory
+include/c++/v1/c++/v1/mutex
+include/c++/v1/c++/v1/new
+include/c++/v1/c++/v1/numeric
+include/c++/v1/c++/v1/ostream
+include/c++/v1/c++/v1/queue
+include/c++/v1/c++/v1/random
+include/c++/v1/c++/v1/ratio
+include/c++/v1/c++/v1/regex
+include/c++/v1/c++/v1/scoped_allocator
+include/c++/v1/c++/v1/set
+include/c++/v1/c++/v1/shared_mutex
+include/c++/v1/c++/v1/sstream
+include/c++/v1/c++/v1/stack
+include/c++/v1/c++/v1/stdexcept
+include/c++/v1/c++/v1/streambuf
+include/c++/v1/c++/v1/string
+include/c++/v1/c++/v1/strstream
+include/c++/v1/c++/v1/support/ibm/limits.h
+include/c++/v1/c++/v1/support/ibm/support.h
+include/c++/v1/c++/v1/support/ibm/xlocale.h
+include/c++/v1/c++/v1/support/solaris/floatingpoint.h
+include/c++/v1/c++/v1/support/solaris/wchar.h
+include/c++/v1/c++/v1/support/solaris/xlocale.h
+include/c++/v1/c++/v1/support/win32/limits_win32.h
+include/c++/v1/c++/v1/support/win32/locale_win32.h
+include/c++/v1/c++/v1/support/win32/math_win32.h
+include/c++/v1/c++/v1/support/win32/support.h
+include/c++/v1/c++/v1/system_error
+include/c++/v1/c++/v1/tgmath.h
+include/c++/v1/c++/v1/thread
+include/c++/v1/c++/v1/tuple
+include/c++/v1/c++/v1/type_traits
+include/c++/v1/c++/v1/typeindex
+include/c++/v1/c++/v1/typeinfo
+include/c++/v1/c++/v1/unordered_map
+include/c++/v1/c++/v1/unordered_set
+include/c++/v1/c++/v1/utility
+include/c++/v1/c++/v1/valarray
+include/c++/v1/c++/v1/vector
include/c++/v1/cassert
include/c++/v1/ccomplex
include/c++/v1/cctype
@@ -29,6 +143,7 @@ include/c++/v1/cinttypes
include/c++/v1/ciso646
include/c++/v1/climits
include/c++/v1/clocale
+include/c++/v1/cmake_install.cmake
include/c++/v1/cmath
include/c++/v1/codecvt
include/c++/v1/complex
@@ -47,8 +162,11 @@ include/c++/v1/ctgmath
include/c++/v1/ctime
include/c++/v1/cwchar
include/c++/v1/cwctype
+include/c++/v1/cxxabi.h
include/c++/v1/deque
include/c++/v1/exception
+include/c++/v1/experimental/dynarray
+include/c++/v1/experimental/optional
include/c++/v1/ext/__hash
include/c++/v1/ext/hash_map
include/c++/v1/ext/hash_set
@@ -78,12 +196,16 @@ include/c++/v1/ratio
include/c++/v1/regex
include/c++/v1/scoped_allocator
include/c++/v1/set
+include/c++/v1/shared_mutex
include/c++/v1/sstream
include/c++/v1/stack
include/c++/v1/stdexcept
include/c++/v1/streambuf
include/c++/v1/string
include/c++/v1/strstream
+include/c++/v1/support/ibm/limits.h
+include/c++/v1/support/ibm/support.h
+include/c++/v1/support/ibm/xlocale.h
include/c++/v1/support/solaris/floatingpoint.h
include/c++/v1/support/solaris/wchar.h
include/c++/v1/support/solaris/xlocale.h
@@ -94,21 +216,38 @@ include/c++/v1/support/win32/support.h
include/c++/v1/system_error
include/c++/v1/tgmath.h
include/c++/v1/thread
+include/c++/v1/tr1
include/c++/v1/tuple
include/c++/v1/type_traits
include/c++/v1/typeindex
include/c++/v1/typeinfo
include/c++/v1/unordered_map
include/c++/v1/unordered_set
+include/c++/v1/unwind-arm.h
+include/c++/v1/unwind-itanium.h
+include/c++/v1/unwind.h
include/c++/v1/utility
include/c++/v1/valarray
include/c++/v1/vector
lib/libc++.so
lib/libc++.so.1
lib/libc++.so.1.0
-@dirrmtry include/c++/v1/support/win32
-@dirrmtry include/c++/v1/support/solaris
-@dirrmtry include/c++/v1/support
-@dirrmtry include/c++/v1/ext
-@dirrmtry include/c++/v1
+lib/c++/libstdc++.so
+@dirrm include/c++/v1/support/win32
+@dirrm include/c++/v1/support/solaris
+@dirrm include/c++/v1/support/ibm
+@dirrm include/c++/v1/support
+@dirrm include/c++/v1/ext
+@dirrm include/c++/v1/experimental
+@dirrm include/c++/v1/c++/v1/support/win32
+@dirrm include/c++/v1/c++/v1/support/solaris
+@dirrm include/c++/v1/c++/v1/support/ibm
+@dirrm include/c++/v1/c++/v1/support
+@dirrm include/c++/v1/c++/v1/ext
+@dirrm include/c++/v1/c++/v1/experimental
+@dirrm include/c++/v1/c++/v1
+@dirrm include/c++/v1/c++
+@dirrm include/c++/v1/CMakeFiles
+@dirrm include/c++/v1
@dirrmtry include/c++
+@dirrm lib/c++