aboutsummaryrefslogtreecommitdiff
path: root/devel/libcli/files
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-05-04 04:55:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-05-04 04:55:26 +0000
commit7c175cbd613cb48bd4759b4ce5e7743cc0cb4ff5 (patch)
tree4ff997226a7154cdbaf5bca7cc8920b37709a9a4 /devel/libcli/files
parent1d278fbaaf0fa40ec06b80c4b3ca2ffd88dd3a81 (diff)
downloadports-7c175cbd613cb48bd4759b4ce5e7743cc0cb4ff5.tar.gz
ports-7c175cbd613cb48bd4759b4ce5e7743cc0cb4ff5.zip
- update to 1.9.5
Submitted by: Erik Karulf erik@karulf.com (by mail)
Notes
Notes: svn path=/head/; revision=273613
Diffstat (limited to 'devel/libcli/files')
-rw-r--r--devel/libcli/files/patch-Makefile35
-rw-r--r--devel/libcli/files/patch-clitest.c10
-rw-r--r--devel/libcli/files/patch-libcli.c10
3 files changed, 17 insertions, 38 deletions
diff --git a/devel/libcli/files/patch-Makefile b/devel/libcli/files/patch-Makefile
index 7577b5921bf7..099dab36e1b7 100644
--- a/devel/libcli/files/patch-Makefile
+++ b/devel/libcli/files/patch-Makefile
@@ -1,38 +1,37 @@
---- ./Makefile.orig 2008-10-09 04:38:01.000000000 +0200
-+++ ./Makefile 2011-05-02 23:43:52.002280937 +0200
-@@ -3,14 +3,12 @@
-
- MAJOR = 1
- MINOR = 9
--REVISION = 3
-+REVISION = 4
+--- ./Makefile.orig 2011-05-04 04:52:15.000000000 +0200
++++ ./Makefile 2011-05-04 06:51:14.794591784 +0200
+@@ -8,16 +8,14 @@
LIB = libcli.so
CC = gcc
-DEBUG = -g
-OPTIM = -O3
-CFLAGS += $(DEBUG) $(OPTIM) -Wall -Wformat-security -Wno-format-zero-length
--LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR).$(MINOR)
+CFLAGS += -Wall -Wformat-security -Wno-format-zero-length
-+LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR)$(MINOR)
+ LDFLAGS += -shared
LIBPATH += -L.
- LIBS = -lcrypt
-@@ -18,9 +16,10 @@
+ ifeq ($(UNAME),Darwin)
+ LDFLAGS += -Wl,-install_name,$(LIB).$(MAJOR).$(MINOR)
+ else
+-LDFLAGS += -Wl,-soname,$(LIB).$(MAJOR).$(MINOR)
++LDFLAGS += -Wl,-soname,$(LIB).$(MAJOR)$(MINOR)
+ LIBS = -lcrypt
+ endif
+@@ -26,8 +24,9 @@
$(LIB): libcli.o
$(CC) -o $(LIB).$(MAJOR).$(MINOR).$(REVISION) $^ $(LDFLAGS) $(LIBS)
-- -rm -f $(LIB) $(LIB).$(MAJOR).$(MINOR)
+ -rm -f $(LIB) $(LIB).$(MAJOR).$(MINOR)
- ln -s $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR)
- ln -s $(LIB).$(MAJOR).$(MINOR) $(LIB)
-+ -rm -f $(LIB) $(LIB).$(MAJOR).$(MINOR) $(LIB).$(MAJOR)$(MINOR)
-+ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR)$(MINOR)
+ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR)
-+ ln -sf $(LIB).$(MAJOR)$(MINOR) $(LIB)
++ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR)$(MINOR)
++ ln -sf $(LIB).$(MAJOR).$(MINOR) $(LIB)
%.o: %.c
$(CC) $(CPPFLAGS) $(CFLAGS) -fPIC -o $@ -c $<
-@@ -41,8 +40,9 @@
+@@ -48,8 +47,9 @@
install -m 0644 libcli.h $(DESTDIR)$(PREFIX)/include
install -m 0755 $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(DESTDIR)$(PREFIX)/lib
cd $(DESTDIR)$(PREFIX)/lib && \
@@ -40,7 +39,7 @@
- ln -s $(LIB).$(MAJOR).$(MINOR) $(LIB)
+ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR) && \
+ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR)$(MINOR) && \
-+ ln -sf $(LIB).$(MAJOR)$(MINOR) $(LIB)
++ ln -sf $(LIB).$(MAJOR).$(MINOR) $(LIB)
rpm:
mkdir libcli-$(MAJOR).$(MINOR).$(REVISION)
diff --git a/devel/libcli/files/patch-clitest.c b/devel/libcli/files/patch-clitest.c
deleted file mode 100644
index 88f645ef7bf9..000000000000
--- a/devel/libcli/files/patch-clitest.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./clitest.c.orig 2008-10-09 04:38:01.000000000 +0200
-+++ ./clitest.c 2011-05-02 23:42:29.730543145 +0200
-@@ -4,6 +4,7 @@
- #include <winsock2.h>
- #include <windows.h>
- #else
-+#include <netinet/in.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
- #endif
diff --git a/devel/libcli/files/patch-libcli.c b/devel/libcli/files/patch-libcli.c
deleted file mode 100644
index ddb982c6454b..000000000000
--- a/devel/libcli/files/patch-libcli.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./libcli.c.orig 2008-10-09 04:38:01.000000000 +0200
-+++ ./libcli.c 2011-05-02 23:42:29.732543394 +0200
-@@ -9,7 +9,6 @@
- #include <stdarg.h>
- #include <stdlib.h>
- #include <memory.h>
--#include <malloc.h>
- #include <string.h>
- #include <ctype.h>
- #include <unistd.h>