aboutsummaryrefslogtreecommitdiff
path: root/devel/libcwd
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-10-31 00:40:08 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-10-31 00:40:08 +0000
commit169b2b84da66e427a80d6178acf00b656a4b41bf (patch)
tree3c6d8a46485261df034932a52232981a33d76c52 /devel/libcwd
parent3f4e120da7e1e6782f08f10d91cbaeeaa6d5ddc9 (diff)
downloadports-169b2b84da66e427a80d6178acf00b656a4b41bf.tar.gz
ports-169b2b84da66e427a80d6178acf00b656a4b41bf.zip
- update to 0.99.39
Notes
Notes: svn path=/head/; revision=120506
Diffstat (limited to 'devel/libcwd')
-rw-r--r--devel/libcwd/Makefile24
-rw-r--r--devel/libcwd/distinfo4
-rw-r--r--devel/libcwd/files/patch-debugmalloc.cc11
-rw-r--r--devel/libcwd/pkg-plist20
4 files changed, 31 insertions, 28 deletions
diff --git a/devel/libcwd/Makefile b/devel/libcwd/Makefile
index 1d6eb25efe52..627d84b7de82 100644
--- a/devel/libcwd/Makefile
+++ b/devel/libcwd/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= libcwd
-PORTVERSION= 0.99.31
-PORTREVISION= 2
+PORTVERSION= 0.99.39
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,21 +16,27 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= The C++ Debugging Support Library
-USE_GCC= 3.3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-threading
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501103
-# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
-MAKE_ENV+= CC="${CC}" CXX="${CXX}"
+.if ${OSVERSION} < 500035
+USE_GCC= 3.4
.endif
-# dirty hack
-post-configure:
- @${CP} -f ${WRKSRC}/include/sys.ho ${WRKSRC}/include/sys.h
+post-patch:
+ @${REINPLACE_CMD} -e 's,test x"\$$libcwd_config_alloc" = x"yes",false,g' \
+ -E -e 's,^(DEFS=)(.*),\1"\2 -D__GNU_LIBRARY__=yes",g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's,localtime(,localtime((const time_t *),g' \
+ ${WRKSRC}/debugmalloc.cc
+ @${REINPLACE_CMD} -E -e 's,\$$\(libdir\)/(pkgconfig),${PREFIX}/libdata/\1,g' \
+ ${WRKSRC}/${MAKEFILE}.in
+ @${REINPLACE_CMD} -e 's,Elf32_Off,uint32_t,g' ${WRKSRC}/bfd.cc
.include <bsd.port.post.mk>
diff --git a/devel/libcwd/distinfo b/devel/libcwd/distinfo
index 112ca4ceb2c7..486942e7ebfd 100644
--- a/devel/libcwd/distinfo
+++ b/devel/libcwd/distinfo
@@ -1,2 +1,2 @@
-MD5 (libcwd-0.99.31.tar.gz) = 2effcb1dfd9e772facaa52fb338fd4aa
-SIZE (libcwd-0.99.31.tar.gz) = 961222
+MD5 (libcwd-0.99.39.tar.gz) = d337c4783d2e9343fbcbf3533db8809f
+SIZE (libcwd-0.99.39.tar.gz) = 1251627
diff --git a/devel/libcwd/files/patch-debugmalloc.cc b/devel/libcwd/files/patch-debugmalloc.cc
deleted file mode 100644
index c9756323b8d7..000000000000
--- a/devel/libcwd/files/patch-debugmalloc.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- debugmalloc.cc.orig Mon Nov 10 15:42:25 2003
-+++ debugmalloc.cc Mon Nov 10 15:50:49 2003
-@@ -1346,7 +1346,7 @@
- struct tm tbuf;
- tbuf_ptr = localtime_r(&alloc->a_time.tv_sec, &tbuf);
- #else
-- tbuf_ptr = localtime(&alloc->a_time.tv_sec);
-+ tbuf_ptr = localtime((const time_t *)&alloc->a_time.tv_sec);
- #endif
- _private_::set_invisible_off(LIBCWD_TSD);
- --LIBCWD_DO_TSD_MEMBER_OFF(debug_object);
diff --git a/devel/libcwd/pkg-plist b/devel/libcwd/pkg-plist
index 3bf6f3d98e5c..88ff42798f0b 100644
--- a/devel/libcwd/pkg-plist
+++ b/devel/libcwd/pkg-plist
@@ -1,3 +1,6 @@
+include/libcwd/sys.h
+include/libcwd/config.h
+include/libcwd/attach_gdb.h
include/libcwd/bfd.h
include/libcwd/buf2str.h
include/libcwd/char2str.h
@@ -13,22 +16,24 @@ include/libcwd/class_continued_channel.inl
include/libcwd/class_debug.h
include/libcwd/class_debug.inl
include/libcwd/class_debug_string.h
+include/libcwd/debug.h
include/libcwd/class_debug_string.inl
include/libcwd/class_fatal_channel.h
include/libcwd/class_fatal_channel.inl
+include/libcwd/class_function.h
include/libcwd/class_location.h
include/libcwd/class_location.inl
include/libcwd/class_marker.h
include/libcwd/class_object_file.h
-include/libcwd/class_ooam_filter.h
-include/libcwd/config.h
+include/libcwd/class_alloc_filter.h
+include/libcwd/class_rcfile.h
include/libcwd/control_flag.h
include/libcwd/core_dump.h
include/libcwd/cwprint.h
-include/libcwd/debug.h
include/libcwd/debugmalloc.h
include/libcwd/demangle.h
include/libcwd/enum_memblk_types.h
+include/libcwd/libraries_debug.h
include/libcwd/lockable_auto_ptr.h
include/libcwd/macro_AllocTag.h
include/libcwd/macro_ForAllDebugChannels.h
@@ -59,8 +64,11 @@ include/libcwd/set_ostream.inl
include/libcwd/smart_ptr.h
include/libcwd/strerrno.h
include/libcwd/struct_debug_tsd.h
-include/libcwd/sys.h
include/libcwd/type_info.h
-@dirrm include/libcwd
-lib/libcwd.so
lib/libcwd.so.99
+lib/libcwd.so
+libdata/pkgconfig/libcwd.pc
+libdata/pkgconfig/libcwd_r.pc
+%%DATADIR%%/libcwdrc
+@dirrm include/libcwd
+@dirrm %%DATADIR%%