aboutsummaryrefslogtreecommitdiff
path: root/devel/libdlmalloc
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-04-21 00:30:35 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-04-21 00:30:35 +0000
commit11eae40ef2363ceb774c867741958eb8809f4acc (patch)
tree1a3d6a01de1a5e344109e285a2cce2810f0243b3 /devel/libdlmalloc
parent9c52e2270b42a6b15e7d4a619df52c3592ff3f10 (diff)
downloadports-11eae40ef2363ceb774c867741958eb8809f4acc.tar.gz
ports-11eae40ef2363ceb774c867741958eb8809f4acc.zip
Upgrade to 2.6.4.
Mention that doc files are at http://g.oswego.edu/dl/html/malloc.html
Notes
Notes: svn path=/head/; revision=6255
Diffstat (limited to 'devel/libdlmalloc')
-rw-r--r--devel/libdlmalloc/Makefile12
-rw-r--r--devel/libdlmalloc/distinfo2
-rw-r--r--devel/libdlmalloc/files/Makefile12
-rw-r--r--devel/libdlmalloc/files/patch-aa82
-rw-r--r--devel/libdlmalloc/pkg-message2
5 files changed, 45 insertions, 65 deletions
diff --git a/devel/libdlmalloc/Makefile b/devel/libdlmalloc/Makefile
index 5bd96b6b2067..27a34c2e9c07 100644
--- a/devel/libdlmalloc/Makefile
+++ b/devel/libdlmalloc/Makefile
@@ -3,14 +3,14 @@
# Date created: 3 June 1995
# Whom: roberto
#
-# $Id: Makefile,v 1.3 1995/11/26 11:29:07 asami Exp $
+# $Id: Makefile,v 1.4 1996/11/18 11:22:44 asami Exp $
#
DISTNAME= dlmalloc
-PKGNAME= dlmalloc-2.5.3b
+PKGNAME= dlmalloc-2.6.4
CATEGORIES= devel
MASTER_SITES= ftp://gee.cs.oswego.edu/pub/misc/
-DISTFILES= malloc-2.5.3b.c
+DISTFILES= malloc-2.6.4.c
MAINTAINER= roberto@FreeBSD.ORG
@@ -19,9 +19,9 @@ NO_CONFIGURE= yes
do-extract:
@rm -rf ${WRKDIR}
- @mkdir -p ${WRKDIR}
- cp -p ${DISTDIR}/${DISTFILES} ${WRKDIR}
- cp -p ${FILESDIR}/Makefile ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ ${CP} -p ${DISTDIR}/${DISTFILES} ${WRKDIR}
+ ${CP} -p ${FILESDIR}/Makefile ${WRKDIR}
post-install:
ldconfig -m ${PREFIX}/lib
diff --git a/devel/libdlmalloc/distinfo b/devel/libdlmalloc/distinfo
index a3f0a33b5c5a..8905da57e022 100644
--- a/devel/libdlmalloc/distinfo
+++ b/devel/libdlmalloc/distinfo
@@ -1 +1 @@
-MD5 (malloc-2.5.3b.c) = 7936180a964854d052ae13ce6e1015d7
+MD5 (malloc-2.6.4.c) = 90829e1a88274319109f9234a05cc577
diff --git a/devel/libdlmalloc/files/Makefile b/devel/libdlmalloc/files/Makefile
index 7f9cb63fcc2b..c612752a5947 100644
--- a/devel/libdlmalloc/files/Makefile
+++ b/devel/libdlmalloc/files/Makefile
@@ -15,15 +15,15 @@
LIBDIR=${PREFIX}/lib
# for the shared lib stuff
-VERSION=2.5
+VERSION=2.6
LIBMALLOC=libdlmalloc.a
LIBSMALLOC=libdlmalloc.so.${VERSION}
-SRCS = malloc-2.5.3b.c
+SRCS = malloc-2.6.4.c
-OBJS = malloc-2.5.3b.o
-SOBJS = malloc-2.5.3b.so
+OBJS = $(SRCS:.c=.o)
+SOBJS = $(SRCS:.c=.so)
.SUFFIXES:
.SUFFIXES: .out .o .po .so .s .S .c .cc .cxx .m .C .f .y .l
@@ -55,5 +55,5 @@ install:
-$(RANLIB) $(LIBDIR)/${LIBMALLOC}
install -c -m 555 ${LIBSMALLOC} $(LIBDIR)
-malloc-2.5.3b.o: malloc-2.5.3b.c
-malloc-2.5.3b.so: malloc-2.5.3b.c
+$(OBJS): $(SRCS)
+$(SOBJS): $(SRCS)
diff --git a/devel/libdlmalloc/files/patch-aa b/devel/libdlmalloc/files/patch-aa
index ccd6dc8853e5..7a087a30f483 100644
--- a/devel/libdlmalloc/files/patch-aa
+++ b/devel/libdlmalloc/files/patch-aa
@@ -1,52 +1,30 @@
-*** malloc-2.5.3b.c.orig Sun Mar 26 10:50:54 1995
---- malloc-2.5.3b.c Fri Apr 7 19:21:29 1995
-***************
-*** 271,276 ****
---- 271,278 ----
-
- /* preliminaries */
-
-+ #include <sys/param.h>
-+
- #ifndef __STD_C
- #ifdef __STDC__
- #define __STD_C 1
-***************
-*** 1365,1373 ****
- }
-
-
--
- /* Derivatives */
-
- #if __STD_C
- Void_t* valloc(size_t bytes)
- #else
---- 1367,1375 ----
- }
-
-
- /* Derivatives */
-
-+ #if 0
- #if __STD_C
- Void_t* valloc(size_t bytes)
- #else
-***************
-*** 1394,1400 ****
- while (sz-- > 0) *q++ = 0;
- return p;
- }
-!
- #if __STD_C
- void cfree(Void_t *mem)
- #else
---- 1396,1402 ----
- while (sz-- > 0) *q++ = 0;
- return p;
- }
-! #endif
- #if __STD_C
- void cfree(Void_t *mem)
- #else
-
+--- malloc-2.6.4.c.orig Thu Nov 28 06:07:12 1996
++++ malloc-2.6.4.c Sun Apr 20 17:25:42 1997
+@@ -216,6 +216,8 @@
+
+ /* Preliminaries */
+
++#include <sys/param.h>
++
+ #ifndef __STD_C
+ #ifdef __STDC__
+ #define __STD_C 1
+@@ -495,7 +497,7 @@
+ # ifdef _SC_PAGE_SIZE
+ # define malloc_getpagesize sysconf(_SC_PAGE_SIZE)
+ # else
+-# if defined(BSD) || defined(DGUX) || defined(HAVE_GETPAGESIZE)
++# if (defined(BSD) && (BSD < 199306)) || defined(DGUX) || defined(HAVE_GETPAGESIZE)
+ extern size_t getpagesize();
+ # define malloc_getpagesize getpagesize()
+ # else
+@@ -789,7 +791,9 @@
+ #else /* INTERNAL_LINUX_C_LIB */
+
+ #if __STD_C
++# if !(defined(BSD) && (BSD >= 199306))
+ extern Void_t* sbrk(ptrdiff_t);
++# endif
+ #else
+ extern Void_t* sbrk();
+ #endif
diff --git a/devel/libdlmalloc/pkg-message b/devel/libdlmalloc/pkg-message
new file mode 100644
index 000000000000..5fef536e12d7
--- /dev/null
+++ b/devel/libdlmalloc/pkg-message
@@ -0,0 +1,2 @@
+Please see http://g.oswego.edu/dl/html/malloc.html or the distribution file
+(malloc-<ver>.c) for documenation on the use of Doug Lea's malloc library.