aboutsummaryrefslogtreecommitdiff
path: root/devel/libdsp
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-06-22 21:31:47 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-06-22 21:31:47 +0000
commitfa4afa7e0ee737b6fe11e0a1bedaa3163dc031a9 (patch)
tree70b85c3abe437d009b1cc21a4a8a11b044b028c1 /devel/libdsp
parentd91e7cbf1b68d90e5afd90cb22e78a531fd5660c (diff)
downloadports-fa4afa7e0ee737b6fe11e0a1bedaa3163dc031a9.tar.gz
ports-fa4afa7e0ee737b6fe11e0a1bedaa3163dc031a9.zip
Update to version 4.6.0
PR: 53387 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=83451
Diffstat (limited to 'devel/libdsp')
-rw-r--r--devel/libdsp/Makefile12
-rw-r--r--devel/libdsp/distinfo2
-rw-r--r--devel/libdsp/files/patch-Makefile.FreeBSD26
-rw-r--r--devel/libdsp/pkg-plist11
4 files changed, 42 insertions, 9 deletions
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 523be8d17153..de530a374752 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libdsp
-PORTVERSION= 4.4.2
+PORTVERSION= 4.6.0
CATEGORIES= devel audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -27,6 +27,12 @@ MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" MKDIR="${MKDIR}" \
MAKEFILE= Makefile.FreeBSD
INSTALLS_SHLIB= yes
-INLINE_VER= 1.2.4
+INLINE_VER= 1.2.5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+CFLAGS+= -DDSP_X86
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libdsp/distinfo b/devel/libdsp/distinfo
index eb4b56104981..73ebf966c8da 100644
--- a/devel/libdsp/distinfo
+++ b/devel/libdsp/distinfo
@@ -1 +1 @@
-MD5 (libdsp-src-4.4.2.tar.gz) = 502ad564edef99dc4b2107abd6b14ae1
+MD5 (libdsp-src-4.6.0.tar.gz) = a3cd88faaf307aa9b727a4cbbf39a151
diff --git a/devel/libdsp/files/patch-Makefile.FreeBSD b/devel/libdsp/files/patch-Makefile.FreeBSD
index 84a448dd8859..1733140d6251 100644
--- a/devel/libdsp/files/patch-Makefile.FreeBSD
+++ b/devel/libdsp/files/patch-Makefile.FreeBSD
@@ -1,5 +1,5 @@
---- Makefile.FreeBSD.orig Sat Apr 6 09:07:37 2002
-+++ Makefile.FreeBSD Wed Apr 17 02:02:45 2002
+--- Makefile.FreeBSD.bak Mon Jun 16 23:46:56 2003
++++ Makefile.FreeBSD Tue Jun 17 07:59:44 2003
@@ -17,15 +17,8 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
@@ -34,9 +34,9 @@
-PREFIX = /usr/local
+PREFIX ?= /usr/local
- VERSION = 4:0:0
+ VERSION = 5:0:4
-@@ -116,26 +109,26 @@
+@@ -143,35 +136,35 @@
$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -rpath $(PREFIX)/lib -version-info $(VERSION) -o libdsp.la $(LOBJS) $(LIBS)
install: libdsp.la
@@ -46,14 +46,23 @@
- install -m 644 dsp/DSPVector.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Decimator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FFTDecimator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/FFTInterpolator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/FFTMultiRate.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Filter.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Filter2.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FIRDecimator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/FIRInterpolator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/FIRMultiRate.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Hankel.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/IIRCascade.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/IIRDecimator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/IIRInterpolator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/IIRMultiRate.hh $(PREFIX)/include/dsp
- install -m 644 dsp/ReBuffer.hh $(PREFIX)/include/dsp
- install -m 644 dsp/ReBuffer2.hh $(PREFIX)/include/dsp
- install -m 644 dsp/ReBuffer3.hh $(PREFIX)/include/dsp
- install -m 644 dsp/RecDecimator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/RecInterpolator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Transform4.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Transform8.hh $(PREFIX)/include/dsp
- install -m 644 dsp/TransformS.hh $(PREFIX)/include/dsp
@@ -66,14 +75,23 @@
+ ${BSD_INSTALL_DATA} dsp/DSPVector.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Decimator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FFTDecimator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/FFTInterpolator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/FFTMultiRate.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Filter.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Filter2.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FIRDecimator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/FIRInterpolator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/FIRMultiRate.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Hankel.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/IIRCascade.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/IIRDecimator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/IIRInterpolator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/IIRMultiRate.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/ReBuffer.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/ReBuffer2.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/ReBuffer3.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/RecDecimator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/RecInterpolator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Transform4.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Transform8.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/TransformS.hh $(PREFIX)/include/dsp
diff --git a/devel/libdsp/pkg-plist b/devel/libdsp/pkg-plist
index 2036d26d00d9..b4f140bfd66b 100644
--- a/devel/libdsp/pkg-plist
+++ b/devel/libdsp/pkg-plist
@@ -3,14 +3,23 @@ include/dsp/DSPOp.hh
include/dsp/DSPVector.hh
include/dsp/Decimator.hh
include/dsp/FFTDecimator.hh
+include/dsp/FFTInterpolator.hh
+include/dsp/FFTMultiRate.hh
include/dsp/FIRDecimator.hh
+include/dsp/FIRInterpolator.hh
+include/dsp/FIRMultiRate.hh
include/dsp/Filter.hh
include/dsp/Filter2.hh
include/dsp/Hankel.hh
+include/dsp/IIRCascade.hh
+include/dsp/IIRDecimator.hh
+include/dsp/IIRInterpolator.hh
+include/dsp/IIRMultiRate.hh
include/dsp/ReBuffer.hh
include/dsp/ReBuffer2.hh
include/dsp/ReBuffer3.hh
include/dsp/RecDecimator.hh
+include/dsp/RecInterpolator.hh
include/dsp/Transform4.hh
include/dsp/Transform8.hh
include/dsp/TransformS.hh
@@ -20,5 +29,5 @@ include/dsp/dsptypes.h
lib/libdsp.a
lib/libdsp.la
lib/libdsp.so
-lib/libdsp.so.4
+lib/libdsp.so.5
@dirrm include/dsp