aboutsummaryrefslogtreecommitdiff
path: root/devel/libgsf/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /devel/libgsf/Makefile
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Notes
Notes: svn path=/head/; revision=147261
Diffstat (limited to 'devel/libgsf/Makefile')
-rw-r--r--devel/libgsf/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
index b76935f4dfff..7aed3c3c1b32 100644
--- a/devel/libgsf/Makefile
+++ b/devel/libgsf/Makefile
@@ -3,11 +3,12 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/devel/libgsf/Makefile,v 1.17 2005/10/11 22:08:17 marcus Exp $
#
PORTNAME= libgsf
-PORTVERSION= 1.11.1
-PORTREVISION?= 1
+PORTVERSION= 1.13.2
+PORTREVISION?= 0
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -20,14 +21,21 @@ COMMENT?= An extensible i/o abstraction for dealing with structured file formats
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
+USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_GNOME?= gnomehack glib20 libxml2
-USE_LIBTOOL_VER=15
+USE_GNOME?= gnomehack glib20 libxml2 gconf2 ltverhack intlhack
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc --without-gnome --with-bz2
+ --disable-gtk-doc --without-gnome --with-bz2 \
+ --mandir=${PREFIX}/man
CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(GSF_SLAVE)
+GCONF_SCHEMAS= gsf-office-thumbnailer.schemas
+MAN1= gsf-office-thumbnailer.1
+.endif
+
.include <bsd.port.mk>