aboutsummaryrefslogtreecommitdiff
path: root/devel/libkolab/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /devel/libkolab/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'devel/libkolab/Makefile')
-rw-r--r--devel/libkolab/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/libkolab/Makefile b/devel/libkolab/Makefile
index 100505fd8063..577876b3bb81 100644
--- a/devel/libkolab/Makefile
+++ b/devel/libkolab/Makefile
@@ -25,10 +25,10 @@ CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
-DPHP_BINDINGS:BOOL=OFF \
-DPYTHON_BINDINGS:BOOL=OFF \
-DUSE_LIBCALENDARING:BOOL=OFF
-USES= cmake:outsource kde:4
+USES= cmake:outsource kde:4 qt:4
USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
-USE_QT4= corelib dbus gui network svg xml \
+USE_QT= corelib dbus gui network svg xml \
moc_build qmake_build rcc_build uic_build
# Fix build of desktuils/kdepim4-runtime:
CXXFLAGS+= -DMAKE_KOLAB_LIB