aboutsummaryrefslogtreecommitdiff
path: root/devel/libmimedir
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-02-05 23:19:37 +0000
committerJohn Marino <marino@FreeBSD.org>2014-02-05 23:19:37 +0000
commit0524dc636870a1c50853d66250b87aea17e3b6a2 (patch)
treea10ec70fd08c64fd41765c851867153b1c42ba93 /devel/libmimedir
parent0e9bde09302bbe976f02539dd41bc328b92947fe (diff)
downloadports-0524dc636870a1c50853d66250b87aea17e3b6a2.tar.gz
ports-0524dc636870a1c50853d66250b87aea17e3b6a2.zip
devel/libmimedir: Add dragonfly support in configure script
Notes
Notes: svn path=/head/; revision=342895
Diffstat (limited to 'devel/libmimedir')
-rw-r--r--devel/libmimedir/Makefile2
-rw-r--r--devel/libmimedir/files/patch-configure99
2 files changed, 101 insertions, 0 deletions
diff --git a/devel/libmimedir/Makefile b/devel/libmimedir/Makefile
index 8768bf37125a..3f0c99e6fcef 100644
--- a/devel/libmimedir/Makefile
+++ b/devel/libmimedir/Makefile
@@ -13,6 +13,8 @@ USES= bison desthack libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE=yes
+
post-patch:
${REINPLACE_CMD} -e 's/444/644/g' ${WRKSRC}/Makefile.in
diff --git a/devel/libmimedir/files/patch-configure b/devel/libmimedir/files/patch-configure
new file mode 100644
index 000000000000..d3cbe5b0dc4e
--- /dev/null
+++ b/devel/libmimedir/files/patch-configure
@@ -0,0 +1,99 @@
+--- configure.orig 2005-10-13 16:31:51.000000000 -0500
++++ configure
+@@ -3298,13 +3298,13 @@ darwin* | rhapsody*)
+ lt_cv_deplibs_check_method=pass_all
+ ;;
+
+-freebsd* | kfreebsd*-gnu)
++dragonfly* | freebsd* | kfreebsd*-gnu)
+ if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+ case $host_cpu in
+ i*86 )
+ # Not sure whether the presence of OpenBSD here was a mistake.
+ # Let's accept both of them until this is cleared up.
+- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD)/i[3-9]86 (compact )?demand paged shared library'
++ lt_cv_deplibs_check_method='file_magic (FreeBSD|DragonFly|OpenBSD)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_file_magic_cmd=/usr/bin/file
+ lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
+ ;;
+@@ -6879,7 +6879,7 @@ if test -z "$aix_libpath"; then aix_libp
+ ;;
+
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ archive_cmds='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
+ hardcode_libdir_flag_spec='-R$libdir'
+ hardcode_direct=yes
+@@ -7457,7 +7457,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly*|freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in
+@@ -9837,7 +9837,7 @@ if test -z "$aix_libpath"; then aix_libp
+ freebsd-elf*)
+ archive_cmds_need_lc_CXX=no
+ ;;
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ # FreeBSD 3 and later use GNU C++ and GNU ld with standard ELF
+ # conventions
+ ld_shlibs_CXX=yes
+@@ -10548,7 +10548,7 @@ echo $ECHO_N "checking for $compiler opt
+ ;;
+ esac
+ ;;
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ # FreeBSD uses GNU C++
+ ;;
+ hpux9* | hpux10* | hpux11*)
+@@ -11159,7 +11159,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly*|freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in
+@@ -13730,7 +13730,7 @@ if test -z "$aix_libpath"; then aix_libp
+ ;;
+
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ archive_cmds_F77='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
+ hardcode_libdir_flag_spec_F77='-R$libdir'
+ hardcode_direct_F77=yes
+@@ -14308,7 +14308,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly*|freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in
+@@ -16081,7 +16081,7 @@ if test -z "$aix_libpath"; then aix_libp
+ ;;
+
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ archive_cmds_GCJ='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
+ hardcode_libdir_flag_spec_GCJ='-R$libdir'
+ hardcode_direct_GCJ=yes
+@@ -16659,7 +16659,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly*|freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in