aboutsummaryrefslogtreecommitdiff
path: root/devel/libmowgli
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-09-13 20:05:55 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-09-13 20:05:55 +0000
commit036759133ddc11a84816409a8b33276b766bf306 (patch)
tree0b3fe6218a9de9b573d31c9281a9f6944b7e0d63 /devel/libmowgli
parentac5990f45002afd03e583eed03d9908d95db71e4 (diff)
downloadports-036759133ddc11a84816409a8b33276b766bf306.tar.gz
ports-036759133ddc11a84816409a8b33276b766bf306.zip
adding libmowgli which will be used in future versions of multimedia/audacious
mowgli is a development framework for C (like GLib), which provides high performance and highly flexible algorithms. It can be used as a suppliment to GLib (to add additional functions (dictionaries, hashes), or replace some of the slow GLib list manipulation functions), or stand alone. It also provides a powerful hook system and convenient logging for your code, as well as a high performance block allocator.
Notes
Notes: svn path=/head/; revision=199430
Diffstat (limited to 'devel/libmowgli')
-rw-r--r--devel/libmowgli/Makefile26
-rw-r--r--devel/libmowgli/distinfo3
-rw-r--r--devel/libmowgli/pkg-descr8
-rw-r--r--devel/libmowgli/pkg-plist36
4 files changed, 73 insertions, 0 deletions
diff --git a/devel/libmowgli/Makefile b/devel/libmowgli/Makefile
new file mode 100644
index 000000000000..3f9557d8a863
--- /dev/null
+++ b/devel/libmowgli/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libmowgli
+# Date Created: 06 Sep 2007
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmowgli
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+MASTER_SITES= http://distfiles.atheme.org/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A development framework for C
+
+MAKE_ENV+= VERBOSE=1
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's|$$(LIBDIR)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libmowgli/distinfo b/devel/libmowgli/distinfo
new file mode 100644
index 000000000000..0d27f36dfaa4
--- /dev/null
+++ b/devel/libmowgli/distinfo
@@ -0,0 +1,3 @@
+MD5 (libmowgli-0.4.0.tgz) = 46b03e8ac00bb49a6db9695d1c143aff
+SHA256 (libmowgli-0.4.0.tgz) = 083f367ba6472c68c736d1af2f5754a1905130988257c764011c91db6e82e8fe
+SIZE (libmowgli-0.4.0.tgz) = 106528
diff --git a/devel/libmowgli/pkg-descr b/devel/libmowgli/pkg-descr
new file mode 100644
index 000000000000..c03aa0fe9a6d
--- /dev/null
+++ b/devel/libmowgli/pkg-descr
@@ -0,0 +1,8 @@
+mowgli is a development framework for C (like GLib), which provides high
+performance and highly flexible algorithms. It can be used as a suppliment
+to GLib (to add additional functions (dictionaries, hashes), or replace
+some of the slow GLib list manipulation functions), or stand alone. It
+also provides a powerful hook system and convenient logging for your code,
+as well as a high performance block allocator.
+
+WWW: http://sacredspiral.co.uk/~nenolod/mowgli/
diff --git a/devel/libmowgli/pkg-plist b/devel/libmowgli/pkg-plist
new file mode 100644
index 000000000000..5e69ce0368dd
--- /dev/null
+++ b/devel/libmowgli/pkg-plist
@@ -0,0 +1,36 @@
+include/libmowgli/mowgli.h
+include/libmowgli/mowgli_alloc.h
+include/libmowgli/mowgli_argstack.h
+include/libmowgli/mowgli_assert.h
+include/libmowgli/mowgli_bitvector.h
+include/libmowgli/mowgli_config.h
+include/libmowgli/mowgli_dictionary.h
+include/libmowgli/mowgli_error_backtrace.h
+include/libmowgli/mowgli_exception.h
+include/libmowgli/mowgli_formatter.h
+include/libmowgli/mowgli_global_storage.h
+include/libmowgli/mowgli_hash.h
+include/libmowgli/mowgli_heap.h
+include/libmowgli/mowgli_hook.h
+include/libmowgli/mowgli_init.h
+include/libmowgli/mowgli_ioevent.h
+include/libmowgli/mowgli_iterator.h
+include/libmowgli/mowgli_list.h
+include/libmowgli/mowgli_logger.h
+include/libmowgli/mowgli_mempool.h
+include/libmowgli/mowgli_module.h
+include/libmowgli/mowgli_object.h
+include/libmowgli/mowgli_object_class.h
+include/libmowgli/mowgli_object_messaging.h
+include/libmowgli/mowgli_object_metadata.h
+include/libmowgli/mowgli_queue.h
+include/libmowgli/mowgli_random.h
+include/libmowgli/mowgli_signal.h
+include/libmowgli/mowgli_spinlock.h
+include/libmowgli/mowgli_stdinc.h
+include/libmowgli/mowgli_string.h
+lib/libmowgli.so
+lib/libmowgli.so.1
+lib/libmowgli.so.1.0.0
+libdata/pkgconfig/libmowgli.pc
+@dirrm include/libmowgli