aboutsummaryrefslogtreecommitdiff
path: root/devel/liboil/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2004-11-28 18:46:47 +0000
committerKoop Mast <kwm@FreeBSD.org>2004-11-28 18:46:47 +0000
commit2c6ac14ece8f283f2b920a1d9e5567b985518edf (patch)
tree42dc05e66ba1f576dd46ea1bfa3aaca0cd2ba6d0 /devel/liboil/Makefile
parent65292a27dc0df89ba8024f0509cd138f35625bb8 (diff)
downloadports-2c6ac14ece8f283f2b920a1d9e5567b985518edf.tar.gz
ports-2c6ac14ece8f283f2b920a1d9e5567b985518edf.zip
Add liboil a library of simple functions that are optimized for various CPUs.
These functions are generally loops implementing simple algorithmes. Grab maintainer-ship PR: 74361 Submitted by: ijliao Approved by: pav (mentor)
Notes
Notes: svn path=/head/; revision=122680
Diffstat (limited to 'devel/liboil/Makefile')
-rw-r--r--devel/liboil/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
new file mode 100644
index 000000000000..5207be706e17
--- /dev/null
+++ b/devel/liboil/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: liboil
+# Date created: Nov 24, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboil
+PORTVERSION= 0.2.2
+CATEGORIES= devel
+MASTER_SITES= http://www.schleef.org/liboil/download/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library of optimized inner loops
+
+USE_GNOME= gnomeprefix glib20
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+
+PLIST_SUB= VERSION=${PORTVERSION:R}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|g' \
+ ${WRKSRC}/liboil/liboiltypes.h \
+ ${WRKSRC}/liboil/liboil.h
+
+.include <bsd.port.mk>