aboutsummaryrefslogtreecommitdiff
path: root/devel/libpci
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-11 01:03:12 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-11 01:03:12 +0000
commit52b9d0798e733a8998bb321a3e8ab1be73020798 (patch)
treefb69108425d720ca69a44f323bb60e77c1b46c8c /devel/libpci
parent38a54c664df1568fc6a8dda0e42788b22cb9335e (diff)
downloadports-52b9d0798e733a8998bb321a3e8ab1be73020798.tar.gz
ports-52b9d0798e733a8998bb321a3e8ab1be73020798.zip
- Update to 3.1.7
Approved by: miwi (mentor) via irc.
Notes
Notes: svn path=/head/; revision=250882
Diffstat (limited to 'devel/libpci')
-rw-r--r--devel/libpci/Makefile3
-rw-r--r--devel/libpci/distinfo6
-rw-r--r--devel/libpci/files/patch-lib::Makefile12
-rw-r--r--devel/libpci/files/pci.h18
4 files changed, 20 insertions, 19 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 71ed343f15d7..92bf37f21473 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libpci
-PORTVERSION= 2.2.8
-PORTREVISION= 1
+PORTVERSION= 3.1.7
CATEGORIES= devel
MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
${MASTER_SITE_KERNEL_ORG} \
diff --git a/devel/libpci/distinfo b/devel/libpci/distinfo
index 700d6e67cc90..bd3d6511dcbe 100644
--- a/devel/libpci/distinfo
+++ b/devel/libpci/distinfo
@@ -1,3 +1,3 @@
-MD5 (pciutils-2.2.8.tar.gz) = c0b742521a13ef624b9a0a237f46c1c8
-SHA256 (pciutils-2.2.8.tar.gz) = 8bdbcac28a80e05799c3e788bbb24417059537aff53b8bf16c7c8e08b3979fa2
-SIZE (pciutils-2.2.8.tar.gz) = 232602
+MD5 (pciutils-3.1.7.tar.gz) = f3e349d22a3714b4272b171649ad5235
+SHA256 (pciutils-3.1.7.tar.gz) = 0f39818eabd793bb48d5b98ca52141d8247306a85876482c0075d0c95aeccea2
+SIZE (pciutils-3.1.7.tar.gz) = 320603
diff --git a/devel/libpci/files/patch-lib::Makefile b/devel/libpci/files/patch-lib::Makefile
index c91be38b8d03..5496c4b59d1b 100644
--- a/devel/libpci/files/patch-lib::Makefile
+++ b/devel/libpci/files/patch-lib::Makefile
@@ -1,10 +1,10 @@
---- lib/Makefile.orig Thu Dec 26 22:28:33 2002
-+++ lib/Makefile Sat Jun 28 05:39:36 2003
-@@ -56,6 +56,7 @@
+--- lib/Makefile.orig 2009-07-04 13:11:04.000000000 -0300
++++ lib/Makefile 2010-03-08 19:39:24.000000000 -0300
+@@ -49,6 +49,7 @@
rm -f $@
$(AR) rcs $@ $^
$(RANLIB) $@
+ $(CC) $(CFLAGS) -shared $^ -o libpci.so
-
- $(PCILIBPC): $(PCILIBPC).in
- sed <$< >$@ -e 's,@PREFIX@,$(PREFIX),' \
+ else
+ CFLAGS += -fPIC -fvisibility=hidden
+ $(PCILIB): $(addsuffix .o,$(OBJS))
diff --git a/devel/libpci/files/pci.h b/devel/libpci/files/pci.h
index 0fe2171edf89..4b41825cffc2 100644
--- a/devel/libpci/files/pci.h
+++ b/devel/libpci/files/pci.h
@@ -1,15 +1,17 @@
---- lib/pci.h.orig Thu Oct 30 15:57:58 2003
-+++ lib/pci.h Thu Oct 30 16:04:23 2003
-@@ -9,9 +9,9 @@
- #ifndef _PCI_LIB_H
+--- lib/pci.h.orig 2009-07-04 13:11:04.000000000 -0300
++++ lib/pci.h 2010-03-08 19:46:36.000000000 -0300
+@@ -10,11 +10,11 @@
#define _PCI_LIB_H
+ #ifndef PCI_CONFIG_H
-#include "config.h"
++#include "pci/config.h"
+ #endif
+
-#include "header.h"
-#include "types.h"
-+#include <pci/config.h>
-+#include <pci/header.h>
-+#include <pci/types.h>
++#include "pci/header.h"
++#include "pci/types.h"
- #define PCI_LIB_VERSION 0x020204
+ #define PCI_LIB_VERSION 0x030100