aboutsummaryrefslogtreecommitdiff
path: root/devel/libpci
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-07 10:43:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-07 10:43:43 +0000
commit579968fc95a2ff8d7b1c7b63db8fb906e90d586b (patch)
tree4ab96f96f875fdbeda7a0b6750c2c70c38b2c029 /devel/libpci
parent34a6b591314348e80178cccb86174023af9107d2 (diff)
downloadports-579968fc95a2ff8d7b1c7b63db8fb906e90d586b.tar.gz
ports-579968fc95a2ff8d7b1c7b63db8fb906e90d586b.zip
- Build libpci.so with libz (-lz)
- Bump PORTREVISION for package change Reported by: olgeni
Notes
Notes: svn path=/head/; revision=283110
Diffstat (limited to 'devel/libpci')
-rw-r--r--devel/libpci/Makefile1
-rw-r--r--devel/libpci/files/patch-lib::Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index f1f445fb52d6..2938678ad391 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libpci
PORTVERSION= 3.1.8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
LOCAL/sunpoet
diff --git a/devel/libpci/files/patch-lib::Makefile b/devel/libpci/files/patch-lib::Makefile
index 5496c4b59d1b..6cace9d07d1f 100644
--- a/devel/libpci/files/patch-lib::Makefile
+++ b/devel/libpci/files/patch-lib::Makefile
@@ -4,7 +4,7 @@
rm -f $@
$(AR) rcs $@ $^
$(RANLIB) $@
-+ $(CC) $(CFLAGS) -shared $^ -o libpci.so
++ $(CC) $(CFLAGS) -shared $^ -lz -o libpci.so
else
CFLAGS += -fPIC -fvisibility=hidden
$(PCILIB): $(addsuffix .o,$(OBJS))