aboutsummaryrefslogtreecommitdiff
path: root/devel/libpeas/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-04-24 06:41:25 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-04-24 06:41:25 +0000
commitb96ce883df6651091b49d90d4bea0e43bd4b020b (patch)
tree29865d4bda84b4a08eb36795ad28a501a6cbd560 /devel/libpeas/Makefile
parent819a1fb35f4197d5a3a1b4026c37c12083af249a (diff)
downloadports-b96ce883df6651091b49d90d4bea0e43bd4b020b.tar.gz
ports-b96ce883df6651091b49d90d4bea0e43bd4b020b.zip
Add libpeas 1.6.1.
Libpeas is a gobject-based plugins engine. Obtained from: GNOME team repo, based on patch by Gustau Perez
Notes
Notes: svn path=/head/; revision=316403
Diffstat (limited to 'devel/libpeas/Makefile')
-rw-r--r--devel/libpeas/Makefile71
1 files changed, 71 insertions, 0 deletions
diff --git a/devel/libpeas/Makefile b/devel/libpeas/Makefile
new file mode 100644
index 000000000000..14cee6e08edd
--- /dev/null
+++ b/devel/libpeas/Makefile
@@ -0,0 +1,71 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/devel/libpeas/Makefile 17268 2013-04-01 05:13:11Z marcus $
+
+PORTNAME= libpeas
+PORTVERSION= 1.6.1
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Next evolution of the Gedit plugins engine
+
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection \
+ valac:${PORTSDIR}/lang/vala
+
+USE_XZ= yes
+USE_PYTHON= 2.5+
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
+USES= pathfix
+USE_GNOME= glib20 gtk30 ltverhack
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+=--disable-glade-catalog
+
+OPTIONS_DEFINE= PYTHON JS
+OPTIONS_DEFAULT=PYTHON JS GJS
+OPTIONS_MULTI= JS
+OPTIONS_MULTI_JS=SEED GJS
+JS_DESC=JavaScript plugin support
+SEED_DESC= JavaScript support based on webkit-gtk3
+GJS_DESC= JavaScript support based on spidermonkey
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSEED}
+CONFIGURE_ARGS+=--enable-seed=yes
+LIB_DEPENDS= seed-gtk3:${PORTSDIR}/devel/seed3
+PLIST_SUB+= SEED=""
+.else
+CONFIGURE_ARGS+=--enable-seed=no
+PLIST_SUB+= SEED="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPYTHON}
+CONFIGURE_ARGS+=--enable-python
+USE_GNOME+= pygobject3
+PLIST_SUB+= PYTHONS=""
+.else
+CONFIGURE_ARGS+=--enable-python=no
+PLIST_SUB+= PYTHONS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGJS}
+CONFIGURE_ARGS+=--enable-gjs
+BUILD_DEPENDS+= gjs>=1.32.0:${PORTSDIR}/lang/gjs
+LIB_DEPENDS+= gjs:${PORTSDIR}/lang/gjs
+PLIST_SUB+= GJS=""
+.else
+CONFIGURE_ARGS+=--enable-gjs=no
+PLIST_SUB+= GJS="@comment "
+.endif
+
+PLIST_SUB+= VALA="@comment "
+
+.include <bsd.port.mk>