aboutsummaryrefslogtreecommitdiff
path: root/devel/librcc
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-01-15 12:52:57 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-01-15 12:52:57 +0000
commit4f6eca8ec5d9bd9f3e257248d3ab31e373dc4f33 (patch)
tree7b63dfca5d64e4ff3e319fad26f53232ad8f953f /devel/librcc
parentaf39f77ee7f5d39d9086d9b1d5d2db9d8f29fc00 (diff)
downloadports-4f6eca8ec5d9bd9f3e257248d3ab31e373dc4f33.tar.gz
ports-4f6eca8ec5d9bd9f3e257248d3ab31e373dc4f33.zip
- Add option to install GUI configuretion utility for librcc
- Disable BDB/LibTranslate support by default, it causes breakages in depended apps at i386 only [1] Noticed by: myself, Alberto Villa, Alexander Yerenkow, David Johnson [1] Approved by: miwi, tabthorpe (mentors implicit)
Notes
Notes: svn path=/head/; revision=247939
Diffstat (limited to 'devel/librcc')
-rw-r--r--devel/librcc/Makefile23
-rw-r--r--devel/librcc/files/extrapatch-rcc-config23
-rw-r--r--devel/librcc/pkg-plist2
3 files changed, 45 insertions, 3 deletions
diff --git a/devel/librcc/Makefile b/devel/librcc/Makefile
index 0441ff767152..7cf7a20e2018 100644
--- a/devel/librcc/Makefile
+++ b/devel/librcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= librcc
PORTVERSION= 0.2.9
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/rusxmms/Charset%20Conversion%20Library/${PORTVERSION} \
http://dside.dyndns.org/files/rusxmms/
@@ -29,9 +30,10 @@ USE_AUTOTOOLS= autoheader:262
CPPFLAGS= -I${LOCALBASE}/include
LIBS= -L${LOCALBASE}/lib
-OPTIONS= BDB "Translation database support" on \
- TRANSLATE "Online translation support" on \
- GTK2 "Gtk+2 frontend" on
+OPTIONS= BDB "Translation database support" off \
+ TRANSLATE "Online translation support" off \
+ TOOLS "Install recode configuration utility" on \
+ GTK2 "Use Gtk2 library/frontend" on
.include <bsd.port.options.mk>
@@ -59,8 +61,23 @@ CONFIGURE_ARGS+=--disable-glib1 --disable-gtk1
PLIST_SUB+= WITH_GTK2="@comment "
.endif
+.if defined(WITH_TOOLS)
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-rcc-config
+PLIST_SUB+= TOOLS=""
+.else
+PLIST_SUB+= TOOLS="@comment "
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LIBS="${LIBS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+pre-everything::
+.if ${ARCH} == "i386"
+.if defined(WITH_BDB) || defined (WITH_TRANSLATE)
+ @${ECHO} 'BDB/LibTranslate support may cause breakages in depended apps on ${ARCH}'
+ @${ECHO} 'Use it with caution'
+.endif
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/librcc/files/extrapatch-rcc-config b/devel/librcc/files/extrapatch-rcc-config
new file mode 100644
index 000000000000..80c7e5c3734c
--- /dev/null
+++ b/devel/librcc/files/extrapatch-rcc-config
@@ -0,0 +1,23 @@
+--- Makefile.in.orig 2009-10-11 10:58:12.000000000 +1100
++++ Makefile.in 2010-01-13 00:18:18.951041257 +1000
+@@ -223,7 +223,7 @@
+ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = src engines external ui
++SUBDIRS = src engines external ui examples
+ EXTRA_DIST = librcd.spec
+ ACLOCAL_AMFLAGS = -I m4
+ all: config.h
+--- examples/Makefile.in.orig 2009-10-11 10:58:12.000000000 +1100
++++ examples/Makefile.in 2010-01-13 00:16:51.098228400 +1000
+@@ -31,8 +31,7 @@
+ POST_UNINSTALL = :
+ build_triplet = @build@
+ host_triplet = @host@
+-bin_PROGRAMS = example1$(EXEEXT) example2$(EXEEXT) $(am__EXEEXT_1) \
+- $(am__EXEEXT_2)
++bin_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2)
+ @HAVE_GTK_TRUE@am__append_1 = rcc-gtk-config
+ @HAVE_GTK2_TRUE@am__append_2 = rcc-gtk2-config
+ subdir = examples
diff --git a/devel/librcc/pkg-plist b/devel/librcc/pkg-plist
index adba243a1cd8..aea070e46f92 100644
--- a/devel/librcc/pkg-plist
+++ b/devel/librcc/pkg-plist
@@ -1,3 +1,5 @@
+%%TOOLS%%bin/rcc-gtk-config
+%%TOOLS%%%%WITH_GTK2%%bin/rcc-gtk2-config
include/librcc.h
include/librccui.h
lib/librcc.a