aboutsummaryrefslogtreecommitdiff
path: root/devel/libunistring/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-08-08 13:29:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-08-08 13:29:34 +0000
commit6a0617331902b6b2b0d45d0977a3d34a67458c5c (patch)
treec8c10bdcc04f26c46548cb4868c60abfb570be97 /devel/libunistring/Makefile
parente5e0c4b33235b0691f9927278e7ee1c822154e47 (diff)
downloadports-6a0617331902b6b2b0d45d0977a3d34a67458c5c.tar.gz
ports-6a0617331902b6b2b0d45d0977a3d34a67458c5c.zip
GNU LIBUNISTRING - Unicode string library
This library provides functions for manipulating Unicode strings and for manipulating C strings according to the Unicode standard. WWW: http://www.gnu.org/software/libunistring/ PR: ports/157172 Submitted by: Takefu <takefu@airport.fm>
Notes
Notes: svn path=/head/; revision=279222
Diffstat (limited to 'devel/libunistring/Makefile')
-rw-r--r--devel/libunistring/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/libunistring/Makefile b/devel/libunistring/Makefile
new file mode 100644
index 000000000000..173188c5ffb4
--- /dev/null
+++ b/devel/libunistring/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libunistring
+# Date created: 2011-05-17
+# Whom: Takefu
+#
+# $FreeBSD$
+#
+
+PORTNAME= libunistring
+PORTVERSION= 0.9.3
+CATEGORIES= devel
+MASTER_SITES= GNU
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Unicode string library
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
+
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INFO= ${PORTNAME}
+
+pre-patch:
+.if defined(NOPORTDOCS)
+ cd ${WRKSRC}/doc && ${REINPLACE_CMD}\
+ -e 's!install-data-local:!#install-data-local:!' Makefile.in
+.endif
+
+.include <bsd.port.mk>